aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-02-11 20:25:13 +0800
committernovel <novel@FreeBSD.org>2006-02-11 20:25:13 +0800
commit473f6e1912bcdff452e0e127e504e3adb117c3c9 (patch)
tree8ce07d510252b70e19c92f3f0d27b8dd7f5e07fd /net
parent45c23fb52e43859c6ce212b9b786c4c992010a62 (diff)
downloadfreebsd-ports-gnome-473f6e1912bcdff452e0e127e504e3adb117c3c9.tar.gz
freebsd-ports-gnome-473f6e1912bcdff452e0e127e504e3adb117c3c9.tar.zst
freebsd-ports-gnome-473f6e1912bcdff452e0e127e504e3adb117c3c9.zip
(Re)add gotthard 1.3, ssh through https proxy tunnel.
PR: ports/93177 Submitted by: Anton Karpov <toxa@toxahost.ru>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/gotthard/Makefile25
-rw-r--r--net/gotthard/distinfo3
-rw-r--r--net/gotthard/pkg-descr3
-rw-r--r--net/gotthard/pkg-plist3
5 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 608fa8564d24..729c54b05339 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -157,6 +157,7 @@
SUBDIR += gofish
SUBDIR += googolplex
SUBDIR += gopher
+ SUBDIR += gotthard
SUBDIR += gq
SUBDIR += grdesktop
SUBDIR += gsk
diff --git a/net/gotthard/Makefile b/net/gotthard/Makefile
new file mode 100644
index 000000000000..b7ef40250ad3
--- /dev/null
+++ b/net/gotthard/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gotthard
+# Date created: 11 Feb 2006
+# Whom: Anton Karpov <toxa@toxahost.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gotthard
+PORTVERSION= 1.3
+CATEGORIES= net
+MASTER_SITES= http://www.nazgul.ch/dev/
+
+MAINTAINER= toxa@toxahost.ru
+COMMENT= Ssh through https proxy tunnel
+
+MAN8= gotthard.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gotthard ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/gotthard.8 ${PREFIX}/man/man8
+ ${INSTALL_DATA} ${WRKSRC}/gotthard.conf ${PREFIX}/etc/gotthard.conf.sample
+ [ -f ${PREFIX}/etc/gotthard.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/gotthard.conf ${PREFIX}/etc
+
+.include <bsd.port.mk>
diff --git a/net/gotthard/distinfo b/net/gotthard/distinfo
new file mode 100644
index 000000000000..f16ffd77ccbb
--- /dev/null
+++ b/net/gotthard/distinfo
@@ -0,0 +1,3 @@
+MD5 (gotthard-1.3.tar.gz) = 99161ac721490e372c68869bd81b5079
+SHA256 (gotthard-1.3.tar.gz) = a37b64b5278049fd9520cf3448c7e07d35c6ed15492d38889c3b4f3fe3f2eb0d
+SIZE (gotthard-1.3.tar.gz) = 6887
diff --git a/net/gotthard/pkg-descr b/net/gotthard/pkg-descr
new file mode 100644
index 000000000000..5902ca9065d3
--- /dev/null
+++ b/net/gotthard/pkg-descr
@@ -0,0 +1,3 @@
+gotthard is a daemon which tunnels ssh sessions through a https proxy.
+
+WWW: http://www.nazgul.ch/dev.html
diff --git a/net/gotthard/pkg-plist b/net/gotthard/pkg-plist
new file mode 100644
index 000000000000..ddc0a2daa463
--- /dev/null
+++ b/net/gotthard/pkg-plist
@@ -0,0 +1,3 @@
+bin/gotthard
+@unexec if cmp -s %D/etc/gotthard.conf %D/etc/gotthard.conf.sample; then rm -f %D/etc/gotthard.conf; fi
+etc/gotthard.conf.sample