aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2003-07-29 12:26:22 +0800
committerlofi <lofi@FreeBSD.org>2003-07-29 12:26:22 +0800
commit479d487f0145cf1c6b055c0575361c5350c135ac (patch)
treecd6b53895ab84f4324ba042d08f921529be4ca55 /net
parent1e8eb5e8be1b2d96efca243817309906398909d6 (diff)
downloadfreebsd-ports-gnome-479d487f0145cf1c6b055c0575361c5350c135ac.tar.gz
freebsd-ports-gnome-479d487f0145cf1c6b055c0575361c5350c135ac.tar.zst
freebsd-ports-gnome-479d487f0145cf1c6b055c0575361c5350c135ac.zip
Update KDE to the latest official release, KDE 3.1.3
Official KDE 3.1.3 announcement: http://www.kde.org/announcements/announce-3.1.3.php (may not work until a few hours after this commit - we jumped the gun a little in order to have the update in place at the time the security notifications for KDE 3.1.2 will be released together with the announcement of KDE 3.1.3). Changelog from 3.1.2 to 3.1.3 release: http://www.kde.org/announcements/changelogs/changelog3_1_2to3_1_3.php Thanks and credits need to go to the whole KDE-FreeBSD team, as well as everyone on kde@freebsd.org for providing feedback, reporting bugs and just using the KDE ports. Approved by: will (real mentor asleep)
Diffstat (limited to 'net')
-rw-r--r--net/kdenetwork3/Makefile13
-rw-r--r--net/kdenetwork3/distinfo2
-rw-r--r--net/kdenetwork3/files/patch-kmime_util.cpp27
-rw-r--r--net/kdenetwork3/files/plist.base4
-rw-r--r--net/kdenetwork4/Makefile13
-rw-r--r--net/kdenetwork4/distinfo2
-rw-r--r--net/kdenetwork4/files/patch-kmime_util.cpp27
-rw-r--r--net/kdenetwork4/files/plist.base4
8 files changed, 24 insertions, 68 deletions
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index 241282d93acc..1529b7a734ea 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -8,7 +8,6 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
CATEGORIES?= net news kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${KDE_VERSION}/src
@@ -25,18 +24,25 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+pre-configure::
+ ${REINPLACE_CMD} -e 's@-pedantic @@g' ${WRKSRC}/configure
+
.if !defined(WITHOUT_KTALKD)
UTMP?= /var/run/utmp
.if exists(${UTMP})
PLIST_APPEND+= plist.ktalkd
.else
DO_NOT_COMPILE+= ktalkd
-pre-configure:
+pre-configure::
@${ECHO_MSG} "===> \"${UTMP}\" was not found."
@${ECHO_MSG} "===> The talk daemon (ktalkd) will not be built."
.endif # exists(${UTMP})
@@ -48,5 +54,4 @@ DO_NOT_COMPILE+= ktalkd
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/kdenetwork3/distinfo b/net/kdenetwork3/distinfo
index 6b6106686dba..b9b2902567ae 100644
--- a/net/kdenetwork3/distinfo
+++ b/net/kdenetwork3/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdenetwork-3.1.2.tar.bz2) = baf7663463d9e85a96d5c5143ef2b4be
+MD5 (KDE/kdenetwork-3.1.3.tar.bz2) = 18b1a274575eddf053dd6e72ad5554c7
diff --git a/net/kdenetwork3/files/patch-kmime_util.cpp b/net/kdenetwork3/files/patch-kmime_util.cpp
deleted file mode 100644
index 30213c8f9eab..000000000000
--- a/net/kdenetwork3/files/patch-kmime_util.cpp
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: libkdenetwork/kmime_util.cpp
-===================================================================
-RCS file: /home/kde/kdenetwork/libkdenetwork/Attic/kmime_util.cpp,v
-retrieving revision 1.16.2.1
-diff -u -5 -p -d -r1.16.2.1 kmime_util.cpp
---- libkdenetwork/kmime_util.cpp 13 Dec 2002 09:31:38 -0000 1.16.2.1
-+++ libkdenetwork/kmime_util.cpp 25 Jun 2003 19:42:06 -0000
-@@ -646,17 +646,13 @@ DateFormatter::zone(time_t otime) const
- int secs = abs( local->tm_gmtoff );
- int neg = (local->tm_gmtoff<0)?1:0; //no, I don't know why it's backwards :o
- int hours = secs/3600;
- int mins = (secs - hours*3600)/60;
-
-- if ( local->tm_isdst > 0 ) {
-+ if ( local->tm_isdst > 0 )
- mDaylight = 1;
-- if ( neg )
-- --hours;
-- else
-- ++hours;
-- } else
-+ else
- mDaylight = 0;
-
- ret.sprintf("%c%.2d%.2d",(neg)?'-':'+', hours, mins);
-
- #else
diff --git a/net/kdenetwork3/files/plist.base b/net/kdenetwork3/files/plist.base
index 329b493d8845..cd2d0f8a4e10 100644
--- a/net/kdenetwork3/files/plist.base
+++ b/net/kdenetwork3/files/plist.base
@@ -596,8 +596,8 @@ share/apps/kppp/Rules/Italy/Infostrada_Libero1055_SpZero.rst
share/apps/kppp/Rules/Italy/Infostrada_Loc_Reg_Naz_SpZero.rst
share/apps/kppp/Rules/Italy/Infostrada_Locali_Base.rst
share/apps/kppp/Rules/Italy/Infostrada_Reg_Naz_Base.rst
-share/apps/kppp/Rules/Italy/Tele2_Interurbane.rst
-share/apps/kppp/Rules/Italy/Tele2_Urbane.rst
+share/apps/kppp/Rules/Italy/Tele2_Altri_ISP.rst
+share/apps/kppp/Rules/Italy/Tele2_Internet.rst
share/apps/kppp/Rules/Italy/Telecom_Interurbane_Fino15Km.rst
share/apps/kppp/Rules/Italy/Telecom_Interurbane_Oltre15Km.rst
share/apps/kppp/Rules/Italy/Telecom_Locali.rst
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 241282d93acc..1529b7a734ea 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -8,7 +8,6 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
CATEGORIES?= net news kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${KDE_VERSION}/src
@@ -25,18 +24,25 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+pre-configure::
+ ${REINPLACE_CMD} -e 's@-pedantic @@g' ${WRKSRC}/configure
+
.if !defined(WITHOUT_KTALKD)
UTMP?= /var/run/utmp
.if exists(${UTMP})
PLIST_APPEND+= plist.ktalkd
.else
DO_NOT_COMPILE+= ktalkd
-pre-configure:
+pre-configure::
@${ECHO_MSG} "===> \"${UTMP}\" was not found."
@${ECHO_MSG} "===> The talk daemon (ktalkd) will not be built."
.endif # exists(${UTMP})
@@ -48,5 +54,4 @@ DO_NOT_COMPILE+= ktalkd
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/kdenetwork4/distinfo b/net/kdenetwork4/distinfo
index 6b6106686dba..b9b2902567ae 100644
--- a/net/kdenetwork4/distinfo
+++ b/net/kdenetwork4/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdenetwork-3.1.2.tar.bz2) = baf7663463d9e85a96d5c5143ef2b4be
+MD5 (KDE/kdenetwork-3.1.3.tar.bz2) = 18b1a274575eddf053dd6e72ad5554c7
diff --git a/net/kdenetwork4/files/patch-kmime_util.cpp b/net/kdenetwork4/files/patch-kmime_util.cpp
deleted file mode 100644
index 30213c8f9eab..000000000000
--- a/net/kdenetwork4/files/patch-kmime_util.cpp
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: libkdenetwork/kmime_util.cpp
-===================================================================
-RCS file: /home/kde/kdenetwork/libkdenetwork/Attic/kmime_util.cpp,v
-retrieving revision 1.16.2.1
-diff -u -5 -p -d -r1.16.2.1 kmime_util.cpp
---- libkdenetwork/kmime_util.cpp 13 Dec 2002 09:31:38 -0000 1.16.2.1
-+++ libkdenetwork/kmime_util.cpp 25 Jun 2003 19:42:06 -0000
-@@ -646,17 +646,13 @@ DateFormatter::zone(time_t otime) const
- int secs = abs( local->tm_gmtoff );
- int neg = (local->tm_gmtoff<0)?1:0; //no, I don't know why it's backwards :o
- int hours = secs/3600;
- int mins = (secs - hours*3600)/60;
-
-- if ( local->tm_isdst > 0 ) {
-+ if ( local->tm_isdst > 0 )
- mDaylight = 1;
-- if ( neg )
-- --hours;
-- else
-- ++hours;
-- } else
-+ else
- mDaylight = 0;
-
- ret.sprintf("%c%.2d%.2d",(neg)?'-':'+', hours, mins);
-
- #else
diff --git a/net/kdenetwork4/files/plist.base b/net/kdenetwork4/files/plist.base
index 329b493d8845..cd2d0f8a4e10 100644
--- a/net/kdenetwork4/files/plist.base
+++ b/net/kdenetwork4/files/plist.base
@@ -596,8 +596,8 @@ share/apps/kppp/Rules/Italy/Infostrada_Libero1055_SpZero.rst
share/apps/kppp/Rules/Italy/Infostrada_Loc_Reg_Naz_SpZero.rst
share/apps/kppp/Rules/Italy/Infostrada_Locali_Base.rst
share/apps/kppp/Rules/Italy/Infostrada_Reg_Naz_Base.rst
-share/apps/kppp/Rules/Italy/Tele2_Interurbane.rst
-share/apps/kppp/Rules/Italy/Tele2_Urbane.rst
+share/apps/kppp/Rules/Italy/Tele2_Altri_ISP.rst
+share/apps/kppp/Rules/Italy/Tele2_Internet.rst
share/apps/kppp/Rules/Italy/Telecom_Interurbane_Fino15Km.rst
share/apps/kppp/Rules/Italy/Telecom_Interurbane_Oltre15Km.rst
share/apps/kppp/Rules/Italy/Telecom_Locali.rst