aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>2003-06-01 09:53:14 +0800
committerfoxfair <foxfair@FreeBSD.org>2003-06-01 09:53:14 +0800
commit53ed89fd84d3a1a2ef3e4288f65e624cf2a301d7 (patch)
tree125cc739d6e56558dade99a8f1bc4bfb6bb36a25 /net
parent5e151c5aa8ef3a720f7f7306bbaffff505422b3a (diff)
downloadfreebsd-ports-gnome-53ed89fd84d3a1a2ef3e4288f65e624cf2a301d7.tar.gz
freebsd-ports-gnome-53ed89fd84d3a1a2ef3e4288f65e624cf2a301d7.tar.zst
freebsd-ports-gnome-53ed89fd84d3a1a2ef3e4288f65e624cf2a301d7.zip
Add iftop 0.12,
network utility for real-time bandwidth usage information. PR: 52649 Submitted by: Kirill Ponomarew <ponomarew@oberon.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/iftop/Makefile43
-rw-r--r--net/iftop/distinfo1
-rw-r--r--net/iftop/pkg-descr4
-rw-r--r--net/iftop/pkg-plist6
5 files changed, 55 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7b64225c32d4..60dded19fa44 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -221,6 +221,7 @@
SUBDIR += icqnix
SUBDIR += idnkit
SUBDIR += ifstat
+ SUBDIR += iftop
SUBDIR += imcom
SUBDIR += iog
SUBDIR += ip6_int
diff --git a/net/iftop/Makefile b/net/iftop/Makefile
new file mode 100644
index 000000000000..4c5ad8d4cf41
--- /dev/null
+++ b/net/iftop/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: iftop
+# Date created: 24 May 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iftop
+PORTVERSION= 0.12
+CATEGORIES= net
+MASTER_SITES= http://www.ex-parrot.com/~pdw/iftop/download/
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Network utility for real-time bandwidth usage information
+
+MAN8= iftop.8
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+DOC_FILES= README \
+ COPYING \
+ INSTALL \
+ TODO
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8/
+
+post-install:
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/iftop/distinfo b/net/iftop/distinfo
new file mode 100644
index 000000000000..e4b126d9de7f
--- /dev/null
+++ b/net/iftop/distinfo
@@ -0,0 +1 @@
+MD5 (iftop-0.12.tar.gz) = 5bebdc96f775420c314f037182c3a993
diff --git a/net/iftop/pkg-descr b/net/iftop/pkg-descr
new file mode 100644
index 000000000000..768905ed87a4
--- /dev/null
+++ b/net/iftop/pkg-descr
@@ -0,0 +1,4 @@
+iftop provides real-time bandwidth usage information on a
+specified interface, listed by host pairs.
+
+WWW: http://www.ex-parrot.com/~pdw/iftop/
diff --git a/net/iftop/pkg-plist b/net/iftop/pkg-plist
new file mode 100644
index 000000000000..faa05ecac5b9
--- /dev/null
+++ b/net/iftop/pkg-plist
@@ -0,0 +1,6 @@
+bin/iftop
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+@dirrm %%PORTDOCS%%%%DOCSDIR%%