aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2013-04-23 18:39:26 +0800
committerdes <des@FreeBSD.org>2013-04-23 18:39:26 +0800
commit55dc7d6797d7a58c80a2195a08875ccef91992f2 (patch)
tree493e310ed59db7ba8e09637f395999f3d999fdac /net
parent3039a6385f062a8467aad6559e5cd6b3f00ee340 (diff)
downloadfreebsd-ports-gnome-55dc7d6797d7a58c80a2195a08875ccef91992f2.tar.gz
freebsd-ports-gnome-55dc7d6797d7a58c80a2195a08875ccef91992f2.tar.zst
freebsd-ports-gnome-55dc7d6797d7a58c80a2195a08875ccef91992f2.zip
Fix loop detection bug.
Approved by: perl (tobez)
Diffstat (limited to 'net')
-rw-r--r--net/p5-RPC-XML/Makefile1
-rw-r--r--net/p5-RPC-XML/files/patch-lib-RPC-XML.pm10
2 files changed, 11 insertions, 0 deletions
diff --git a/net/p5-RPC-XML/Makefile b/net/p5-RPC-XML/Makefile
index 47f763f18124..d4395ad7b65f 100644
--- a/net/p5-RPC-XML/Makefile
+++ b/net/p5-RPC-XML/Makefile
@@ -7,6 +7,7 @@
PORTNAME= RPC-XML
PORTVERSION= 0.77
+PORTREVISION= 1
CATEGORIES= net www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/net/p5-RPC-XML/files/patch-lib-RPC-XML.pm b/net/p5-RPC-XML/files/patch-lib-RPC-XML.pm
new file mode 100644
index 000000000000..fab64dd0364b
--- /dev/null
+++ b/net/p5-RPC-XML/files/patch-lib-RPC-XML.pm
@@ -0,0 +1,10 @@
+--- lib/RPC/XML.pm.orig 2011-08-22 11:29:30.000000000 +0200
++++ lib/RPC/XML.pm 2013-04-23 10:28:19.780990362 +0200
+@@ -258,6 +258,7 @@
+ $type = reftype $_;
+ die "Un-convertable reference: $type, cannot use\n";
+ }
++ $seenrefs->{$_}--;
+ }
+ # You have to check ints first, because they match the
+ # next pattern (for doubles) too