aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-03-10 07:50:05 +0800
committerasami <asami@FreeBSD.org>1996-03-10 07:50:05 +0800
commit5bcf34a43b0e576eb32e5f9f3c8088502d40a9ac (patch)
tree631375e989f13d6a13aba965768e952ddf12fa5f /net
parenta2c39f16e36616ae1511fa9997a6b891b28ac9dc (diff)
downloadfreebsd-ports-gnome-5bcf34a43b0e576eb32e5f9f3c8088502d40a9ac.tar.gz
freebsd-ports-gnome-5bcf34a43b0e576eb32e5f9f3c8088502d40a9ac.tar.zst
freebsd-ports-gnome-5bcf34a43b0e576eb32e5f9f3c8088502d40a9ac.zip
Compress manpages so that this thing actually packages. Also, change
package name slightly (no "beta" allowed in version string).
Diffstat (limited to 'net')
-rw-r--r--net/isc-dhcp2/Makefile8
-rw-r--r--net/isc-dhcp3-server/Makefile8
-rw-r--r--net/isc-dhcp3/Makefile8
-rw-r--r--net/isc-dhcp30-server/Makefile8
-rw-r--r--net/isc-dhcp31-server/Makefile8
-rw-r--r--net/isc-dhcp40-server/Makefile8
6 files changed, 36 insertions, 12 deletions
diff --git a/net/isc-dhcp2/Makefile b/net/isc-dhcp2/Makefile
index 5a69fea589ec..81bcab0c6303 100644
--- a/net/isc-dhcp2/Makefile
+++ b/net/isc-dhcp2/Makefile
@@ -3,11 +3,11 @@
# Date created: 7 Mar 1996
# Whom: se
#
-# $Id: Makefile,v 1.2 1996/02/29 09:22:43 asami Exp $
+# $Id: Makefile,v 1.1 1996/03/08 11:45:10 se Exp $
#
DISTNAME= DHCPD-BETA-0
-PKGNAME= isc-dhcp-beta0
+PKGNAME= isc-dhcp-b0
CATEGORIES+= net
MASTER_SITES= ftp://www.isc.org/pub/dhcp/
@@ -17,5 +17,9 @@ do-install:
cd ${WRKSRC}; $(INSTALL) -c $(STRIP) -o $(BINOWN) -g $(BINGRP) -m $(BINMODE) dhcpd dhclient $(PREFIX)/sbin
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.conf.5${ZEXTENSION} $(PREFIX)/man/man5
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.8${ZEXTENSION} $(PREFIX)/man/man8
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf $(PREFIX)/man/man5/dhcpd.conf.5${ZEXTENSION}
+ gzip -9nf $(PREFIX)/man/man8/dhcpd.8${ZEXTENSION}
+.endif
.include <bsd.port.mk>
diff --git a/net/isc-dhcp3-server/Makefile b/net/isc-dhcp3-server/Makefile
index 5a69fea589ec..81bcab0c6303 100644
--- a/net/isc-dhcp3-server/Makefile
+++ b/net/isc-dhcp3-server/Makefile
@@ -3,11 +3,11 @@
# Date created: 7 Mar 1996
# Whom: se
#
-# $Id: Makefile,v 1.2 1996/02/29 09:22:43 asami Exp $
+# $Id: Makefile,v 1.1 1996/03/08 11:45:10 se Exp $
#
DISTNAME= DHCPD-BETA-0
-PKGNAME= isc-dhcp-beta0
+PKGNAME= isc-dhcp-b0
CATEGORIES+= net
MASTER_SITES= ftp://www.isc.org/pub/dhcp/
@@ -17,5 +17,9 @@ do-install:
cd ${WRKSRC}; $(INSTALL) -c $(STRIP) -o $(BINOWN) -g $(BINGRP) -m $(BINMODE) dhcpd dhclient $(PREFIX)/sbin
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.conf.5${ZEXTENSION} $(PREFIX)/man/man5
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.8${ZEXTENSION} $(PREFIX)/man/man8
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf $(PREFIX)/man/man5/dhcpd.conf.5${ZEXTENSION}
+ gzip -9nf $(PREFIX)/man/man8/dhcpd.8${ZEXTENSION}
+.endif
.include <bsd.port.mk>
diff --git a/net/isc-dhcp3/Makefile b/net/isc-dhcp3/Makefile
index 5a69fea589ec..81bcab0c6303 100644
--- a/net/isc-dhcp3/Makefile
+++ b/net/isc-dhcp3/Makefile
@@ -3,11 +3,11 @@
# Date created: 7 Mar 1996
# Whom: se
#
-# $Id: Makefile,v 1.2 1996/02/29 09:22:43 asami Exp $
+# $Id: Makefile,v 1.1 1996/03/08 11:45:10 se Exp $
#
DISTNAME= DHCPD-BETA-0
-PKGNAME= isc-dhcp-beta0
+PKGNAME= isc-dhcp-b0
CATEGORIES+= net
MASTER_SITES= ftp://www.isc.org/pub/dhcp/
@@ -17,5 +17,9 @@ do-install:
cd ${WRKSRC}; $(INSTALL) -c $(STRIP) -o $(BINOWN) -g $(BINGRP) -m $(BINMODE) dhcpd dhclient $(PREFIX)/sbin
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.conf.5${ZEXTENSION} $(PREFIX)/man/man5
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.8${ZEXTENSION} $(PREFIX)/man/man8
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf $(PREFIX)/man/man5/dhcpd.conf.5${ZEXTENSION}
+ gzip -9nf $(PREFIX)/man/man8/dhcpd.8${ZEXTENSION}
+.endif
.include <bsd.port.mk>
diff --git a/net/isc-dhcp30-server/Makefile b/net/isc-dhcp30-server/Makefile
index 5a69fea589ec..81bcab0c6303 100644
--- a/net/isc-dhcp30-server/Makefile
+++ b/net/isc-dhcp30-server/Makefile
@@ -3,11 +3,11 @@
# Date created: 7 Mar 1996
# Whom: se
#
-# $Id: Makefile,v 1.2 1996/02/29 09:22:43 asami Exp $
+# $Id: Makefile,v 1.1 1996/03/08 11:45:10 se Exp $
#
DISTNAME= DHCPD-BETA-0
-PKGNAME= isc-dhcp-beta0
+PKGNAME= isc-dhcp-b0
CATEGORIES+= net
MASTER_SITES= ftp://www.isc.org/pub/dhcp/
@@ -17,5 +17,9 @@ do-install:
cd ${WRKSRC}; $(INSTALL) -c $(STRIP) -o $(BINOWN) -g $(BINGRP) -m $(BINMODE) dhcpd dhclient $(PREFIX)/sbin
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.conf.5${ZEXTENSION} $(PREFIX)/man/man5
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.8${ZEXTENSION} $(PREFIX)/man/man8
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf $(PREFIX)/man/man5/dhcpd.conf.5${ZEXTENSION}
+ gzip -9nf $(PREFIX)/man/man8/dhcpd.8${ZEXTENSION}
+.endif
.include <bsd.port.mk>
diff --git a/net/isc-dhcp31-server/Makefile b/net/isc-dhcp31-server/Makefile
index 5a69fea589ec..81bcab0c6303 100644
--- a/net/isc-dhcp31-server/Makefile
+++ b/net/isc-dhcp31-server/Makefile
@@ -3,11 +3,11 @@
# Date created: 7 Mar 1996
# Whom: se
#
-# $Id: Makefile,v 1.2 1996/02/29 09:22:43 asami Exp $
+# $Id: Makefile,v 1.1 1996/03/08 11:45:10 se Exp $
#
DISTNAME= DHCPD-BETA-0
-PKGNAME= isc-dhcp-beta0
+PKGNAME= isc-dhcp-b0
CATEGORIES+= net
MASTER_SITES= ftp://www.isc.org/pub/dhcp/
@@ -17,5 +17,9 @@ do-install:
cd ${WRKSRC}; $(INSTALL) -c $(STRIP) -o $(BINOWN) -g $(BINGRP) -m $(BINMODE) dhcpd dhclient $(PREFIX)/sbin
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.conf.5${ZEXTENSION} $(PREFIX)/man/man5
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.8${ZEXTENSION} $(PREFIX)/man/man8
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf $(PREFIX)/man/man5/dhcpd.conf.5${ZEXTENSION}
+ gzip -9nf $(PREFIX)/man/man8/dhcpd.8${ZEXTENSION}
+.endif
.include <bsd.port.mk>
diff --git a/net/isc-dhcp40-server/Makefile b/net/isc-dhcp40-server/Makefile
index 5a69fea589ec..81bcab0c6303 100644
--- a/net/isc-dhcp40-server/Makefile
+++ b/net/isc-dhcp40-server/Makefile
@@ -3,11 +3,11 @@
# Date created: 7 Mar 1996
# Whom: se
#
-# $Id: Makefile,v 1.2 1996/02/29 09:22:43 asami Exp $
+# $Id: Makefile,v 1.1 1996/03/08 11:45:10 se Exp $
#
DISTNAME= DHCPD-BETA-0
-PKGNAME= isc-dhcp-beta0
+PKGNAME= isc-dhcp-b0
CATEGORIES+= net
MASTER_SITES= ftp://www.isc.org/pub/dhcp/
@@ -17,5 +17,9 @@ do-install:
cd ${WRKSRC}; $(INSTALL) -c $(STRIP) -o $(BINOWN) -g $(BINGRP) -m $(BINMODE) dhcpd dhclient $(PREFIX)/sbin
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.conf.5${ZEXTENSION} $(PREFIX)/man/man5
cd ${WRKSRC}; $(INSTALL) -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) dhcpd.8${ZEXTENSION} $(PREFIX)/man/man8
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf $(PREFIX)/man/man5/dhcpd.conf.5${ZEXTENSION}
+ gzip -9nf $(PREFIX)/man/man8/dhcpd.8${ZEXTENSION}
+.endif
.include <bsd.port.mk>