aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkbyanc <kbyanc@FreeBSD.org>2005-01-11 07:33:13 +0800
committerkbyanc <kbyanc@FreeBSD.org>2005-01-11 07:33:13 +0800
commit69848b970afcc6a7fa78b7d7a3ab90e24fd80b4c (patch)
tree1e4d3d729be6f91423d58a7e624720a7018f6253 /net
parent77a6008e73aa2b63ac2dccccf3f44826f6f21765 (diff)
downloadfreebsd-ports-gnome-69848b970afcc6a7fa78b7d7a3ab90e24fd80b4c.tar.gz
freebsd-ports-gnome-69848b970afcc6a7fa78b7d7a3ab90e24fd80b4c.tar.zst
freebsd-ports-gnome-69848b970afcc6a7fa78b7d7a3ab90e24fd80b4c.zip
Update to use the Digest::MD5 module shipped with perl5.8 rather than the
port version if perl 5.8.0 or later is installed. Submitted by: David Lay <dsl (at) webize (dot) com (dot) au> PR: 73222
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net-Radius/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/net/p5-Net-Radius/Makefile b/net/p5-Net-Radius/Makefile
index 93f857a2436f..f0c362a7fb2f 100644
--- a/net/p5-Net-Radius/Makefile
+++ b/net/p5-Net-Radius/Makefile
@@ -15,13 +15,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kbyanc@FreeBSD.org
COMMENT= A perl module to manipulate RADIUS packets
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Net::Radius::Dictionary.3 Net::Radius::Packet.3
post-extract:
${FIND} ${WRKDIR} -type f | ${XARGS} ${PERL5} -pi -e "s:\r::g"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>