aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-14 20:44:23 +0800
committertijl <tijl@FreeBSD.org>2014-09-14 20:44:23 +0800
commit6c083d04a2f9e224d76305ae5a966c0f5288e857 (patch)
tree11de05dc3a3d5ccd41888382760240b69c920063 /net
parent8d49ebd5f3ca003cb09411c29bed4f79660dd879 (diff)
downloadfreebsd-ports-gnome-6c083d04a2f9e224d76305ae5a966c0f5288e857.tar.gz
freebsd-ports-gnome-6c083d04a2f9e224d76305ae5a966c0f5288e857.tar.zst
freebsd-ports-gnome-6c083d04a2f9e224d76305ae5a966c0f5288e857.zip
Remove autotools related bits. Port uses cmake.
Diffstat (limited to 'net')
-rw-r--r--net/rabbitmq-c-devel/Makefile18
-rw-r--r--net/rabbitmq-c-devel/files/patch-configure.ac11
-rw-r--r--net/rabbitmq-c-devel/files/patch-tools_unix_process.c57
3 files changed, 3 insertions, 83 deletions
diff --git a/net/rabbitmq-c-devel/Makefile b/net/rabbitmq-c-devel/Makefile
index f3168360e60d..26f65c4cc77f 100644
--- a/net/rabbitmq-c-devel/Makefile
+++ b/net/rabbitmq-c-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rabbitmq-c
PORTVERSION= 0.5.1
+PORTREVISION= 1
CATEGORIES= net
PKGNAMESUFFIX= -devel
@@ -17,25 +18,18 @@ BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
CONFLICTS= rabbitmq-c-[0-9]*
-USES= cmake tar:bzip2 libtool python
+USES= cmake python tar:bzip2
USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= alanxz
GH_COMMIT= e554ca7
GH_TAGNAME= v${PORTVERSION}
-OPTIONS_DEFINE= 64BIT POPT
-64BIT_DESC= Produce 64-bit library
+OPTIONS_DEFINE= POPT
POPT_DESC= Popt support in tools
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:M64BIT}
-ONLY_FOR_ARCHS= amd64 sparc64 powerpc
-ONLY_FOR_ARCHS_REASON= 64BIT option is set
-CONFIGURE_ARGS+= --enable-64-bit
-.endif
-
.if ${PORT_OPTIONS:MPOPT}
LIB_DEPENDS+= libpopt.so:${PORTSDIR}/devel/popt
CFLAGS+= -I${LOCALBASE}/include
@@ -45,12 +39,6 @@ PLIST_SUB+= POPT=""
PLIST_SUB+= POPT="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|rabbitmq-codegen|rabbitmq-codegen-df43f2bfcf0e|g' ${WRKSRC}/configure.ac
-
-pre-configure:
- @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE})
-
post-stage:
${MV} ${STAGEDIR}${PREFIX}/lib/pkgconfig/librabbitmq.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/librabbitmq.pc
${RMDIR} ${STAGEDIR}${PREFIX}/lib/pkgconfig
diff --git a/net/rabbitmq-c-devel/files/patch-configure.ac b/net/rabbitmq-c-devel/files/patch-configure.ac
deleted file mode 100644
index 439e0c56ee9b..000000000000
--- a/net/rabbitmq-c-devel/files/patch-configure.ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2014-02-12 13:50:04.000000000 +0000
-+++ configure.ac 2014-02-12 13:51:38.000000000 +0000
-@@ -39,6 +39,7 @@
- # Environment setup
- AC_CANONICAL_HOST
- AC_C_INLINE
-+AC_CHECK_HEADERS([spawn.h])
-
- # Set compiler flags
- AX_TRY_CFLAGS([-Wall], [AX_CFLAGS([-Wall])])
-
diff --git a/net/rabbitmq-c-devel/files/patch-tools_unix_process.c b/net/rabbitmq-c-devel/files/patch-tools_unix_process.c
deleted file mode 100644
index 258b1334dc19..000000000000
--- a/net/rabbitmq-c-devel/files/patch-tools_unix_process.c
+++ /dev/null
@@ -1,57 +0,0 @@
---- ./tools/unix/process.c.orig 2011-09-06 09:43:42.000000000 +0100
-+++ ./tools/unix/process.c 2011-11-17 15:30:00.000000000 +0000
-@@ -38,7 +38,9 @@
-
- #include <unistd.h>
- #include <errno.h>
-+#ifdef HAVE_SPAWN_H
- #include <spawn.h>
-+#endif
- #include <sys/wait.h>
-
- #include "common.h"
-@@ -46,6 +48,7 @@
-
- extern char **environ;
-
-+#ifdef HAVE_SPAWN_H
- void pipeline(const char *const *argv, struct pipeline *pl)
- {
- posix_spawn_file_actions_t file_acts;
-@@ -75,6 +78,36 @@
-
- pl->infd = pipefds[1];
- }
-+#else
-+void pipeline(const char * const *argv, struct pipeline *pl)
-+{
-+ int pipefds[2];
-+ if (pipe(pipefds))
-+ die_errno(errno, "pipe");
-+
-+ pl->pid = fork();
-+
-+ if (pl->pid == -1)
-+ die_errno(errno, "fork: %s", argv[0]);
-+ else
-+ if (pl->pid == 0) {
-+ if (dup2(pipefds[0], 0))
-+ die_errno(errno, "dup2()");
-+ if (close(pipefds[0]))
-+ die_errno(errno, "close()");
-+ if (close(pipefds[1]))
-+ die_errno(errno, "close()");
-+ execvp(argv[0], argv);
-+ die_errno(errno, "execvp()");
-+ }
-+ else {
-+ if (close(pipefds[0]))
-+ die_errno(errno, "close");
-+ }
-+
-+ pl->infd = pipefds[1];
-+}
-+#endif
-
- int finish_pipeline(struct pipeline *pl)
- {