aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-09-18 14:21:29 +0800
committerpetef <petef@FreeBSD.org>2001-09-18 14:21:29 +0800
commit80f95d7ddf0988578e1da49a765e021904eb1b15 (patch)
tree6e5db933447fa1e37d87fd805fb20c97d117d825 /net
parentffe206252881440f938a334192332f10b674a27f (diff)
downloadfreebsd-ports-gnome-80f95d7ddf0988578e1da49a765e021904eb1b15.tar.gz
freebsd-ports-gnome-80f95d7ddf0988578e1da49a765e021904eb1b15.tar.zst
freebsd-ports-gnome-80f95d7ddf0988578e1da49a765e021904eb1b15.zip
add gutenfetch-1.1
Fetch listings and books from Project Gutenberg PR: 30242 Submitted by: Russell Francis <frussell@p1.cs.ohiou.edu>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/gutenfetch/Makefile28
-rw-r--r--net/gutenfetch/distinfo1
-rw-r--r--net/gutenfetch/pkg-comment1
-rw-r--r--net/gutenfetch/pkg-descr2
-rw-r--r--net/gutenfetch/pkg-message9
-rw-r--r--net/gutenfetch/pkg-plist1
7 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 846c27b773e6..bda75212303f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -133,6 +133,7 @@
SUBDIR += gtk+licq
SUBDIR += gtk-gnutella
SUBDIR += gtkyahoo
+ SUBDIR += gutenfetch
SUBDIR += h2n
SUBDIR += hagelslag
SUBDIR += hesiod
diff --git a/net/gutenfetch/Makefile b/net/gutenfetch/Makefile
new file mode 100644
index 000000000000..5740bb5a5dce
--- /dev/null
+++ b/net/gutenfetch/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gutenfetch
+# Date created: 22-Aug-2001
+# Whom: Russell Francis
+#
+# $FreeBSD$
+#
+
+PORTNAME= gutenfetch
+PORTVERSION= 1.1
+CATEGORIES= net
+MASTER_SITES= http://oak.cats.ohiou.edu/~rf358197/gutenfetch/download/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= petef
+
+MAINTAINER= rf358197@oak.cats.ohiou.edu
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget/ \
+ unzip:${PORTSDIR}/archivers/unzip/
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= gutenfetch.1
+
+post-install:
+ strip ${PREFIX}/bin/gutenfetch
+
+.include <bsd.port.mk>
diff --git a/net/gutenfetch/distinfo b/net/gutenfetch/distinfo
new file mode 100644
index 000000000000..2586c43af76d
--- /dev/null
+++ b/net/gutenfetch/distinfo
@@ -0,0 +1 @@
+MD5 (gutenfetch-1.1.tar.gz) = f87060d0470299c28bcf294bb7812d4a
diff --git a/net/gutenfetch/pkg-comment b/net/gutenfetch/pkg-comment
new file mode 100644
index 000000000000..6482b5945f82
--- /dev/null
+++ b/net/gutenfetch/pkg-comment
@@ -0,0 +1 @@
+Fetch listings and books from Project Gutenberg
diff --git a/net/gutenfetch/pkg-descr b/net/gutenfetch/pkg-descr
new file mode 100644
index 000000000000..f09538630c34
--- /dev/null
+++ b/net/gutenfetch/pkg-descr
@@ -0,0 +1,2 @@
+Gutenfetch - A program which can list books from project gutenberg
+servers. It can also fetch them for reading.
diff --git a/net/gutenfetch/pkg-message b/net/gutenfetch/pkg-message
new file mode 100644
index 000000000000..1c45b56727d6
--- /dev/null
+++ b/net/gutenfetch/pkg-message
@@ -0,0 +1,9 @@
+---------------------------------------------------------------------------
+gutenfetch must be run once to pick out local Project Gutenberg
+servers. If you are an administrator please copy the generated
+file ~/.gutenfetchrc to /etc/gutenfetchrc. This will prevent other
+users from having to pick out their favorite servers.
+
+gutenfetch also performs best with a caching proxy server such as
+wwwoffle or squid.
+---------------------------------------------------------------------------
diff --git a/net/gutenfetch/pkg-plist b/net/gutenfetch/pkg-plist
new file mode 100644
index 000000000000..ca3e3856154d
--- /dev/null
+++ b/net/gutenfetch/pkg-plist
@@ -0,0 +1 @@
+bin/gutenfetch