aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-07-08 17:07:10 +0800
committeradamw <adamw@FreeBSD.org>2003-07-08 17:07:10 +0800
commit8b8b9f3f0c9a565b529a63e52fd9f7b87d688e13 (patch)
treef30694a3c87feefeca9edcf6a976285aa8652086 /net
parentac1d9600bd5b31548666e958e29d7ac171ee05e1 (diff)
downloadfreebsd-ports-gnome-8b8b9f3f0c9a565b529a63e52fd9f7b87d688e13.tar.gz
freebsd-ports-gnome-8b8b9f3f0c9a565b529a63e52fd9f7b87d688e13.tar.zst
freebsd-ports-gnome-8b8b9f3f0c9a565b529a63e52fd9f7b87d688e13.zip
Add loudmouth.
Loudmouth is a lightweight and easy-to-use C library for programming with the Jabber protocol. It's designed to be easy to get started with and yet extensible to let you do anything the Jabber protocol allows.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/loudmouth/Makefile24
-rw-r--r--net/loudmouth/distinfo1
-rw-r--r--net/loudmouth/files/patch-configure10
-rw-r--r--net/loudmouth/pkg-descr5
-rw-r--r--net/loudmouth/pkg-plist13
6 files changed, 54 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e9fc6873fec8..7a7d9163be1e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -310,6 +310,7 @@
SUBDIR += lmd
SUBDIR += lmule
SUBDIR += loadd
+ SUBDIR += loudmouth
SUBDIR += magictun
SUBDIR += maradns
SUBDIR += mars_nwe
diff --git a/net/loudmouth/Makefile b/net/loudmouth/Makefile
new file mode 100644
index 000000000000..d8ad6d04af4f
--- /dev/null
+++ b/net/loudmouth/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: loudmouth
+# Date created: 08 July 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= loudmouth
+PORTVERSION= 0.10.1
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.10
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Lightweight Jabber client library
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_GNOME= gnomehack glib20
+
+.include <bsd.port.mk>
diff --git a/net/loudmouth/distinfo b/net/loudmouth/distinfo
new file mode 100644
index 000000000000..cfdc984bf65c
--- /dev/null
+++ b/net/loudmouth/distinfo
@@ -0,0 +1 @@
+MD5 (loudmouth-0.10.1.tar.bz2) = 02772bf6af0a1a8572387913605c9031
diff --git a/net/loudmouth/files/patch-configure b/net/loudmouth/files/patch-configure
new file mode 100644
index 000000000000..2622df1d24fd
--- /dev/null
+++ b/net/loudmouth/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Tue Jul 8 01:41:33 2003
++++ configure Tue Jul 8 01:42:15 2003
+@@ -18006,6 +18006,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/net/loudmouth/pkg-descr b/net/loudmouth/pkg-descr
new file mode 100644
index 000000000000..3915e760393e
--- /dev/null
+++ b/net/loudmouth/pkg-descr
@@ -0,0 +1,5 @@
+Loudmouth is a lightweight and easy-to-use C library for programming with the
+Jabber protocol. It's designed to be easy to get started with and yet
+extensible to let you do anything the Jabber protocol allows.
+
+WWW: http://www.imendio.com/projects/loudmouth/
diff --git a/net/loudmouth/pkg-plist b/net/loudmouth/pkg-plist
new file mode 100644
index 000000000000..37fa3dedf6c9
--- /dev/null
+++ b/net/loudmouth/pkg-plist
@@ -0,0 +1,13 @@
+include/loudmouth-1.0/loudmouth/lm-connection.h
+include/loudmouth-1.0/loudmouth/lm-error.h
+include/loudmouth-1.0/loudmouth/lm-message-handler.h
+include/loudmouth-1.0/loudmouth/lm-message-node.h
+include/loudmouth-1.0/loudmouth/lm-message.h
+include/loudmouth-1.0/loudmouth/lm-utils.h
+include/loudmouth-1.0/loudmouth/loudmouth.h
+lib/libloudmouth.a
+lib/libloudmouth.so
+lib/libloudmouth.so.0
+libdata/pkgconfig/loudmouth-1.0.pc
+@dirrm include/loudmouth-1.0/loudmouth
+@dirrm include/loudmouth-1.0