aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-12-08 22:10:04 +0800
committerpetef <petef@FreeBSD.org>2001-12-08 22:10:04 +0800
commit90b97faaea1b9d15561dfebdec18e13252d13eba (patch)
tree128601629dc047bf8e63b7f51da06095838ab67e /net
parent0fe5cf0ed083113f989b4422eef83ba95bb88fd3 (diff)
downloadfreebsd-ports-gnome-90b97faaea1b9d15561dfebdec18e13252d13eba.tar.gz
freebsd-ports-gnome-90b97faaea1b9d15561dfebdec18e13252d13eba.tar.zst
freebsd-ports-gnome-90b97faaea1b9d15561dfebdec18e13252d13eba.zip
Fix a problem with auto{conf,make}: some build magic was introduced to
make sure that the "autoconf" and "automake" binaries KDE looked for were found and were autoconf213 and automake14 (as there are issues with the latest versions), but the logic in setting $PATH was wrong. This puts ${WRKSRC}/auto-bin before the rest of the users $PATH. This fixes KDE auto* problems if automake14 and automake-1.5 are both installed. PR: 32512 Submitted by: Alan Eldridge <alane@geeksrus.net> Approved by: will
Diffstat (limited to 'net')
-rw-r--r--net/kdenetwork2/Makefile3
-rw-r--r--net/kdenetwork3/Makefile3
-rw-r--r--net/kdenetwork4/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/net/kdenetwork2/Makefile b/net/kdenetwork2/Makefile
index cc7b590ecb18..33580b3a398a 100644
--- a/net/kdenetwork2/Makefile
+++ b/net/kdenetwork2/Makefile
@@ -31,6 +31,7 @@ CONFIGURE_ARGS+=--enable-final
CONFIGURE_ARGS+=--disable-debug
.endif
USE_GMAKE= yes
+CONFIGURE_ENV+= PATH=${WRKSRC}/auto-bin:$$PATH
MAKE_ENV= ${CONFIGURE_ENV}
pre-configure:
@@ -41,7 +42,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s:-lpthread:${PTHREAD_LIBS}:g" ${WRKSRC}/knode/Makefile.in
${PERL} -pi -e "s@all_includes=\"@all_includes=\"-I/usr/include @g" ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index cc7b590ecb18..33580b3a398a 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -31,6 +31,7 @@ CONFIGURE_ARGS+=--enable-final
CONFIGURE_ARGS+=--disable-debug
.endif
USE_GMAKE= yes
+CONFIGURE_ENV+= PATH=${WRKSRC}/auto-bin:$$PATH
MAKE_ENV= ${CONFIGURE_ENV}
pre-configure:
@@ -41,7 +42,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s:-lpthread:${PTHREAD_LIBS}:g" ${WRKSRC}/knode/Makefile.in
${PERL} -pi -e "s@all_includes=\"@all_includes=\"-I/usr/include @g" ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index cc7b590ecb18..33580b3a398a 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -31,6 +31,7 @@ CONFIGURE_ARGS+=--enable-final
CONFIGURE_ARGS+=--disable-debug
.endif
USE_GMAKE= yes
+CONFIGURE_ENV+= PATH=${WRKSRC}/auto-bin:$$PATH
MAKE_ENV= ${CONFIGURE_ENV}
pre-configure:
@@ -41,7 +42,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s:-lpthread:${PTHREAD_LIBS}:g" ${WRKSRC}/knode/Makefile.in
${PERL} -pi -e "s@all_includes=\"@all_includes=\"-I/usr/include @g" ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4