aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-09-05 10:30:19 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-09-05 10:30:19 +0800
commit992aa4361509c108768f6880f293e75607700f3c (patch)
treec6e13830fda39c21907149a82922589e3fb880f2 /net
parenta30878deee51492ecd5acf42d393d75d06586ec1 (diff)
downloadfreebsd-ports-gnome-992aa4361509c108768f6880f293e75607700f3c.tar.gz
freebsd-ports-gnome-992aa4361509c108768f6880f293e75607700f3c.tar.zst
freebsd-ports-gnome-992aa4361509c108768f6880f293e75607700f3c.zip
- rename nc to netcat to prevent /usr/bin/nc from shadowing
/usr/local/bin/nc PR: ports/11970 Submitted by: Jonathan Liu <Net147@hotmail.com> Approved by: maintainer timeout (sumikawa ; 960 days)
Diffstat (limited to 'net')
-rw-r--r--net/netcat/Makefile12
-rw-r--r--net/netcat/files/nc.112
2 files changed, 12 insertions, 12 deletions
diff --git a/net/netcat/Makefile b/net/netcat/Makefile
index cfb868dba32b..39a59bdf41f4 100644
--- a/net/netcat/Makefile
+++ b/net/netcat/Makefile
@@ -8,7 +8,7 @@
PORTNAME= netcat
PORTVERSION= 1.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= ftp://coast.cs.purdue.edu/pub/tools/unix/netutils/netcat/ \
ftp://ftp.cuhk.edu.hk/pub/packages/security/purdue/netutils/netcat/ \
@@ -30,9 +30,9 @@ OPTIONS= IPV6 "enable IPv6 support" on \
TELNET "enable TELNET support" on \
GAPING "enable GAPING_SECURITY_HOLE support" on
-PLIST_FILES= bin/nc
+PLIST_FILES= bin/netcat
PORTDOCS= README
-MAN1= nc.1
+MAN1= netcat.1
.include <bsd.port.pre.mk>
@@ -48,11 +48,11 @@ XFLAGS+= -DTELNET
XFLAGS+= -DGAPING_SECURITY_HOLE
.endif
-MAKE_ENV= XFLAGS="$(XFLAGS)"
+MAKE_ENV= XFLAGS="${XFLAGS}"
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nc ${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/nc.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/nc ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${FILESDIR}/nc.1 ${PREFIX}/man/man1/${MAN1}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/net/netcat/files/nc.1 b/net/netcat/files/nc.1
index 8b4379f1652a..43da468e3754 100644
--- a/net/netcat/files/nc.1
+++ b/net/netcat/files/nc.1
@@ -1,11 +1,11 @@
-.TH NC 1
+.TH NETCAT 1
.SH NAME
-nc \- TCP/IP swiss army knife
+netcat \- TCP/IP swiss army knife
.SH SYNOPSIS
-.B nc
+.B netcat
.I "[-options] hostname port[s] [ports] ..."
.br
-.B nc
+.B netcat
.I "-l -p port [-options] [hostname] [port]"
.SH "DESCRIPTION"
.B netcat
@@ -15,11 +15,11 @@ reliable "back-end" tool that can be used directly or easily driven by
other programs and scripts. At the same time, it is a feature-rich
network debugging and exploration tool, since it can create almost any
kind of connection you would need and has several interesting built-in
-capabilities. Netcat, or "nc" as the actual program is named, should
+capabilities. Netcat, or "netcat" as the actual program is named, should
have been supplied long ago as another one of those cryptic but
standard Unix tools.
.P
-In the simplest usage, "nc host port" creates a TCP connection to the
+In the simplest usage, "netcat host port" creates a TCP connection to the
given port on the given target host. Your standard input is then sent
to the host, and anything that comes back across the connection is
sent to your standard output. This continues indefinitely, until the