aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2001-12-14 11:21:51 +0800
committerclive <clive@FreeBSD.org>2001-12-14 11:21:51 +0800
commitac8ce031052dd61e1fc3dbe2ae82f301149d9c71 (patch)
treeeeaa58f95323856f1a253242a94967714dd2a0c8 /net
parent0904536260519d5b2849a538aa300f9c2986372e (diff)
downloadfreebsd-ports-gnome-ac8ce031052dd61e1fc3dbe2ae82f301149d9c71.tar.gz
freebsd-ports-gnome-ac8ce031052dd61e1fc3dbe2ae82f301149d9c71.tar.zst
freebsd-ports-gnome-ac8ce031052dd61e1fc3dbe2ae82f301149d9c71.zip
New port: UDPTunnel
UDPTunnel is a small program which can tunnel UDP packets bi-directionally over a TCP connection. Its primary purpose (and original motivation) is to allow multi-media conferences to traverse a firewall which allows only outgoing TCP connections. PR: ports/32820 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/udptunnel/Makefile17
-rw-r--r--net/udptunnel/distinfo1
-rw-r--r--net/udptunnel/pkg-comment1
-rw-r--r--net/udptunnel/pkg-descr17
-rw-r--r--net/udptunnel/pkg-plist1
6 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index aaaf9c01d30f..1b21ed0e29b1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -455,6 +455,7 @@
SUBDIR += ttt
SUBDIR += tund
SUBDIR += tvark
+ SUBDIR += udptunnel
SUBDIR += unison
SUBDIR += urlendec
SUBDIR += vchat
diff --git a/net/udptunnel/Makefile b/net/udptunnel/Makefile
new file mode 100644
index 000000000000..003d9444e759
--- /dev/null
+++ b/net/udptunnel/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: udptunnel
+# Date created: 14 December 2001
+# Whom: Yen-Ming Lee <leeym@leeym.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= udptunnel
+PORTVERSION= 1.1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.cs.columbia.edu/pub/lennox/udptunnel/
+
+MAINTAINER= leeym@leeym.com
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/udptunnel/distinfo b/net/udptunnel/distinfo
new file mode 100644
index 000000000000..ce91532eb0bd
--- /dev/null
+++ b/net/udptunnel/distinfo
@@ -0,0 +1 @@
+MD5 (udptunnel-1.1.tar.gz) = 1e64753a502f2c12386fa0b7baaf50ba
diff --git a/net/udptunnel/pkg-comment b/net/udptunnel/pkg-comment
new file mode 100644
index 000000000000..bdaf272618f4
--- /dev/null
+++ b/net/udptunnel/pkg-comment
@@ -0,0 +1 @@
+Tunnel UDP packets over a TCP connection
diff --git a/net/udptunnel/pkg-descr b/net/udptunnel/pkg-descr
new file mode 100644
index 000000000000..131388d19524
--- /dev/null
+++ b/net/udptunnel/pkg-descr
@@ -0,0 +1,17 @@
+UDPTunnel by Jonathan Lennox; copyright 1999,2001 by Columbia University.
+
+UDPTunnel is a small program which can tunnel UDP packets bi-directionally
+over a TCP connection. Its primary purpose (and original motivation) is to
+allow multi-media conferences to traverse a firewall which allows only
+outgoing TCP connections.
+
+Source code for Unix is available from
+WWW: ftp://ftp.cs.columbia.edu/pub/lennox/udptunnel/
+
+See udptunnel.html for installation and usage instructions. See COPYRIGHT
+for conditions and terms of redistribution. A current version of
+udptunnel.html is located at
+WWW: http://www.cs.columbia.edu/~lennox/udptunnel/
+
+Jonathan Lennox
+September 6, 2001
diff --git a/net/udptunnel/pkg-plist b/net/udptunnel/pkg-plist
new file mode 100644
index 000000000000..7125a0b755a1
--- /dev/null
+++ b/net/udptunnel/pkg-plist
@@ -0,0 +1 @@
+bin/udptunnel