aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorolivier <olivier@FreeBSD.org>2019-06-28 02:27:37 +0800
committerolivier <olivier@FreeBSD.org>2019-06-28 02:27:37 +0800
commitee2857da36c386945d1ae45a643beceeea3d461b (patch)
tree2846061c784e60aba6948febb4954dff45a67f59 /net
parent35e96bbb90f87265152e2c8402b5c64c85cb89b8 (diff)
downloadfreebsd-ports-gnome-ee2857da36c386945d1ae45a643beceeea3d461b.tar.gz
freebsd-ports-gnome-ee2857da36c386945d1ae45a643beceeea3d461b.tar.zst
freebsd-ports-gnome-ee2857da36c386945d1ae45a643beceeea3d461b.zip
Add MRT protocol support
PR: 238847 Submitted by: mat
Diffstat (limited to 'net')
-rw-r--r--net/bird2/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net/bird2/Makefile b/net/bird2/Makefile
index 024b2578a4cb..9a0b8dd44e0c 100644
--- a/net/bird2/Makefile
+++ b/net/bird2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bird
DISTVERSION= 2.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/
PKGNAMESUFFIX= 2
@@ -30,12 +30,13 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS_MULTI= RP
RP_DESC= Routing Protocols
-OPTIONS_MULTI_RP= BFD BABEL BGP OSPF PIPE RADV RIP RPKI STATIC
+OPTIONS_MULTI_RP= BFD BABEL BGP MRT OSPF PIPE RADV RIP RPKI STATIC
OPTIONS_DEFAULT= ${OPTIONS_MULTI_RP}
BFD_DESC= Bidirectional Forwarding Detection
BABEL_DESC= Babel routing protocol
BGP_DESC= Border Gateway Protocol
+MRT_DESC= Dumping Routing Information in MRT Format
OSPF_DESC= Open Short Path First
PIPE_DESC= PIPE routing
RADV_DESC= Router Advertisement
@@ -46,6 +47,7 @@ STATIC_DESC= Static routing
BFD_VARS= rt_prot+=bfd
BABEL_VARS= rt_prot+=babel
BGP_VARS= rt_prot+=bgp
+MRT_VARS= rt_prot+=mrt
OSPF_VARS= rt_prot+=ospf
PIPE_VARS= rt_prot+=pipe
RADV_VARS= rt_prot+=radv