aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-06-03 10:21:13 +0800
committerwill <will@FreeBSD.org>2003-06-03 10:21:13 +0800
commitf53efdd6ab6d4967194a9020de2ede81a8b47161 (patch)
treed329362ff2cf6d025c70b7b2a7d8e9f7fcc93341 /net
parentc10935a87247dec25a0d84e744076efa1a11d7f0 (diff)
downloadfreebsd-ports-gnome-f53efdd6ab6d4967194a9020de2ede81a8b47161.tar.gz
freebsd-ports-gnome-f53efdd6ab6d4967194a9020de2ede81a8b47161.tar.zst
freebsd-ports-gnome-f53efdd6ab6d4967194a9020de2ede81a8b47161.zip
Add mdnsd 0.7G, a program to advertise a service via Rendezvous.
PR: 52658 Submitted by: Dan Pelleg <daniel+mdnsd@pelleg.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/mdnsd/Makefile26
-rw-r--r--net/mdnsd/distinfo1
-rw-r--r--net/mdnsd/pkg-descr10
-rw-r--r--net/mdnsd/pkg-message4
-rw-r--r--net/mdnsd/pkg-plist2
6 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a9e970f434a2..ae4d9fbeae4f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -308,6 +308,7 @@
SUBDIR += maradns
SUBDIR += mars_nwe
SUBDIR += mbrowse
+ SUBDIR += mdnsd
SUBDIR += merlinmon
SUBDIR += micq
SUBDIR += mldonkey
diff --git a/net/mdnsd/Makefile b/net/mdnsd/Makefile
new file mode 100644
index 000000000000..264293cde20a
--- /dev/null
+++ b/net/mdnsd/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mdnsd
+# Date created: 2003/05/24
+# Whom: Dan Pelleg <daniel+mdnsd@pelleg.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mdnsd
+PORTVERSION= 0.7G
+CATEGORIES= net
+MASTER_SITES= http://dotlocal.org/${PORTNAME}/ \
+ http://web.cs.cmu.edu/~dpelleg/download/
+
+MAINTAINER= daniel+mdnsd@pelleg.org
+COMMENT= Advertise a service via Rendezvous
+
+do-install:
+ @${ECHO_MSG} "Installing files"
+.for i in mhttp mquery
+ @${INSTALL} ${COPY} ${_BINOWNGRP} ${WRKSRC}/${i} ${PREFIX}/bin
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/mdnsd/distinfo b/net/mdnsd/distinfo
new file mode 100644
index 000000000000..e21c686c2d5a
--- /dev/null
+++ b/net/mdnsd/distinfo
@@ -0,0 +1 @@
+MD5 (mdnsd-0.7G.tar.gz) = 3692107785567b0eff6cec979506da3b
diff --git a/net/mdnsd/pkg-descr b/net/mdnsd/pkg-descr
new file mode 100644
index 000000000000..97269d8ab3c8
--- /dev/null
+++ b/net/mdnsd/pkg-descr
@@ -0,0 +1,10 @@
+mdnsd is a very lightweight, simple, portable, and easy to integrate open
+source implementation of Multicast DNS (part of Zeroconf, also called
+Rendezvous by Apple) for developers. It supports both acting as a Query and
+a Responder, allowing any software to participate fully on the
+.localnetwork.
+
+WWW: http://dotlocal.org/mdnsd/
+
+ -- Dan Pelleg
+daniel+mdnsd@pelleg.org
diff --git a/net/mdnsd/pkg-message b/net/mdnsd/pkg-message
new file mode 100644
index 000000000000..7ab1d3e9b657
--- /dev/null
+++ b/net/mdnsd/pkg-message
@@ -0,0 +1,4 @@
+To use:
+ mhttp 'unique name' 12.34.56.78 80 '/optionalpath'
+For example:
+ mhttp audiotron 192.168.123.195 80 '/index.asp' &
diff --git a/net/mdnsd/pkg-plist b/net/mdnsd/pkg-plist
new file mode 100644
index 000000000000..163cb574f318
--- /dev/null
+++ b/net/mdnsd/pkg-plist
@@ -0,0 +1,2 @@
+bin/mhttp
+bin/mquery