aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-02-18 22:47:05 +0800
committermiwi <miwi@FreeBSD.org>2016-02-18 22:47:05 +0800
commit0605c2e30fd40378d7d04ab8d5fa3016d20395bd (patch)
treee69b03665ccb6cfc03028cfd2ad64ba204ed3d0f /net
parentc3ce6a8b5508bdf420f83160811e90504704c834 (diff)
downloadfreebsd-ports-gnome-0605c2e30fd40378d7d04ab8d5fa3016d20395bd.tar.gz
freebsd-ports-gnome-0605c2e30fd40378d7d04ab8d5fa3016d20395bd.tar.zst
freebsd-ports-gnome-0605c2e30fd40378d7d04ab8d5fa3016d20395bd.zip
- Ignore php70
- While here remove old php gruft
Diffstat (limited to 'net')
-rw-r--r--net/pecl-amqp/Makefile1
-rw-r--r--net/pecl-apn/Makefile2
-rw-r--r--net/pecl-cvsclient/Makefile2
-rw-r--r--net/pecl-geoip/Makefile1
-rw-r--r--net/pecl-gupnp/Makefile1
-rw-r--r--net/pecl-ip2location/Makefile1
-rw-r--r--net/pecl-mosquitto/Makefile1
-rw-r--r--net/pecl-oauth/Makefile1
-rw-r--r--net/pecl-radius/Makefile1
-rw-r--r--net/pecl-yaz/Makefile1
-rw-r--r--net/pecl-yp/Makefile1
11 files changed, 11 insertions, 2 deletions
diff --git a/net/pecl-amqp/Makefile b/net/pecl-amqp/Makefile
index b10d1bb9a461..c1ba0f61f0df 100644
--- a/net/pecl-amqp/Makefile
+++ b/net/pecl-amqp/Makefile
@@ -18,5 +18,6 @@ LIB_DEPENDS= librabbitmq.so:${PORTSDIR}/net/rabbitmq-c-devel
PHP_MODNAME= ${PORTNAME}
USE_PHP= yes
USE_PHPEXT= yes
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/net/pecl-apn/Makefile b/net/pecl-apn/Makefile
index cb18c648eac5..138cd107ab91 100644
--- a/net/pecl-apn/Makefile
+++ b/net/pecl-apn/Makefile
@@ -21,6 +21,6 @@ USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
CONFIGURE_ARGS= --with-apn=${LOCALBASE}
-IGNORE_WITH_PHP=52
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/net/pecl-cvsclient/Makefile b/net/pecl-cvsclient/Makefile
index d0598f686875..0ce7a46a4b08 100644
--- a/net/pecl-cvsclient/Makefile
+++ b/net/pecl-cvsclient/Makefile
@@ -16,6 +16,6 @@ LICENSE= PHP202
USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
-IGNORE_WITH_PHP=5 56
+IGNORE_WITH_PHP= 56 70
.include <bsd.port.mk>
diff --git a/net/pecl-geoip/Makefile b/net/pecl-geoip/Makefile
index b9f42bff251f..0765387c6ceb 100644
--- a/net/pecl-geoip/Makefile
+++ b/net/pecl-geoip/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
USE_PHP= yes
USE_PHPEXT= yes
USES= tar:tgz
+IGNORE_WITH_PHP= 70
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/config.m4
diff --git a/net/pecl-gupnp/Makefile b/net/pecl-gupnp/Makefile
index 8b461ace47d2..d1ca9b4cf2ec 100644
--- a/net/pecl-gupnp/Makefile
+++ b/net/pecl-gupnp/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libgupnp-1.0.so:${PORTSDIR}/net/gupnp
USE_PHP= yes
USE_PHPEXT= yes
USES= pkgconfig tar:tgz
+IGNORE_WITH_PHP= 70
post-patch:
@${REINPLACE_CMD} -e 's| -ldl||g' ${WRKSRC}/config.m4
diff --git a/net/pecl-ip2location/Makefile b/net/pecl-ip2location/Makefile
index 15c21ca3b384..bfdaf1648abe 100644
--- a/net/pecl-ip2location/Makefile
+++ b/net/pecl-ip2location/Makefile
@@ -19,5 +19,6 @@ USES= tar:tgz
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/net/pecl-mosquitto/Makefile b/net/pecl-mosquitto/Makefile
index 6ba42485dc73..e0f2a95172ad 100644
--- a/net/pecl-mosquitto/Makefile
+++ b/net/pecl-mosquitto/Makefile
@@ -19,5 +19,6 @@ BUILD_DEPENDS= mosquitto>=0:${PORTSDIR}/net/mosquitto
USE_PHP= yes
USE_PHPEXT= yes
USES= tar:tgz
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/net/pecl-oauth/Makefile b/net/pecl-oauth/Makefile
index dac371c4aefb..925ef334606c 100644
--- a/net/pecl-oauth/Makefile
+++ b/net/pecl-oauth/Makefile
@@ -23,5 +23,6 @@ CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/net/pecl-radius/Makefile b/net/pecl-radius/Makefile
index 243b07f28642..7300b0d1d00d 100644
--- a/net/pecl-radius/Makefile
+++ b/net/pecl-radius/Makefile
@@ -16,6 +16,7 @@ LICENSE= BSD3CLAUSE
USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
+IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-radius
diff --git a/net/pecl-yaz/Makefile b/net/pecl-yaz/Makefile
index 31da1b06fdc7..f4c1d7b6cf7f 100644
--- a/net/pecl-yaz/Makefile
+++ b/net/pecl-yaz/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libyaz.so:${PORTSDIR}/net/yaz
USE_PHP= yes
USE_PHPEXT= yes
+IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --with-yaz=${LOCALBASE}
diff --git a/net/pecl-yp/Makefile b/net/pecl-yp/Makefile
index 8269e633c687..eabd0ce3988d 100644
--- a/net/pecl-yp/Makefile
+++ b/net/pecl-yp/Makefile
@@ -16,5 +16,6 @@ LICENSE= PHP301
USE_PHP= yes
USE_PHPEXT= yes
USES= tar:tgz
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>