aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-13 21:30:42 +0800
committertrevor <trevor@FreeBSD.org>2003-11-13 21:30:42 +0800
commit0a792d129c721bbf05ec4507020041dae7ccb939 (patch)
tree5443a6df79f666d3a39d8c4f9b5f89991dc6ce44 /net
parent0bfadbd86b2e8399c2d3221e66321fc0dc66cab1 (diff)
downloadfreebsd-ports-gnome-0a792d129c721bbf05ec4507020041dae7ccb939.tar.gz
freebsd-ports-gnome-0a792d129c721bbf05ec4507020041dae7ccb939.tar.zst
freebsd-ports-gnome-0a792d129c721bbf05ec4507020041dae7ccb939.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Diffstat (limited to 'net')
-rw-r--r--net/clusterit/Makefile3
-rw-r--r--net/coda5_doc/Makefile2
-rw-r--r--net/gopher/Makefile2
-rw-r--r--net/ntp-devel/Makefile5
-rw-r--r--net/ntp-stable/Makefile5
-rw-r--r--net/ntp/Makefile5
-rw-r--r--net/p5-Net-Radius/Makefile2
-rw-r--r--net/p5-Net-XWhois/Makefile2
-rw-r--r--net/ppxp/Makefile2
-rw-r--r--net/xipdump/Makefile2
10 files changed, 17 insertions, 13 deletions
diff --git a/net/clusterit/Makefile b/net/clusterit/Makefile
index 250aa272b211..51c8b3367f27 100644
--- a/net/clusterit/Makefile
+++ b/net/clusterit/Makefile
@@ -27,7 +27,8 @@ USE_XLIB= yes
.endif
post-patch:
- @find ${WRKSRC} -name Makefile | xargs ${PERL} -pi -e 's#/usr/X11R6#${X11BASE}#g'
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
+ ${PERL} -pi -e 's#/usr/X11R6#${X11BASE}#g'
.for file in command.c rvt.c screen.c
@${PERL} -pi -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/rvt/${file}
.endfor
diff --git a/net/coda5_doc/Makefile b/net/coda5_doc/Makefile
index 3c13a694933e..fba24324ea32 100644
--- a/net/coda5_doc/Makefile
+++ b/net/coda5_doc/Makefile
@@ -100,7 +100,7 @@ do-build:
@${ECHO} "or two."
do-install:
- find ${WRKSRC} -type d -exec chmod 755 {} \;
+ ${FIND} ${WRKSRC} -type d -exec chmod 755 {} \;
cd ${WRKSRC}; tar cf - man | (cd ${PREFIX}; tar xvf -)
.if !defined(NOPORTDOCS)
cd ${WRKSRC}; tar cf - doc | (cd ${PREFIX}/share; tar xvf -)
diff --git a/net/gopher/Makefile b/net/gopher/Makefile
index fb2d79cf5113..f5ef219a6d15 100644
--- a/net/gopher/Makefile
+++ b/net/gopher/Makefile
@@ -24,7 +24,7 @@ MAN1= gopher.1 gophfilt.1
MAN5= gopherrc.5
pre-patch:
- @${FIND} ${WRKSRC} -name '*.[ch]' | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
's,<malloc.h>,<stdlib.h>,'
.include <bsd.port.mk>
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index 90febb39c523..7145e0038ead 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -32,8 +32,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/ntp
${TAR} -C ${WRKSRC}/html -cf - . | \
${TAR} -C ${PREFIX}/share/doc/ntp --unlink -xf -
- find ${PREFIX}/share/doc/ntp | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- find ${PREFIX}/share/doc/ntp -type f | xargs ${CHMOD} ${SHAREMODE}
+ ${FIND} ${PREFIX}/share/doc/ntp | \
+ ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ ${FIND} ${PREFIX}/share/doc/ntp -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.mk>
diff --git a/net/ntp-stable/Makefile b/net/ntp-stable/Makefile
index 8e8f8c176bb5..907514ea34d0 100644
--- a/net/ntp-stable/Makefile
+++ b/net/ntp-stable/Makefile
@@ -31,8 +31,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/ntp
${TAR} -C ${WRKSRC}/html -cf - . | \
${TAR} -C ${PREFIX}/share/doc/ntp --unlink -xf -
- find ${PREFIX}/share/doc/ntp | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- find ${PREFIX}/share/doc/ntp -type f | xargs ${CHMOD} ${SHAREMODE}
+ ${FIND} ${PREFIX}/share/doc/ntp | \
+ ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ ${FIND} ${PREFIX}/share/doc/ntp -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.mk>
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 8e8f8c176bb5..907514ea34d0 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -31,8 +31,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/ntp
${TAR} -C ${WRKSRC}/html -cf - . | \
${TAR} -C ${PREFIX}/share/doc/ntp --unlink -xf -
- find ${PREFIX}/share/doc/ntp | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- find ${PREFIX}/share/doc/ntp -type f | xargs ${CHMOD} ${SHAREMODE}
+ ${FIND} ${PREFIX}/share/doc/ntp | \
+ ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ ${FIND} ${PREFIX}/share/doc/ntp -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.mk>
diff --git a/net/p5-Net-Radius/Makefile b/net/p5-Net-Radius/Makefile
index 65d4405c655d..731c243e52d5 100644
--- a/net/p5-Net-Radius/Makefile
+++ b/net/p5-Net-Radius/Makefile
@@ -22,6 +22,6 @@ PERL_CONFIGURE= yes
MAN3= Net::Radius::Dictionary.3 Net::Radius::Packet.3
post-extract:
- find ${WRKDIR} -type f | xargs perl -pi -e "s:\r::g"
+ ${FIND} ${WRKDIR} -type f | ${XARGS} perl -pi -e "s:\r::g"
.include <bsd.port.mk>
diff --git a/net/p5-Net-XWhois/Makefile b/net/p5-Net-XWhois/Makefile
index 23870ceca27e..c202ea7b8a88 100644
--- a/net/p5-Net-XWhois/Makefile
+++ b/net/p5-Net-XWhois/Makefile
@@ -21,6 +21,6 @@ PERL_CONFIGURE= YES
MAN3= Net::XWhois.3
post-patch:
- @find ${WRKSRC} -type f -name "*.orig" -exec rm -f "{}" ";"
+ @${FIND} ${WRKSRC} -type f -name "*.orig" -exec rm -f "{}" ";"
.include <bsd.port.mk>
diff --git a/net/ppxp/Makefile b/net/ppxp/Makefile
index 796e196a2e68..5ad48499627c 100644
--- a/net/ppxp/Makefile
+++ b/net/ppxp/Makefile
@@ -66,7 +66,7 @@ DOC_ja_JP= QuickStart.txt QuickUsage.txt guide-1.html guide-2.html \
guide-11.html guide.html Answers.txt Report.txt
post-patch:
- @find ${WRKSRC} -name '*.orig' -exec ${RM} -f '{}' ';'
+ @${FIND} ${WRKSRC} -name '*.orig' -exec ${RM} -f '{}' ';'
@${PERL} -pi -e 's/^CFLAGS/#$$&/' ${WRKSRC}/configure
post-install:
diff --git a/net/xipdump/Makefile b/net/xipdump/Makefile
index ec38aee2ddb8..583100a4dcc9 100644
--- a/net/xipdump/Makefile
+++ b/net/xipdump/Makefile
@@ -30,7 +30,7 @@ MAN8= xipdump.8
post-build:
@${CP} ${PKGDIR}/pkg-plist ${PLIST}
- @(cd ${WRKSRC}/data; find pkc pkt ! -type d | \
+ @(cd ${WRKSRC}/data; ${FIND} pkc pkt ! -type d | \
${SED} -e 's|^|share/xipdump/|' >> ${PLIST})
@${ECHO_CMD} "@dirrm share/xipdump/pkt" >> ${PLIST}
@${ECHO_CMD} "@dirrm share/xipdump/pkc" >> ${PLIST}