aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-16 07:26:32 +0800
committerpav <pav@FreeBSD.org>2005-09-16 07:26:32 +0800
commit0f14467b74f01fb1ea683f60ca0a240d47839908 (patch)
tree2fb85bd9d6c775bd43c0be10418568249b9ff5ef /net
parent4458082a242ad114d54c5a52a3841e6f054452c5 (diff)
downloadfreebsd-ports-gnome-0f14467b74f01fb1ea683f60ca0a240d47839908.tar.gz
freebsd-ports-gnome-0f14467b74f01fb1ea683f60ca0a240d47839908.tar.zst
freebsd-ports-gnome-0f14467b74f01fb1ea683f60ca0a240d47839908.zip
Pcapy is a Python extension module that interfaces with
the libpcap packet capture library. Pcapy enables Python scripts to capture packets on the network. Pcapy is highly effective when used in conjunction with a packet-handling package such as Impacket, which is a collection of Python classes for constructing and dissecting network packets. PR: ports/86184 Submitted by: Marcin Jessa <yazzy@yazzy.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pcapy/Makefile22
-rw-r--r--net/py-pcapy/distinfo2
-rw-r--r--net/py-pcapy/pkg-descr13
4 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3fe4d693bfa3..43e081eaa9f4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -668,6 +668,7 @@
SUBDIR += py-mp-random
SUBDIR += py-msnp
SUBDIR += py-pcap
+ SUBDIR += py-pcapy
SUBDIR += py-pyxmpp
SUBDIR += py-radix
SUBDIR += py-rrdpipe
diff --git a/net/py-pcapy/Makefile b/net/py-pcapy/Makefile
new file mode 100644
index 000000000000..ec1aadab4b6f
--- /dev/null
+++ b/net/py-pcapy/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: pcapy
+# Date created: 15th September 2005
+# Whom: Marcin Jessa <yazzy@yazzy.org>
+# $FreeBSD$
+
+PORTNAME= pcapy
+PORTVERSION= 0.10.3
+CATEGORIES= net python
+MASTER_SITES= http://oss.coresecurity.com/repo/ \
+ http://www.yazzy.org/ports/pcapy/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yazzy@yazzy.org
+COMMENT= Python extension module to capture packets on the network
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/pcapy.so
+PORTDOCS= README LICENSE pcapy.html
+
+.include <bsd.port.mk>
diff --git a/net/py-pcapy/distinfo b/net/py-pcapy/distinfo
new file mode 100644
index 000000000000..af9439380b5f
--- /dev/null
+++ b/net/py-pcapy/distinfo
@@ -0,0 +1,2 @@
+MD5 (pcapy-0.10.3.tar.gz) = 2a9eb722156f9ce08370ea4da475af20
+SIZE (pcapy-0.10.3.tar.gz) = 19009
diff --git a/net/py-pcapy/pkg-descr b/net/py-pcapy/pkg-descr
new file mode 100644
index 000000000000..28ea6523b275
--- /dev/null
+++ b/net/py-pcapy/pkg-descr
@@ -0,0 +1,13 @@
+Pcapy is a Python extension module that interfaces with
+the libpcap packet capture library. Pcapy enables Python
+scripts to capture packets on the network.
+
+Pcapy is highly effective when used in conjunction with
+a packet-handling package such as Impacket, which is a
+collection of Python classes for constructing and dissecting
+network packets.
+
+- Marcin Jessa
+yazzy@yazzy.org
+
+WWW: http://oss.coresecurity.com/projects/pcapy.html