aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-18 00:57:14 +0800
committertijl <tijl@FreeBSD.org>2014-05-18 00:57:14 +0800
commit28e42c75bcdfdc70a96743cb31f866dc008a24dd (patch)
treeeae79d4f3cebba3d0e91ecad3c25f200503106b5 /net
parentf084098040cd9061d9bb36e65f8cb0abd8cf4f76 (diff)
downloadfreebsd-ports-gnome-28e42c75bcdfdc70a96743cb31f866dc008a24dd.tar.gz
freebsd-ports-gnome-28e42c75bcdfdc70a96743cb31f866dc008a24dd.tar.zst
freebsd-ports-gnome-28e42c75bcdfdc70a96743cb31f866dc008a24dd.zip
Convert net-im/libpurple (and slave ports net-im/finch and net-im/pidgin)
to "USES=libtool tar:bzip2". Bump PORTREVISION on all dependent ports and modernise them as well (USES, LIB_DEPENDS, staging). audio/pidgin-musictracker: - Replace LIBS with LDFLAGS. - Disable static plugin. net/online-desktop: Remove obsolete patches. net-im/mbpurple: - Drop pkgconf dependency. - Replace post-patch with MAKE_ARGS. - Use standard do-build. net-im/pidgin-audacious-remote: Disable static plugin. net-im/pidgin-birthday-reminder: Disable static plugin. net-im/pidgin-fetion: Replace pkg-plist with PLIST_FILES. net-im/pidgin-guifications: - Drop USE_GNOME=gnomeprefix. - Replace LIBS with LDFLAGS. net-im/pidgin-hotkeys: - Drop CFLAGS=-fPIC. - Fix build on systems without gcc. net-im/pidgin-libnotify: - Use option helpers. - Drop references to PTHREAD_CFLAGS and PTHREAD_LIBS. net-im/pidgin-manualsize: Fix build on systems without gcc. net-im/pidgin-privacy-please: - Replace a patch with CPPFLAGS and LDFLAGS. - Don't use USE_LDCONFIG for a plugin. net-im/pidgin-sipe: - Don't use USE_LDCONFIG for a plugin. - Drop PORTDOCS that don't contain useful documentation. - Patch configure with s/LDLAGS/LDFLAGS/ so LDFLAGS can replace LIBS. - Use option helpers and fix Kerberos option. - Remove obsolete CONFIGURE_ENV. security/pidgin-encryption: - Drop references to PTHREAD_CFLAGS and PTHREAD_LIBS. - Disable static plugin. - Use option helpers. security/pidgin-otr: - Drop redundant comment about PORTREVISION. - Add USE_GNOME=gtk20. - Drop references to PTHREAD_CFLAGS and PTHREAD_LIBS. - Port uses stack protector unconditionally so link with -lssp_nonshared when necessary like Mk/bsd.ssp.mk does. Approved by: portmgr (PORTREVISION bump on unstaged port)
Diffstat (limited to 'net')
-rw-r--r--net/online-desktop/Makefile18
-rw-r--r--net/online-desktop/files/patch-Makefile.in11
-rw-r--r--net/online-desktop/files/patch-po_Makefile.in.in14
-rw-r--r--net/online-desktop/pkg-plist2
4 files changed, 7 insertions, 38 deletions
diff --git a/net/online-desktop/Makefile b/net/online-desktop/Makefile
index b56ab28169ea..fc06e5fa4701 100644
--- a/net/online-desktop/Makefile
+++ b/net/online-desktop/Makefile
@@ -3,7 +3,7 @@
PORTNAME= online-desktop
PORTVERSION= 0.3.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net gnome
MASTER_SITES= GNOME
@@ -16,29 +16,25 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus \
${LOCALBASE}/libdata/pkgconfig/nss.pc:${PORTSDIR}/security/nss \
${LOCALBASE}/libdata/pkgconfig/purple.pc:${PORTSDIR}/net-im/libpurple \
${LOCALBASE}/libdata/pkgconfig/pidgin.pc:${PORTSDIR}/net-im/pidgin
-LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- nspr4.1:${PORTSDIR}/devel/nspr \
- nss3.1:${PORTSDIR}/security/nss \
- purple.10:${PORTSDIR}/net-im/libpurple
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libnspr4.so:${PORTSDIR}/devel/nspr \
+ libnss3.so:${PORTSDIR}/security/nss \
+ libpurple.so:${PORTSDIR}/net-im/libpurple
RUN_DEPENDS= ${LOCALBASE}/libexec/desktop-data-engine:${PORTSDIR}/net/desktop-data-model \
${LOCALBASE}/bin/bigboard:${PORTSDIR}/misc/bigboard \
${LOCALBASE}/bin/purple-remote:${PORTSDIR}/net-im/libpurple \
${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
-USE_BZIP2= yes
+USES= gettext gmake libtool tar:bzip2
USE_GNOME= glib20 gconf2 pygnomedesktop
-USE_GMAKE= yes
-USES= gettext
GNU_CONFIGURE= yes
USE_PYTHON= yes
GCONF_SCHEMAS= online-desktop.schemas
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-NO_STAGE= yes
post-patch:
@${FIND} ${WRKSRC} -type f -exec fgrep -l '%%PREFIX%%' {} \; |${XARGS} ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' -i .bak
- @${FIND} ${WRKSRC} -type f -exec fgrep -l '%%LOCALBASE%%' {} \; |${XARGS} ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' -i .bak
.include <bsd.port.mk>
diff --git a/net/online-desktop/files/patch-Makefile.in b/net/online-desktop/files/patch-Makefile.in
deleted file mode 100644
index ae3d2787bbcc..000000000000
--- a/net/online-desktop/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in 2008-04-25 00:52:28.000000000 +0530
-+++ Makefile.in2 2008-05-28 11:32:38.000000000 +0530
-@@ -114,7 +114,7 @@
- binSCRIPT_INSTALL = $(INSTALL_SCRIPT)
- presessionSCRIPT_INSTALL = $(INSTALL_SCRIPT)
- SCRIPTS = $(bin_SCRIPTS) $(presession_SCRIPTS)
--DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/config
-+DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/config -I%%LOCALBASE%%/include
- depcomp = $(SHELL) $(top_srcdir)/depcomp
- am__depfiles_maybe = depfiles
- COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
diff --git a/net/online-desktop/files/patch-po_Makefile.in.in b/net/online-desktop/files/patch-po_Makefile.in.in
deleted file mode 100644
index 8c912069fac3..000000000000
--- a/net/online-desktop/files/patch-po_Makefile.in.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- po/Makefile.in.in.orig
-+++ po/Makefile.in.in
-@@ -33,7 +33,7 @@
- datadir = @datadir@
- datarootdir = @datarootdir@
- libdir = @libdir@
--DATADIRNAME = @DATADIRNAME@
-+DATADIRNAME = share
- itlocaledir = $(prefix)/$(DATADIRNAME)/locale
- subdir = po
- install_sh = @install_sh@
diff --git a/net/online-desktop/pkg-plist b/net/online-desktop/pkg-plist
index d9009cca53e5..9db4dce2f5b1 100644
--- a/net/online-desktop/pkg-plist
+++ b/net/online-desktop/pkg-plist
@@ -6,7 +6,6 @@ bin/od-session
bin/od-start-im
bin/online-prefs-sync-daemon
bin/web-login-driver
-lib/pidgin/libdbus-api-plugin.la
lib/pidgin/libdbus-api-plugin.so
%%PYTHON_SITELIBDIR%%/ddm/AbstractModel.py
%%PYTHON_SITELIBDIR%%/ddm/AbstractModel.pyc
@@ -29,7 +28,6 @@ lib/pidgin/libdbus-api-plugin.so
%%PYTHON_SITELIBDIR%%/ddm/__init__.py
%%PYTHON_SITELIBDIR%%/ddm/__init__.pyc
%%PYTHON_SITELIBDIR%%/ddm/__init__.pyo
-%%PYTHON_SITELIBDIR%%/nssdecrypt.la
%%PYTHON_SITELIBDIR%%/nssdecrypt.so
%%PYTHON_SITELIBDIR%%/pyonlinedesktop/__init__.py
%%PYTHON_SITELIBDIR%%/pyonlinedesktop/__init__.pyc