aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-25 06:54:23 +0800
committermarcus <marcus@FreeBSD.org>2004-06-25 06:54:23 +0800
commit39924776ae7cec4148dc5c6a416c5939364095cb (patch)
treef396a9229649385adf650aae00e8283fc13eacf8 /net
parent3c770df103fca1bceb3460a25afd92cd46a73fa6 (diff)
downloadfreebsd-ports-gnome-39924776ae7cec4148dc5c6a416c5939364095cb.tar.gz
freebsd-ports-gnome-39924776ae7cec4148dc5c6a416c5939364095cb.tar.zst
freebsd-ports-gnome-39924776ae7cec4148dc5c6a416c5939364095cb.zip
Add meanwhile, an open source implementation of the Lotus Sametime Community
Client protocol.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/meanwhile/Makefile22
-rw-r--r--net/meanwhile/distinfo2
-rw-r--r--net/meanwhile/pkg-descr4
-rw-r--r--net/meanwhile/pkg-plist15
5 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 24212b44a7ed..56701734e5c2 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -313,6 +313,7 @@
SUBDIR += mad_fcl
SUBDIR += magictun
SUBDIR += mars_nwe
+ SUBDIR += meanwhile
SUBDIR += merlinmon
SUBDIR += micq
SUBDIR += minisapserver
diff --git a/net/meanwhile/Makefile b/net/meanwhile/Makefile
new file mode 100644
index 000000000000..d00da0b9679b
--- /dev/null
+++ b/net/meanwhile/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: meanwhile
+# Date created: 24 June 2004
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= meanwhile
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= marcus@FreeBSD.org
+COMMENT= Open Source implementation of the Lotus Sametime protocol
+
+USE_GMAKE= yes
+USE_GNOME= lthack glib20
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=13
+
+.include <bsd.port.mk>
diff --git a/net/meanwhile/distinfo b/net/meanwhile/distinfo
new file mode 100644
index 000000000000..3023b894c6d2
--- /dev/null
+++ b/net/meanwhile/distinfo
@@ -0,0 +1,2 @@
+MD5 (meanwhile-0.2.tar.gz) = 36105dc1101060679dccd8d87c0df442
+SIZE (meanwhile-0.2.tar.gz) = 329678
diff --git a/net/meanwhile/pkg-descr b/net/meanwhile/pkg-descr
new file mode 100644
index 000000000000..f15710906dae
--- /dev/null
+++ b/net/meanwhile/pkg-descr
@@ -0,0 +1,4 @@
+The Meanwhile Project is an open implementation of the Lotus Sametime Community
+Client protocol.
+
+WWW: http://meanwhile.sourceforge.net/
diff --git a/net/meanwhile/pkg-plist b/net/meanwhile/pkg-plist
new file mode 100644
index 000000000000..e4c3cb9d631f
--- /dev/null
+++ b/net/meanwhile/pkg-plist
@@ -0,0 +1,15 @@
+include/meanwhile/channel.h
+include/meanwhile/cipher.h
+include/meanwhile/common.h
+include/meanwhile/error.h
+include/meanwhile/meanwhile.h
+include/meanwhile/message.h
+include/meanwhile/service.h
+include/meanwhile/session.h
+include/meanwhile/srvc_aware.h
+include/meanwhile/srvc_conf.h
+include/meanwhile/srvc_im.h
+lib/libmeanwhile.a
+lib/libmeanwhile.so
+lib/libmeanwhile.so.0
+@dirrm include/meanwhile