aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-05-14 00:48:24 +0800
committerfjoe <fjoe@FreeBSD.org>2003-05-14 00:48:24 +0800
commit8bbdddec2537a03e357bae32b68a0b11cde4e5c5 (patch)
tree879f1ebeaf46406b7e4813f5a2d26bb41a9aac1b /net
parent8b086ac43123228e8118bca6923d3c7c03e1c45a (diff)
downloadfreebsd-ports-gnome-8bbdddec2537a03e357bae32b68a0b11cde4e5c5.tar.gz
freebsd-ports-gnome-8bbdddec2537a03e357bae32b68a0b11cde4e5c5.tar.zst
freebsd-ports-gnome-8bbdddec2537a03e357bae32b68a0b11cde4e5c5.zip
New port: bfilter
Smart filtering HTTP proxy. PR: 52034 Submitted by: Kirill Ponomarew
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/bfilter/Makefile24
-rw-r--r--net/bfilter/distinfo1
-rw-r--r--net/bfilter/pkg-descr8
-rw-r--r--net/bfilter/pkg-plist6
5 files changed, 40 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index fc5ae0ee17e3..3176c5be843b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -34,6 +34,7 @@
SUBDIR += b2bua
SUBDIR += balance
SUBDIR += bbsnet
+ SUBDIR += bfilter
SUBDIR += bgpq
SUBDIR += bind8
SUBDIR += bind9
diff --git a/net/bfilter/Makefile b/net/bfilter/Makefile
new file mode 100644
index 000000000000..15445c43e35f
--- /dev/null
+++ b/net/bfilter/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: bfilter
+# Date created: 10.05.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bfilter
+PORTVERSION= 0.8.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Smart filtering HTTP proxy
+
+GNU_CONFIGURE= yes
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/bfilter/distinfo b/net/bfilter/distinfo
new file mode 100644
index 000000000000..35786f827475
--- /dev/null
+++ b/net/bfilter/distinfo
@@ -0,0 +1 @@
+MD5 (bfilter-0.8.1.tar.gz) = 4b40a4c80932100b844bb4642831d778
diff --git a/net/bfilter/pkg-descr b/net/bfilter/pkg-descr
new file mode 100644
index 000000000000..856c550d063b
--- /dev/null
+++ b/net/bfilter/pkg-descr
@@ -0,0 +1,8 @@
+BFilter is a smart filtering HTTP proxy. It removes ads,
+webbugs, and popups. Unlike the majority of similar tools, it
+doesn't rely on a list of blocked URLs, but instead parses HTML
+on the fly, and detects ads using a set of heuristic rules.
+BFilter has a built-in JavaScript engine which detects popups
+and js-generated ads.
+
+WWW: http://bfilter.sourceforge.net
diff --git a/net/bfilter/pkg-plist b/net/bfilter/pkg-plist
new file mode 100644
index 000000000000..9079a2bf2975
--- /dev/null
+++ b/net/bfilter/pkg-plist
@@ -0,0 +1,6 @@
+bin/bfilter
+etc/bfilter/config
+etc/bfilter/config.default
+etc/bfilter/rules
+etc/bfilter/rules.local
+@dirrm /etc/bfilter