aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-12-08 20:04:07 +0800
committermva <mva@FreeBSD.org>2013-12-08 20:04:07 +0800
commit99dc8cf3e20698c03e2a8d18397eeb89dcd1a232 (patch)
treee7739b3fe4bfdf1719f8d97173598bfde9ef261b /net
parentd3f477704a1b69ab45d50515cc20ec04ab66c770 (diff)
downloadfreebsd-ports-gnome-99dc8cf3e20698c03e2a8d18397eeb89dcd1a232.tar.gz
freebsd-ports-gnome-99dc8cf3e20698c03e2a8d18397eeb89dcd1a232.tar.zst
freebsd-ports-gnome-99dc8cf3e20698c03e2a8d18397eeb89dcd1a232.zip
New USES=twisted, to replace the old USE_TWISTED knob.
twisted can be configured with the arguments run or build to replace the previous USE_TWISTED_RUN and USE_TWISTED_BUILD knobs. The twisted components can be added as comma-separated arguments. If you previously wrote USE_TWISTED= yes USE_TWISTED= conch names USE_TWISTED_RUN= yes you now would write USES= twisted USES= twisted:conch,names USES= twisted:run
Diffstat (limited to 'net')
-rw-r--r--net/kippo/Makefile2
-rw-r--r--net/kojoney/Makefile3
-rw-r--r--net/py-ldaptor/Makefile3
-rw-r--r--net/py-tofu/Makefile2
-rw-r--r--net/py-txamqp/Makefile2
-rw-r--r--net/sippy_b2bua/Makefile2
6 files changed, 6 insertions, 8 deletions
diff --git a/net/kippo/Makefile b/net/kippo/Makefile
index ffd0a5ff1ee4..a8b88d4ad285 100644
--- a/net/kippo/Makefile
+++ b/net/kippo/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypt
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= 2.5+
-USE_TWISTED_RUN= conch web
+USES= twisted:run,conch,web
NO_BUILD= yes
USE_RC_SUBR= kippo
diff --git a/net/kojoney/Makefile b/net/kojoney/Makefile
index 86f89f9041cf..d302452dfded 100644
--- a/net/kojoney/Makefile
+++ b/net/kojoney/Makefile
@@ -16,9 +16,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.3.0_1:${PORTSDIR}/devel/py
WRKSRC= ${WRKDIR}/kojoney
USE_PYTHON= 2.5+
-USE_TWISTED= conch
USE_OPENSSL= yes
-USES= perl5
+USES= perl5 twisted:conch
USE_PERL5= run
NO_STAGE= yes
diff --git a/net/py-ldaptor/Makefile b/net/py-ldaptor/Makefile
index 8d577ec1c45e..d98357531468 100644
--- a/net/py-ldaptor/Makefile
+++ b/net/py-ldaptor/Makefile
@@ -16,9 +16,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyparsing.py:${PORTSDIR}/devel/py-parsing \
GITVERSION= aad8ded658b36337a08aeb7402b6b67eb8771bea
-USES= gettext
+USES= gettext twisted
USE_PYTHON= yes
-USE_TWISTED= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGVERSION= 0.0.0
PYDISTUTILS_PKGNAME= ldaptor
diff --git a/net/py-tofu/Makefile b/net/py-tofu/Makefile
index 0b457dc1be67..2282c1d62c8b 100644
--- a/net/py-tofu/Makefile
+++ b/net/py-tofu/Makefile
@@ -14,7 +14,7 @@ COMMENT= Practical high-level network game engine
DIST_SUBDIR= python
USE_BZIP2= yes
USE_PYTHON= yes
-USE_TWISTED= yes
+USES= twisted
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Tofu
WRKSRC= ${WRKDIR}/Tofu-${PORTVERSION}
diff --git a/net/py-txamqp/Makefile b/net/py-txamqp/Makefile
index 5b298d692501..58390a0a6e86 100644
--- a/net/py-txamqp/Makefile
+++ b/net/py-txamqp/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}thrift>0:${PORTSDIR}/devel/py-thrift
USE_PYTHON= -2.7
USE_PYDISTUTILS=easy_install
-USE_TWISTED= yes
+USES= twisted
WRKSRC= ${WRKDIR}/python-${PORTNAME}-${PORTVERSION}
diff --git a/net/sippy_b2bua/Makefile b/net/sippy_b2bua/Makefile
index cb9ae73f43f2..7989366545aa 100644
--- a/net/sippy_b2bua/Makefile
+++ b/net/sippy_b2bua/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= sobomax@FreeBSD.org
COMMENT= SIP Back-to-back user agent (B2BUA) server with Radius support
USE_PYTHON= yes
-USE_TWISTED= yes
+USES= twisted
USE_PYDISTUTILS= yes
NO_STAGE= yes
PYDISTUTILS_PKGNAME= sippy