aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-03-10 14:16:46 +0800
committervanilla <vanilla@FreeBSD.org>2015-03-10 14:16:46 +0800
commitb92a7132bfcf5774bce8035f54a5d5608193bd57 (patch)
treebaa8f111729f7ce7abc432fe141d09763224f623 /net
parent4f02d17226bf95fbb83f3904e58a70d76d01020e (diff)
downloadfreebsd-ports-gnome-b92a7132bfcf5774bce8035f54a5d5608193bd57.tar.gz
freebsd-ports-gnome-b92a7132bfcf5774bce8035f54a5d5608193bd57.tar.zst
freebsd-ports-gnome-b92a7132bfcf5774bce8035f54a5d5608193bd57.zip
Add p5-NetAddr-MAC 0.93, netAddr::MAC - Handles hardware MAC Addresses
(EUI-48 and EUI-64). PR: 198308 Submitted by: Anton Berezin <tobez@tobez.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-NetAddr-MAC/Makefile16
-rw-r--r--net/p5-NetAddr-MAC/distinfo2
-rw-r--r--net/p5-NetAddr-MAC/pkg-descr10
-rw-r--r--net/p5-NetAddr-MAC/pkg-plist2
5 files changed, 31 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c8bb5ebe654e..3f2108c8b355 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -699,6 +699,7 @@
SUBDIR += p5-Net-sFlow
SUBDIR += p5-Net-uFTP
SUBDIR += p5-NetAddr-IP-Count
+ SUBDIR += p5-NetAddr-MAC
SUBDIR += p5-NetPacket
SUBDIR += p5-OAI-Harvester
SUBDIR += p5-OurNet-BBS
diff --git a/net/p5-NetAddr-MAC/Makefile b/net/p5-NetAddr-MAC/Makefile
new file mode 100644
index 000000000000..f3061cee98e1
--- /dev/null
+++ b/net/p5-NetAddr-MAC/Makefile
@@ -0,0 +1,16 @@
+# Created by: Anton Berezin <tobez@tobez.org>
+# $FreeBSD$
+
+PORTNAME= NetAddr-MAC
+PORTVERSION= 0.93
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dgeo@centrale-marseille.fr
+COMMENT= NetAddr::MAC - Handles hardware MAC Addresses (EUI-48 and EUI-64)
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/net/p5-NetAddr-MAC/distinfo b/net/p5-NetAddr-MAC/distinfo
new file mode 100644
index 000000000000..e90f43cce260
--- /dev/null
+++ b/net/p5-NetAddr-MAC/distinfo
@@ -0,0 +1,2 @@
+SHA256 (NetAddr-MAC-0.93.tar.gz) = b9e762c1ff4b579040497b8a0089cf998fc839d3897d3597318758e84564a2f9
+SIZE (NetAddr-MAC-0.93.tar.gz) = 22416
diff --git a/net/p5-NetAddr-MAC/pkg-descr b/net/p5-NetAddr-MAC/pkg-descr
new file mode 100644
index 000000000000..220081c5ea04
--- /dev/null
+++ b/net/p5-NetAddr-MAC/pkg-descr
@@ -0,0 +1,10 @@
+This module provides an interface to deal with Media Access Control (or MAC)
+addresses. These are the addresses that uniquely identify a device on various
+layer 2 networks. Although the most common case is hardware addresses
+on Ethernet network cards, there are a variety of devices that use this
+system of addressing.
+
+This module supports both EUI-48 and EUI-64 addresses and implements an OO
+and a functional interface.
+
+WWW: http://search.cpan.org/dist/NetAddr-MAC/
diff --git a/net/p5-NetAddr-MAC/pkg-plist b/net/p5-NetAddr-MAC/pkg-plist
new file mode 100644
index 000000000000..1cb8358d143c
--- /dev/null
+++ b/net/p5-NetAddr-MAC/pkg-plist
@@ -0,0 +1,2 @@
+%%PERL5_MAN3%%/NetAddr::MAC.3.gz
+%%SITE_PERL%%/NetAddr/MAC.pm