aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-27 02:10:43 +0800
committermarino <marino@FreeBSD.org>2015-03-27 02:10:43 +0800
commitce2cac1702e375e08970dea6e734bf5bb83e29e3 (patch)
treec651683ae1f39920147019bc2fe3b0d0f1bb3cc4 /net
parent768e5dab6ef6681c104f30dc3d078e4bfc5c5900 (diff)
downloadfreebsd-ports-gnome-ce2cac1702e375e08970dea6e734bf5bb83e29e3.tar.gz
freebsd-ports-gnome-ce2cac1702e375e08970dea6e734bf5bb83e29e3.tar.zst
freebsd-ports-gnome-ce2cac1702e375e08970dea6e734bf5bb83e29e3.zip
net/netembryo: Add 2 new options, SCTP and IPv6
DragonFly does not support SCTP. This was detected fine in the configure script, but check-plist failed due to an SCTP file that didn't get installed. The configure script takes options for SCTP and IPv6, so turn those into options. Use the brand-new OPTIONS_EXCLUDE_DragonFly feature to allow SCTP to be on by default for FreeBSD and not even an option for DragonFly.
Diffstat (limited to 'net')
-rw-r--r--net/netembryo/Makefile12
-rw-r--r--net/netembryo/pkg-plist2
2 files changed, 10 insertions, 4 deletions
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
index 3e032e60ca2f..683bd1a41e41 100644
--- a/net/netembryo/Makefile
+++ b/net/netembryo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netembryo
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://pkgs.fedoraproject.org/repo/pkgs/netembryo/netembryo-0.1.1.tar.bz2/d5a3c96b37fe3e4fb1c49df1f7a4a16f/ \
@@ -15,8 +15,14 @@ COMMENT= Network abstraction library
LICENSE= LGPL21
-OPTIONS_DEFINE= OPENSSL
-OPTIONS_DEFAULT=OPENSSL
+OPTIONS_DEFINE= OPENSSL SCTP IPV6
+OPTIONS_DEFAULT= OPENSSL SCTP
+OPTIONS_SUB= yes
+SCTP_DESC= Stream Control Transmission Protocol support
+
+OPTIONS_EXCLUDE_DragonFly= SCTP
+IPV6_CONFIGURE_ENABLE= ipv6
+SCTP_CONFIGURE_ENABLE= sctp
USES= gmake libtool pathfix pkgconfig tar:bzip2
USE_GNOME= glib20
diff --git a/net/netembryo/pkg-plist b/net/netembryo/pkg-plist
index 932f839b07bd..0333be9b09f2 100644
--- a/net/netembryo/pkg-plist
+++ b/net/netembryo/pkg-plist
@@ -7,4 +7,4 @@ lib/libnetembryo.so
lib/libnetembryo.so.9
lib/libnetembryo.so.9.0.0
libdata/pkgconfig/libnetembryo.pc
-libdata/pkgconfig/libnetembryo-sctp.pc
+%%SCTP%%libdata/pkgconfig/libnetembryo-sctp.pc