aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-06 04:18:30 +0800
committerbsam <bsam@FreeBSD.org>2013-09-06 04:18:30 +0800
commitd4be7ebb16af8657e516c12bf0574fb925a3f26f (patch)
tree3b1d1321b78dcf4a659d95ca332649d8253316c1 /net
parentd17cc05291e2481f97fd8cd319a6585d4004ffad (diff)
downloadfreebsd-ports-gnome-d4be7ebb16af8657e516c12bf0574fb925a3f26f.tar.gz
freebsd-ports-gnome-d4be7ebb16af8657e516c12bf0574fb925a3f26f.tar.zst
freebsd-ports-gnome-d4be7ebb16af8657e516c12bf0574fb925a3f26f.zip
. introduce ICONV_CONFIGURE_BASE variable at Mk/Uses/iconv.mk. It's value is
"--with-libiconv=${LOCALBASE}" at systems pre OSVERSION 100043 and "" (null) otherwise; . convert all ports which has CONFIGURE_ARGS=--with-libiconv=${LOCALBASE}. Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'net')
-rw-r--r--net/netatalk/Makefile9
-rw-r--r--net/netatalk3/Makefile9
-rw-r--r--net/samba36/Makefile2
-rw-r--r--net/samba4/Makefile2
-rw-r--r--net/samba4wins/Makefile2
5 files changed, 7 insertions, 17 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index 4997ce4b4db6..85e04c8079ea 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -21,6 +21,7 @@ USE_RC_SUBR= netatalk
CONFIGURE_ARGS+= --with-tcp-wrappers \
--with-pkgconfdir=${PREFIX}/etc \
+ ${ICONV_CONFIGURE_BASE} \
--with-libgcrypt-dir=${LOCALBASE} \
--with-uams-path=${PREFIX}/libexec/netatalk-uams \
--with-bdb=${LOCALBASE}
@@ -119,12 +120,6 @@ CONFIGURE_ARGS+= --enable-sendfile
CONFIGURE_ARGS+= --disable-sendfile
.endif
-.include <bsd.port.pre.mk>
-
-.if !empty(ICONV_LIB)
-CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
@@ -146,4 +141,4 @@ post-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index eece000a2f69..a2252901e495 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -27,6 +27,7 @@ CONFIGURE_ARGS+= --enable-tcp-wrappers \
--with-libgcrypt-dir=${LOCALBASE} \
--with-uams-path=${PREFIX}/libexec/netatalk-uams \
--with-bdb=${LOCALBASE} \
+ ${ICONV_CONFIGURE_BASE} \
--localstatedir=/var \
--disable-bundled-libevent \
--with-libevent-header=${LOCALBASE}/include \
@@ -116,12 +117,6 @@ PLIST_SUB+= ATFUNCS="@comment "
PLIST_SUB+= ATFUNCS=""
.endif
-.include <bsd.port.pre.mk>
-
-.if !empty(ICONV_LIB)
-CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
@@ -137,4 +132,4 @@ post-install:
${INSTALL_DATA} -c ${PREFIX}/etc/extmap.conf.dist ${PREFIX}/etc/extmap.conf
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/samba36/Makefile b/net/samba36/Makefile
index 86bc05593943..595cf99c3d63 100644
--- a/net/samba36/Makefile
+++ b/net/samba36/Makefile
@@ -95,7 +95,7 @@ BUILD_DEPENDS+= tevent>=0.9.11:${PORTSDIR}/devel/tevent
RUN_DEPENDS+= tevent>=0.9.11:${PORTSDIR}/devel/tevent
CONFIGURE_ARGS+= --without-libtevent --enable-external-libtevent
# These options are common for all (sub)ports
-CONFIGURE_ARGS+= --with-libiconv="${LOCALBASE}" \
+CONFIGURE_ARGS+= ${ICONV_CONFIGURE_BASE} \
--disable-as-needed
.if !defined(SAMBA_SUBPORT)
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index ba9fb279bc8e..a83277ccdcc9 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -159,7 +159,7 @@ CONFIGURE_ARGS+= \
--with-iconv \
--with-sendfile-support \
--builtin-libraries=smbclient \
- --with-libiconv="${LOCALBASE}" \
+ ${ICONV_CONFIGURE_BASE} \
--with-gettext="${LOCALBASE}"
# for libexecinfo: (so that __builtin_frame_address() finds the top of the stack)
diff --git a/net/samba4wins/Makefile b/net/samba4wins/Makefile
index 804b758c43bb..cab0e50fd753 100644
--- a/net/samba4wins/Makefile
+++ b/net/samba4wins/Makefile
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
CONFIGURE_ARGS+= --disable-reg-gconf --disable-socket-wrapper \
--with-readline=/usr --with-included-popt \
- --with-libiconv=${LOCALBASE} --without-sqlite3 \
+ ${ICONV_CONFIGURE_BASE} --without-sqlite3 \
--without-pthreads --without-python
USE_RC_SUBR= smbd4wins