aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorluigi <luigi@FreeBSD.org>2002-02-18 16:50:24 +0800
committerluigi <luigi@FreeBSD.org>2002-02-18 16:50:24 +0800
commiteff78fdd8c418faa35ba1e4e3b68c0615c2a8d5c (patch)
treedabd44175949cdf290e6a07f75e7056a86f67832 /net
parent59dc465923a0767fb1f0cbd26cba57bd8795f8fc (diff)
downloadfreebsd-ports-gnome-eff78fdd8c418faa35ba1e4e3b68c0615c2a8d5c.tar.gz
freebsd-ports-gnome-eff78fdd8c418faa35ba1e4e3b68c0615c2a8d5c.tar.zst
freebsd-ports-gnome-eff78fdd8c418faa35ba1e4e3b68c0615c2a8d5c.zip
Upgrade etherboot to 5.0.5, improve pkg documentation and use more
sensible defaults for FreeBSD. Specifically: Makefile, distinfo: upgrade to etherboot 5.0.5 pkg-descr: improve description on installing on floppy/hd files/patch-aa: implement some FreeBSD-specific defaults, namely: + boot1a.s use a FreeBSD partition type instead of a DOS partition type + makerom.c pad the image size to multiples of 8k instead of powers of 2. This makes the tulip image fit in the 62 sectors which are typically unused on the first track of hard disks (other images were already 16k so there is not a problem with them). + Makefile make the disk loader bin/boot1a.bin be compiled by default All these diffs are in the same patchfile because they are very short, version independent (they even work with 5.0.4 and probably earlier versions of etherboot) and will be contributed back to the developers, so it is not worthwhile to clutter the ports subtree with multiple patches. Approved-by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/etherboot/Makefile2
-rw-r--r--net/etherboot/distinfo2
-rw-r--r--net/etherboot/files/patch-aa44
-rw-r--r--net/etherboot/pkg-descr23
4 files changed, 57 insertions, 14 deletions
diff --git a/net/etherboot/Makefile b/net/etherboot/Makefile
index ec72ed68a5ba..3c10db9bc980 100644
--- a/net/etherboot/Makefile
+++ b/net/etherboot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= etherboot
-PORTVERSION= 5.0.4
+PORTVERSION= 5.0.5
CATEGORIES= net
#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
#MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/etherboot/distinfo b/net/etherboot/distinfo
index 860a9f9fbf01..27022036898e 100644
--- a/net/etherboot/distinfo
+++ b/net/etherboot/distinfo
@@ -1 +1 @@
-MD5 (etherboot-5.0.4.tar.bz2) = a15a124cb4e2ca06228d60bf83b2fac6
+MD5 (etherboot-5.0.5.tar.bz2) = 1b7bcf5544ef8729bd6ea571ef8fc365
diff --git a/net/etherboot/files/patch-aa b/net/etherboot/files/patch-aa
index 86796f4692b0..7a6f1c78db8b 100644
--- a/net/etherboot/files/patch-aa
+++ b/net/etherboot/files/patch-aa
@@ -9,3 +9,47 @@
# These flags affect the loader that is prepended to the Etherboot image
LCONFIG+= -DMOVEROM
+--- boot1a.s.orig Sat Jun 23 08:56:25 2001
++++ boot1a.s Mon Feb 4 14:49:28 2002
+@@ -56,7 +56,7 @@
+ # Partition Constants
+ .set PRT_OFF,0x1be # Partition offset
+ .set PRT_NUM,0x4 # Partitions
+- .set PRT_BSD,0x1 # Partition type
++ .set PRT_BSD,0xA5 # Partition type
+
+ # Flag Bits
+ .set FL_PACKET,0x80 # Packet mode
+--- makerom.c.orig Thu Aug 2 00:27:48 2001
++++ makerom.c Mon Feb 4 15:05:00 2002
+@@ -67,7 +67,7 @@
+ fprintf(stderr, "BIOS extension ROM Image did not start with 0x55 0xAA\n");
+ size = buffer[2] * 512L;
+ /* sizes are usually powers of two, warn if not */
+- for (i = MINROMSIZE; i < MAXROMSIZE && i < size; i *= 2)
++ for (i = MINROMSIZE; i < MAXROMSIZE && i < size; i += MINROMSIZE)
+ ;
+ if (size > 0 && i > size)
+ fprintf(stderr, "%ld is a strange size for a boot ROM\n",
+@@ -192,8 +192,8 @@
+ exit(1);
+ }
+ /* shrink it down to the smallest size that will do */
+- for (romsize = MAXROMSIZE; romsize > MINROMSIZE && romsize >= 2*fs; )
+- romsize /= 2L;
++ for (romsize = MINROMSIZE; romsize < MAXROMSIZE && romsize <fs;
++ romsize += MINROMSIZE );
+ rom[2] = romsize / 512L;
+ rom[5] = 0;
+ if (verbose)
+--- Makefile.orig Sun Feb 17 18:59:52 2002
++++ Makefile Sun Feb 17 19:00:04 2002
+@@ -166,7 +166,7 @@
+ BOBJS32+= bin32/serial.o bin32/timer.o
+ BLIB32= bin32/bootlib.a
+ LIBS32= $(BLIB32) $(LIBC32)
+-UTILS+= bin/makerom bin/lzhuf
++UTILS+= bin/makerom bin/lzhuf $(DISKLOADER)
+ STDDEPS32= $(START32) $(BLIB32) $(UTILS)
+ UBE_DEPS32= $(UBE_START32) $(BLIB32)
+ # MAKEDEPS is the one target that is depended by all ROMs, so we check gcc here
diff --git a/net/etherboot/pkg-descr b/net/etherboot/pkg-descr
index 1c769468e924..9ff2f03f8992 100644
--- a/net/etherboot/pkg-descr
+++ b/net/etherboot/pkg-descr
@@ -1,15 +1,14 @@
-This code was originaly from FreeBSD and then the Linux folks greatly
-enhanced its functionality and capabilities. It produces ROM-able
-code to boot ELF/aout kernels over NFS or TFTP. It also includes
-boot loaders to load the ROM images from raw floppy or hard disks,
-or DOS disks.
+This code produce bootloaders for a number of cards that can be
+loaded from from raw or DOS-formatted floppy/hard disks and ROMs
+to boot ELF/aout kernels over NFS or TFTP.
+Edit work/etherboot/src/Config to see/set the desired features.
-There are different ROM images for different network cards
-(many are supported). They are built in work/etherboot/src/bin32.
+The defaults used here are suited to boot FreeBSD ELF kernels over NFS.
-Edit "Config" in work/etherboot/src directory for more features,
-default is to boot ELF kernels over NFS.
+To produce an etherboot floppy (or HD partition) do
-To make a floppy image do
- cd work/etherboot/src ; gmake bin32/<device.fd0
-.COM images are made via gmake bin32/<device type>.com .
+ cd work/etherboot/src
+ cat bin/boot1a.bin bin32/<device>.lzrom > /dev/fd0
+
+Replace <device> with the specific code for your card, and /dev/fd0
+with your hard disk partition.