aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-10-01 16:43:43 +0800
committerlinimon <linimon@FreeBSD.org>2007-10-01 16:43:43 +0800
commitf8427688ad45462ca51ef6deb7b5d0a17304ebcd (patch)
treeecd8aa4ac780802db1839dcbdc66a9ee7637a6d0 /net
parenta09ed26b689d4ec98ee61f781ef3256a4b8a3330 (diff)
downloadfreebsd-ports-gnome-f8427688ad45462ca51ef6deb7b5d0a17304ebcd.tar.gz
freebsd-ports-gnome-f8427688ad45462ca51ef6deb7b5d0a17304ebcd.tar.zst
freebsd-ports-gnome-f8427688ad45462ca51ef6deb7b5d0a17304ebcd.zip
Mark as broken on gcc4.2. While here, add USE_PERL5, which is necessary
to conditionalize inclusion of bsd.perl.mk. Hat: portmgr
Diffstat (limited to 'net')
-rw-r--r--net/DarwinStreamingServer/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net/DarwinStreamingServer/Makefile b/net/DarwinStreamingServer/Makefile
index a80e61292ad4..9ef39f9e6313 100644
--- a/net/DarwinStreamingServer/Makefile
+++ b/net/DarwinStreamingServer/Makefile
@@ -20,6 +20,7 @@ COMMENT= Darwin Streaming Server, a MP3, MPEG4 and QuickTime streaming server
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+USE_PERL5= yes
USE_RC_SUBR= streamingadminserver.sh darwin_streaming_server.sh
SUB_LIST+= PERL=${PERL}
@@ -134,4 +135,10 @@ do-install:
@(cd ${WRKSRC}/${OPSYS}; ${SETENV} ${MAKE_ENV} ./Install)
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
+.include <bsd.port.post.mk>