aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-04-08 08:22:46 +0800
committersylvio <sylvio@FreeBSD.org>2010-04-08 08:22:46 +0800
commit079d3b7952d8ac58ea90292ee1c58686aefc2452 (patch)
treec83b858aa9e9aa8863e03b6efc2d2a5f1b418ba2 /net
parent6592082ea6ec1bc6038748842ea466f1d691768f (diff)
downloadfreebsd-ports-gnome-079d3b7952d8ac58ea90292ee1c58686aefc2452.tar.gz
freebsd-ports-gnome-079d3b7952d8ac58ea90292ee1c58686aefc2452.tar.zst
freebsd-ports-gnome-079d3b7952d8ac58ea90292ee1c58686aefc2452.zip
- aims to simplify the basic interactions with the Cassandra database.
WWW: http://search.cpan.org/dist/Net-Cassandra-Easy/ PR: ports/145436 Submitted by: Gea-Suan Lin <gslin@gslin.org> Approved by: itetcu (mentor, implicit)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Cassandra-Easy/Makefile30
-rw-r--r--net/p5-Net-Cassandra-Easy/distinfo3
-rw-r--r--net/p5-Net-Cassandra-Easy/pkg-descr4
-rw-r--r--net/p5-Net-Cassandra-Easy/pkg-plist24
5 files changed, 62 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8a3ee88646b7..89a496086007 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -517,6 +517,7 @@
SUBDIR += p5-Net-CIDR-Lite
SUBDIR += p5-Net-CSTA
SUBDIR += p5-Net-Cassandra
+ SUBDIR += p5-Net-Cassandra-Easy
SUBDIR += p5-Net-DAV-Server
SUBDIR += p5-Net-DHCP
SUBDIR += p5-Net-DHCPClient
diff --git a/net/p5-Net-Cassandra-Easy/Makefile b/net/p5-Net-Cassandra-Easy/Makefile
new file mode 100644
index 000000000000..e0e0e014e2a8
--- /dev/null
+++ b/net/p5-Net-Cassandra-Easy/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Net-Cassandra-Easy
+# Date created: 2010-04-03
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Cassandra-Easy
+PORTVERSION= 0.08b
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perlish interface to the Cassandra database
+
+RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
+ p5-Hash-Merge>=0:${PORTSDIR}/textproc/p5-Hash-Merge \
+ p5-Modern-Perl>=0:${PORTSDIR}/lang/p5-Modern-Perl \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+
+PERL_CONFIGURE= yes
+USE_PERL5= 5.10.0+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.08
+
+MAN3= Net::Cassandra::Easy.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Cassandra-Easy/distinfo b/net/p5-Net-Cassandra-Easy/distinfo
new file mode 100644
index 000000000000..c749f974e08b
--- /dev/null
+++ b/net/p5-Net-Cassandra-Easy/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Cassandra-Easy-0.08b.tar.gz) = 06ba99c53ee413bccf16b721b2e83191
+SHA256 (Net-Cassandra-Easy-0.08b.tar.gz) = 08b5106e1774737a01b8a70392982dd9625c5191da23e702b7aa7af3f452b31e
+SIZE (Net-Cassandra-Easy-0.08b.tar.gz) = 40174
diff --git a/net/p5-Net-Cassandra-Easy/pkg-descr b/net/p5-Net-Cassandra-Easy/pkg-descr
new file mode 100644
index 000000000000..309f0eb5ea8e
--- /dev/null
+++ b/net/p5-Net-Cassandra-Easy/pkg-descr
@@ -0,0 +1,4 @@
+aims to simplify the basic interactions with the
+Cassandra database.
+
+WWW: http://search.cpan.org/dist/Net-Cassandra-Easy/
diff --git a/net/p5-Net-Cassandra-Easy/pkg-plist b/net/p5-Net-Cassandra-Easy/pkg-plist
new file mode 100644
index 000000000000..253cfe76181e
--- /dev/null
+++ b/net/p5-Net-Cassandra-Easy/pkg-plist
@@ -0,0 +1,24 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/Cassandra/Easy.pm
+%%SITE_PERL%%/Net/Cassandra/cassidy.pl
+%%SITE_PERL%%/Net/GenCassandra/Cassandra.pm
+%%SITE_PERL%%/Net/GenCassandra/Constants.pm
+%%SITE_PERL%%/Net/GenCassandra/Types.pm
+%%SITE_PERL%%/Net/GenThrift/Thrift.pm
+%%SITE_PERL%%/Net/GenThrift/Thrift/BinaryProtocol.pm
+%%SITE_PERL%%/Net/GenThrift/Thrift/BufferedTransport.pm
+%%SITE_PERL%%/Net/GenThrift/Thrift/FramedTransport.pm
+%%SITE_PERL%%/Net/GenThrift/Thrift/HttpClient.pm
+%%SITE_PERL%%/Net/GenThrift/Thrift/MemoryBuffer.pm
+%%SITE_PERL%%/Net/GenThrift/Thrift/Protocol.pm
+%%SITE_PERL%%/Net/GenThrift/Thrift/Socket.pm
+%%SITE_PERL%%/Net/GenThrift/Thrift/Transport.pm
+%%SITE_PERL%%/mach/auto/Net/Cassandra/Easy/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Net/Cassandra/Easy
+@dirrmtry %%SITE_PERL%%/mach/auto/Net/Cassandra
+@dirrmtry %%SITE_PERL%%/mach/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/GenThrift/Thrift
+@dirrmtry %%SITE_PERL%%/Net/GenThrift
+@dirrmtry %%SITE_PERL%%/Net/GenCassandra
+@dirrmtry %%SITE_PERL%%/Net/Cassandra
+@dirrmtry %%SITE_PERL%%/Net