aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-01 00:38:01 +0800
committermat <mat@FreeBSD.org>2014-11-01 00:38:01 +0800
commit0d458ecab32c715dbafac2e780e3bc281c790f30 (patch)
tree9c7667d5365d80313bb5a1d82b3e858badb6b523 /net
parent2faab4c251c70ea616fcb18a3131fc0029f74abd (diff)
downloadfreebsd-ports-gnome-0d458ecab32c715dbafac2e780e3bc281c790f30.tar.gz
freebsd-ports-gnome-0d458ecab32c715dbafac2e780e3bc281c790f30.tar.zst
freebsd-ports-gnome-0d458ecab32c715dbafac2e780e3bc281c790f30.zip
Fix shebang.
Sponsored by: Absolight
Diffstat (limited to 'net')
-rw-r--r--net/p5-ZConf/Makefile7
-rw-r--r--net/p5-ZConf/pkg-plist3
2 files changed, 6 insertions, 4 deletions
diff --git a/net/p5-ZConf/Makefile b/net/p5-ZConf/Makefile
index d0cbd58b183f..aa013075fddb 100644
--- a/net/p5-ZConf/Makefile
+++ b/net/p5-ZConf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ZConf
PORTVERSION= 6.1.0
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:VVELOX
@@ -23,7 +24,11 @@ BUILD_DEPENDS= p5-Chooser>=0:${PORTSDIR}/devel/p5-Chooser \
p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= configure
+SHEBANG_FILES= bin/zcset bin/zccreate bin/zccdump bin/zcvls \
+ bin/zcchooser-set bin/zcget bin/zcchooser-edit \
+ bin/zcchooser-get bin/zcchooser-run bin/zcls \
+ bin/zcrm bin/zcvdel
.include <bsd.port.mk>
diff --git a/net/p5-ZConf/pkg-plist b/net/p5-ZConf/pkg-plist
index 269b23500630..b5c2cddf9e46 100644
--- a/net/p5-ZConf/pkg-plist
+++ b/net/p5-ZConf/pkg-plist
@@ -5,9 +5,6 @@
%%PERL5_MAN3%%/ZConf.3.gz
%%PERL5_MAN3%%/ZConf::backends::file.3.gz
%%PERL5_MAN3%%/ZConf::backends::ldap.3.gz
-@dirrmtry %%SITE_PERL%%/ZConf/backends
-@dirrmtry %%SITE_PERL%%/ZConf
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf
bin/zcchooser-edit
bin/zcchooser-get
bin/zcchooser-run