aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-07-11 21:30:52 +0800
committergarga <garga@FreeBSD.org>2006-07-11 21:30:52 +0800
commit1baba15d4ffd1247a9f04b1b928df568661e6753 (patch)
tree7023f6bade6945e49e0c8c1aed6e9e36d3d3fd93 /net
parent7e14d0ab583625dfc4a4600604705a8e9fd2be38 (diff)
downloadfreebsd-ports-gnome-1baba15d4ffd1247a9f04b1b928df568661e6753.tar.gz
freebsd-ports-gnome-1baba15d4ffd1247a9f04b1b928df568661e6753.tar.zst
freebsd-ports-gnome-1baba15d4ffd1247a9f04b1b928df568661e6753.zip
AstFax provides an outgoing email to fax gateway for the Asterisk PBX package.
Incoming fax to email can also be configured so your Asterisk server can act as both an outgoing and incoming fax server. Features * Written in C * Processes large email messages quickly with the EPS library * Easy to use, simply send an email to the fax number * Configures easily with Asterisk, and most Unix-based MTAs WWW: http://www.inter7.com/index.php?page=astfax PR: ports/85031 Submitted by: Filippo Natali <filippo.natali at gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/astfax/Makefile46
-rw-r--r--net/astfax/distinfo3
-rw-r--r--net/astfax/pkg-descr12
-rw-r--r--net/astfax/pkg-plist3
5 files changed, 65 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index aa7ba49b879c..8fe11dbf24c3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -33,6 +33,7 @@
SUBDIR += asterisk-bristuff
SUBDIR += asterisk-devel
SUBDIR += asterisk-oh323
+ SUBDIR += astfax
SUBDIR += atmsupport
SUBDIR += avahi
SUBDIR += avahi-sharp
diff --git a/net/astfax/Makefile b/net/astfax/Makefile
new file mode 100644
index 000000000000..700e2bca9c97
--- /dev/null
+++ b/net/astfax/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: astfax
+# Date created: 13 Aug 2005
+# Whom: Filippo Natali <filippo.natali@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= astfax
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.inter7.com/astfax/
+
+MAINTAINER= filippo.natali@gmail.com
+COMMENT= AstFax provides an outgoing email to fax gateway for Asterisk
+
+LIB_DEPENDS= spandsp.0:${PORTSDIR}/comms/spandsp
+BUILD_DEPENDS= ${LOCALBASE}/lib/libeps.a:${PORTSDIR}/mail/eps
+RUN_DEPENDS= ${LOCALBASE}/sbin/asterisk:${PORTSDIR}/net/asterisk
+
+PORTDOCS= README testfax.eml testfax.tif
+
+MAKE_ENV+= DEFS="${CFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CC =|CC \?=|' \
+ -e 's|^DEFS =|DEFS \?=|' \
+ -e 's|\/usr\/include\/eps|${LOCALBASE}\/include|' \
+ -e 's|^LIBS=-leps|LIBS=-leps -L${LOCALBASE}\/lib|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|"\/tmp"|"\/var\/tmp"|' \
+ -e 's|"\./ast_fax.call"|"${DATADIR}\/ast_fax.call"|' \
+ ${WRKSRC}/ast_fax.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ast_fax ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ast_fax.call ${DATADIR}
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ for f in ${PORTDOCS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${f} ${DOCSDIR}; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/astfax/distinfo b/net/astfax/distinfo
new file mode 100644
index 000000000000..61f01423969a
--- /dev/null
+++ b/net/astfax/distinfo
@@ -0,0 +1,3 @@
+MD5 (astfax-1.0.tar.gz) = 66e4ef4efc42b3b136bfa81b77552bf5
+SHA256 (astfax-1.0.tar.gz) = 7307e01aad625b90922253aa6c03afc415cb59db7eaf42d7b040b847565524f6
+SIZE (astfax-1.0.tar.gz) = 8664
diff --git a/net/astfax/pkg-descr b/net/astfax/pkg-descr
new file mode 100644
index 000000000000..a1ba56abaa7e
--- /dev/null
+++ b/net/astfax/pkg-descr
@@ -0,0 +1,12 @@
+AstFax provides an outgoing email to fax gateway for the Asterisk PBX package.
+Incoming fax to email can also be configured so your Asterisk server can act
+as both an outgoing and incoming fax server.
+
+Features
+
+ * Written in C
+ * Processes large email messages quickly with the EPS library
+ * Easy to use, simply send an email to the fax number
+ * Configures easily with Asterisk, and most Unix-based MTAs
+
+WWW: http://www.inter7.com/index.php?page=astfax
diff --git a/net/astfax/pkg-plist b/net/astfax/pkg-plist
new file mode 100644
index 000000000000..603624c7b216
--- /dev/null
+++ b/net/astfax/pkg-plist
@@ -0,0 +1,3 @@
+bin/ast_fax
+%%DATADIR%%/ast_fax.call
+@dirrm %%DATADIR%%