aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-05-31 01:30:19 +0800
committerijliao <ijliao@FreeBSD.org>2002-05-31 01:30:19 +0800
commit23bfe7425d7cf5dfc70f4c463b54c8d19e5eec3d (patch)
tree98b6594aba206086f66e3ff43e990b097e53183f /net
parente1e95588d1eb3b5e1926a7bc69f6e42822647869 (diff)
downloadfreebsd-ports-gnome-23bfe7425d7cf5dfc70f4c463b54c8d19e5eec3d.tar.gz
freebsd-ports-gnome-23bfe7425d7cf5dfc70f4c463b54c8d19e5eec3d.tar.zst
freebsd-ports-gnome-23bfe7425d7cf5dfc70f4c463b54c8d19e5eec3d.zip
add p5-Net-SCP 0.06
Perl5 module to access and use scp protocol PR: 38010 Submitted by: Erich Zigler <erich@tacni.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-SCP/Makefile26
-rw-r--r--net/p5-Net-SCP/distinfo1
-rw-r--r--net/p5-Net-SCP/pkg-comment1
-rw-r--r--net/p5-Net-SCP/pkg-descr1
-rw-r--r--net/p5-Net-SCP/pkg-plist5
6 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3c97de691fa0..6b077c926841 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -331,6 +331,7 @@
SUBDIR += p5-Net-Pcap
SUBDIR += p5-Net-Radius
SUBDIR += p5-Net-RawIP
+ SUBDIR += p5-Net-SCP
SUBDIR += p5-Net-SMPP
SUBDIR += p5-Net-SNMP
SUBDIR += p5-Net-SSH
diff --git a/net/p5-Net-SCP/Makefile b/net/p5-Net-SCP/Makefile
new file mode 100644
index 000000000000..c47e629726d5
--- /dev/null
+++ b/net/p5-Net-SCP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-SCP
+# Date created: 12 May 2002
+# Whom: Erich Zigler <erich@tacni.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SCP
+PORTVERSION= 0.06
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erich@tacni.net
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SSH.pm:${PORTSDIR}/net/p5-Net-SSH \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/String/ShellQuote.pm:${PORTSDIR}/textproc/p5-String-ShellQuote
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SCP.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SCP/distinfo b/net/p5-Net-SCP/distinfo
new file mode 100644
index 000000000000..fa85d071c008
--- /dev/null
+++ b/net/p5-Net-SCP/distinfo
@@ -0,0 +1 @@
+MD5 (Net-SCP-0.06.tar.gz) = 3404c8013df8eb19e08a3d179b30a4a7
diff --git a/net/p5-Net-SCP/pkg-comment b/net/p5-Net-SCP/pkg-comment
new file mode 100644
index 000000000000..ee2fb5e1cfe4
--- /dev/null
+++ b/net/p5-Net-SCP/pkg-comment
@@ -0,0 +1 @@
+Perl5 module to access and use scp protocol
diff --git a/net/p5-Net-SCP/pkg-descr b/net/p5-Net-SCP/pkg-descr
new file mode 100644
index 000000000000..ee2fb5e1cfe4
--- /dev/null
+++ b/net/p5-Net-SCP/pkg-descr
@@ -0,0 +1 @@
+Perl5 module to access and use scp protocol
diff --git a/net/p5-Net-SCP/pkg-plist b/net/p5-Net-SCP/pkg-plist
new file mode 100644
index 000000000000..a51250e56234
--- /dev/null
+++ b/net/p5-Net-SCP/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/SCP.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SCP/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SCP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true