aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2013-09-08 16:59:54 +0800
committerdelphij <delphij@FreeBSD.org>2013-09-08 16:59:54 +0800
commit457f97a9d5fc73acf1d605210a3a3519d094b0ef (patch)
treedc9b701d6a47e05a89b80d9fa1db700bcf96b6c5 /net
parent8c67b06d05567a41cc6605c9718dcacf03c956c9 (diff)
downloadfreebsd-ports-gnome-457f97a9d5fc73acf1d605210a3a3519d094b0ef.tar.gz
freebsd-ports-gnome-457f97a9d5fc73acf1d605210a3a3519d094b0ef.tar.zst
freebsd-ports-gnome-457f97a9d5fc73acf1d605210a3a3519d094b0ef.zip
Don't assume that the user have gcc and do not override default CFLAGS.
PR: ports/181929 Reported by: O. Hartmann <ohartman zedat fu-berlin de>
Diffstat (limited to 'net')
-rw-r--r--net/openldap24-server/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 53d9a701d067..1c26f9dacc89 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -56,7 +56,7 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 0
+PORTREVISION_SERVER= 1
OPENLDAP_SHLIB_MAJOR= 8
OPTIONS_DEFINE= FETCH
@@ -501,6 +501,10 @@ PLIST_SUB+= SHLIB_MAJOR=${OPENLDAP_SHLIB_MAJOR}
post-patch:
@${REINPLACE_CMD} -e 's,%LOCALSTATEDIR%/run/,${LDAP_RUN_DIR}/,g' \
${SED_MODULES} ${WRKSRC}/servers/slapd/slapd.conf
+ @${REINPLACE_CMD} -e 's,^OPT =.*,OPT = ${CFLAGS},g' \
+ -e 's,^CC =.*,CC = ${CC},g' \
+ ${SED_MODULES} ${WRKSRC}/contrib/slapd-modules/*/Makefile \
+ ${WRKSRC}/contrib/slapd-modules/*/*/Makefile
.if defined(CONFIGURE_SED)
@${REINPLACE_CMD} -E ${CONFIGURE_SED} \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}