aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-08-22 23:28:16 +0800
committermat <mat@FreeBSD.org>2013-08-22 23:28:16 +0800
commit4a0e3df3c197f951cd4aa5a323bbaaedf998565f (patch)
treec506ecbc38419838513540f714540cbffb3b28bf /net
parent33c1e276fc257de1af22f4346ea025b41f80e7fb (diff)
downloadfreebsd-ports-gnome-4a0e3df3c197f951cd4aa5a323bbaaedf998565f.tar.gz
freebsd-ports-gnome-4a0e3df3c197f951cd4aa5a323bbaaedf998565f.tar.zst
freebsd-ports-gnome-4a0e3df3c197f951cd4aa5a323bbaaedf998565f.zip
Add p5-Net-Works 0.06, APIs for IP addresses and networks.
PR: ports/174360 Submitted by: Kurt Jaeger <fbsd-ports@opsec.eu>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Works/Makefile29
-rw-r--r--net/p5-Net-Works/distinfo2
-rw-r--r--net/p5-Net-Works/pkg-descr4
-rw-r--r--net/p5-Net-Works/pkg-plist14
5 files changed, 50 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 91227c6689f6..981372f2973b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -697,6 +697,7 @@
SUBDIR += p5-Net-Whois-IP
SUBDIR += p5-Net-Whois-RIPE
SUBDIR += p5-Net-Whois-Raw
+ SUBDIR += p5-Net-Works
SUBDIR += p5-Net-Write
SUBDIR += p5-Net-XWhois
SUBDIR += p5-Net-Yadis
diff --git a/net/p5-Net-Works/Makefile b/net/p5-Net-Works/Makefile
new file mode 100644
index 000000000000..423ed6a4dbe5
--- /dev/null
+++ b/net/p5-Net-Works/Makefile
@@ -0,0 +1,29 @@
+# Created by: Kurt Jaeger <fbsd-ports@opsec.eu>
+# $FreeBSD$
+#
+
+PORTNAME= Net-Works
+PORTVERSION= 0.06
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DROLSKY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fbsd-ports@opsec.eu
+COMMENT= APIs for IP addresses and networks
+
+LICENSE= ART20
+
+BUILD_DEPENDS= p5-List-AllUtils>=0.03:${PORTSDIR}/devel/p5-List-AllUtils \
+ p5-Math-Int128>=0.07:${PORTSDIR}/math/p5-Math-Int128 \
+ p5-namespace-autoclean>=0.13:${PORTSDIR}/devel/p5-namespace-autoclean \
+ p5-MooseX-Types>=0.35:${PORTSDIR}/devel/p5-MooseX-Types
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+MAN3= Net::Works.3 Net::Works::Util.3 Net::Works::Address.3 \
+ Net::Works::Network.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Works/distinfo b/net/p5-Net-Works/distinfo
new file mode 100644
index 000000000000..5d48e9eb3c7d
--- /dev/null
+++ b/net/p5-Net-Works/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Works-0.06.tar.gz) = e5b8a36d122a2f1c50ffca70f7c5004685a95827610c53e8ad4cbf5ecc976c40
+SIZE (Net-Works-0.06.tar.gz) = 19044
diff --git a/net/p5-Net-Works/pkg-descr b/net/p5-Net-Works/pkg-descr
new file mode 100644
index 000000000000..7ef089103bfb
--- /dev/null
+++ b/net/p5-Net-Works/pkg-descr
@@ -0,0 +1,4 @@
+Net-Works provides a APIs for IP addresses and networks
+similar to NetAddr::IP, but claims to be cleaner.
+
+WWW: http://search.cpan.org/dist/Net-Works/
diff --git a/net/p5-Net-Works/pkg-plist b/net/p5-Net-Works/pkg-plist
new file mode 100644
index 000000000000..3843578bbb0c
--- /dev/null
+++ b/net/p5-Net-Works/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Net/Works.pm
+%%SITE_PERL%%/Net/Works/Address.pm
+%%SITE_PERL%%/Net/Works/Network.pm
+%%SITE_PERL%%/Net/Works/Role/IP.pm
+%%SITE_PERL%%/Net/Works/Types.pm
+%%SITE_PERL%%/Net/Works/Types/Internal.pm
+%%SITE_PERL%%/Net/Works/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Works/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Works
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/Works/Types
+@dirrm %%SITE_PERL%%/Net/Works/Role
+@dirrm %%SITE_PERL%%/Net/Works
+@dirrm %%SITE_PERL%%/Net