aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-07-04 19:22:49 +0800
committerscheidell <scheidell@FreeBSD.org>2012-07-04 19:22:49 +0800
commit4a89c219597ba6e167560942854e58bd4908941a (patch)
tree947cca474653e2ab09d11f3c0ea958d73cd75b5c /net
parent57c1fbb1032f895d898138c6ca625f6e8e3c6e60 (diff)
downloadfreebsd-ports-gnome-4a89c219597ba6e167560942854e58bd4908941a.tar.gz
freebsd-ports-gnome-4a89c219597ba6e167560942854e58bd4908941a.tar.zst
freebsd-ports-gnome-4a89c219597ba6e167560942854e58bd4908941a.zip
- Fix insecure handling of GeoIP download file
- Bump PORTREVISION since we change package PR: ports/145425 Submitted by: anatoly pugachev <matorola@gmail.com> Approved by: dhn@ (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/GeoIP/Makefile6
-rw-r--r--net/GeoIP/files/geoipupdate.sh5
-rw-r--r--net/GeoIP/files/geoipupdate.sh.in2
3 files changed, 6 insertions, 7 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
index a66ab0a3c961..b161c12e6d92 100644
--- a/net/GeoIP/Makefile
+++ b/net/GeoIP/Makefile
@@ -7,7 +7,7 @@
PORTNAME= GeoIP
PORTVERSION= 1.4.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net geography
MASTER_SITES= http://geolite.maxmind.com/download/geoip/api/c/
@@ -22,11 +22,13 @@ USE_LDCONFIG= yes
MAN1= geoiplookup.1 geoipupdate.1 geoiplookup6.1
+SUB_FILES= geoipupdate.sh
+
run-autotools:
@${REINPLACE_CMD} -e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
${WRKSRC}/aclocal.m4
post-install:
- ${INSTALL_SCRIPT} ${FILESDIR}/geoipupdate.sh ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKDIR}/geoipupdate.sh ${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/net/GeoIP/files/geoipupdate.sh b/net/GeoIP/files/geoipupdate.sh
deleted file mode 100644
index 36a9bd25c7cf..000000000000
--- a/net/GeoIP/files/geoipupdate.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-cd /tmp
-fetch http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz
-gunzip GeoIP.dat.gz
-mv -f GeoIP.dat /usr/local/share/GeoIP
diff --git a/net/GeoIP/files/geoipupdate.sh.in b/net/GeoIP/files/geoipupdate.sh.in
new file mode 100644
index 000000000000..89145deaf6b3
--- /dev/null
+++ b/net/GeoIP/files/geoipupdate.sh.in
@@ -0,0 +1,2 @@
+#!/bin/sh
+fetch -o - http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz | gunzip > %%DATADIR%%/GeoIP.dat