aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-04 05:12:25 +0800
committerpav <pav@FreeBSD.org>2006-04-04 05:12:25 +0800
commit67b31e3cb0fcd0c56990d6fe2a4408d0fabd910b (patch)
treeebc52b432fd86a9bcb5eb5acee2d10fbb665d3fc /net
parentba0f772db99dafbed493f30e81056bfd15e35b90 (diff)
downloadfreebsd-ports-gnome-67b31e3cb0fcd0c56990d6fe2a4408d0fabd910b.tar.gz
freebsd-ports-gnome-67b31e3cb0fcd0c56990d6fe2a4408d0fabd910b.tar.zst
freebsd-ports-gnome-67b31e3cb0fcd0c56990d6fe2a4408d0fabd910b.zip
- Fix logging of "connect from" message
Obtained from: http://lists.samba.org/archive/rsync/2006-March/015143.html
Diffstat (limited to 'net')
-rw-r--r--net/rsync/Makefile1
-rw-r--r--net/rsync/files/patch-clientserver.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 4cd3799ea4cb..c7160f8971a9 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rsync
PORTVERSION= 2.6.7
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://rsync.samba.org/ftp/%SUBDIR%/ \
ftp://ftp.samba.org//pub/%SUBDIR%/ \
diff --git a/net/rsync/files/patch-clientserver.c b/net/rsync/files/patch-clientserver.c
new file mode 100644
index 000000000000..ecf19800c696
--- /dev/null
+++ b/net/rsync/files/patch-clientserver.c
@@ -0,0 +1,20 @@
+--- clientserver.c 24 Feb 2006 01:56:26 -0000 1.177
++++ clientserver.c 31 Mar 2006 17:36:26 -0000
+@@ -733,8 +733,6 @@ int start_daemon(int f_in, int f_out)
+ char *host = client_name(f_in);
+ int i;
+
+- rprintf(FLOG, "connect from %s (%s)\n", host, addr);
+-
+ io_set_sock_fds(f_in, f_out);
+
+ if (!lp_load(config_file, 0))
+@@ -742,6 +740,8 @@ int start_daemon(int f_in, int f_out)
+
+ log_init();
+
++ rprintf(FLOG, "connect from %s (%s)\n", host, addr);
++
+ if (!am_server) {
+ set_socket_options(f_in, "SO_KEEPALIVE");
+ if (sockopts)