aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2009-06-16 04:47:57 +0800
committergarga <garga@FreeBSD.org>2009-06-16 04:47:57 +0800
commit6c93f43159b9dd7bc129ff4c10546b83b719a7fa (patch)
tree1328518c8564bec8e41754fa5d2586c3e97556c8 /net
parent81ccd7fcad98e48fad273be67cd1baff3eb2098f (diff)
downloadfreebsd-ports-gnome-6c93f43159b9dd7bc129ff4c10546b83b719a7fa.tar.gz
freebsd-ports-gnome-6c93f43159b9dd7bc129ff4c10546b83b719a7fa.tar.zst
freebsd-ports-gnome-6c93f43159b9dd7bc129ff4c10546b83b719a7fa.zip
GeoIP searches a GeoIP database for a given host or IP address, and
returns information about the country where the IP address is allocated. This is a GeoIP implementation for rubygems WWW: http://geoip.rubyforge.org
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-geoip/Makefile22
-rw-r--r--net/rubygem-geoip/distinfo3
-rw-r--r--net/rubygem-geoip/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index afc8caed6ed1..b4b71ee846c9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -839,6 +839,7 @@
SUBDIR += ruby-spread
SUBDIR += ruby-tcpsocketpipe
SUBDIR += ruby-tserver
+ SUBDIR += rubygem-geoip
SUBDIR += rubygem-macaddr
SUBDIR += rubygem-net-netrc
SUBDIR += rubygem-oauth
diff --git a/net/rubygem-geoip/Makefile b/net/rubygem-geoip/Makefile
new file mode 100644
index 000000000000..6cd42295b1d2
--- /dev/null
+++ b/net/rubygem-geoip/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: rubygem-geoip
+# Date created: 2009-06-15
+# Whom: Renato Botelho <garga@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= geoip
+PORTVERSION= 0.8.1
+CATEGORIES= net rubygems
+MASTER_SITES= RF
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= Geoip implementation for rubygems
+
+RUN_DEPENDS= geoiplookup:${PORTSDIR}/net/GeoIP
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-geoip/distinfo b/net/rubygem-geoip/distinfo
new file mode 100644
index 000000000000..6b31a6a8f4da
--- /dev/null
+++ b/net/rubygem-geoip/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/geoip-0.8.1.gem) = e46c47dbf753e7797abeda67251211e7
+SHA256 (rubygem/geoip-0.8.1.gem) = 93e6172be47a296ea0e980eda58d6e7bd82e735ac7bcf821e62f3aa24ce636de
+SIZE (rubygem/geoip-0.8.1.gem) = 33792
diff --git a/net/rubygem-geoip/pkg-descr b/net/rubygem-geoip/pkg-descr
new file mode 100644
index 000000000000..7af33b185209
--- /dev/null
+++ b/net/rubygem-geoip/pkg-descr
@@ -0,0 +1,6 @@
+GeoIP searches a GeoIP database for a given host or IP address, and
+returns information about the country where the IP address is allocated.
+
+This is a GeoIP implementation for rubygems
+
+WWW: http://geoip.rubyforge.org