aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-15 02:02:16 +0800
committerantoine <antoine@FreeBSD.org>2014-01-15 02:02:16 +0800
commit7df70d72c39cf8450620f3ceef5e508f4d28ecbb (patch)
tree39692beb2ed8439c7ddea75d0fcb9c271ae43bd1 /net
parent082f0e87423c3dee2e83ef80607424b61371d0bc (diff)
downloadfreebsd-ports-gnome-7df70d72c39cf8450620f3ceef5e508f4d28ecbb.tar.gz
freebsd-ports-gnome-7df70d72c39cf8450620f3ceef5e508f4d28ecbb.tar.zst
freebsd-ports-gnome-7df70d72c39cf8450620f3ceef5e508f4d28ecbb.zip
- Update to 1.8.0
- Stage support PR: ports/185711 Submitted by: KATO Tsuguru
Diffstat (limited to 'net')
-rw-r--r--net/pptpclient/Makefile24
-rw-r--r--net/pptpclient/distinfo4
-rw-r--r--net/pptpclient/files/patch-aa20
-rw-r--r--net/pptpclient/files/patch-ac14
-rw-r--r--net/pptpclient/files/patch-pptp_compat.c11
-rw-r--r--net/pptpclient/pkg-plist4
6 files changed, 15 insertions, 62 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index b3c4d9aefe7f..2a0cd1a5d3cf 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pptpclient
-PORTVERSION= 1.7.2
-PORTREVISION= 6
+PORTVERSION= 1.8.0
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/pptp/pptp-${PORTVERSION}
DISTNAME= pptp-${PORTVERSION}
@@ -11,19 +10,22 @@ DISTNAME= pptp-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= PPTP client for establishing a VPN link with an NT server
-LICENSE= GPLv2
+LICENSE= GPLv2 # (or later)
USES= perl5
-MAKE_ARGS= DEBUG="" CC="${CC}"
+MAKE_ARGS= CC="${CC}" OPTIMIZE="${CFLAGS}" DEBUG="" PPPD="/usr/sbin/ppp"
+CFLAGS+= -DUSER_PPP
-MAN8= pptp.8
+PLIST_FILES= sbin/pptp man/man8/pptp.8.gz
+PORTEXAMPLES= README ppp.conf
+
+OPTIONS_DEFINE= EXAMPLES
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pptp ${PREFIX}/sbin
- @${MKDIR} ${PREFIX}/share/examples/pptpclient
- ${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/pptpclient
- ${INSTALL_DATA} ${FILESDIR}/ppp.conf ${PREFIX}/share/examples/pptpclient
- ${INSTALL_MAN} ${WRKSRC}/pptp.8 ${PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/pptp ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${FILESDIR}/README ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${FILESDIR}/ppp.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/pptp.8 ${STAGEDIR}${MANPREFIX}/man/man8
.include <bsd.port.mk>
diff --git a/net/pptpclient/distinfo b/net/pptpclient/distinfo
index 287234aa7ab5..916f52a8ab1b 100644
--- a/net/pptpclient/distinfo
+++ b/net/pptpclient/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pptp-1.7.2.tar.gz) = e98ae0065d2a39fa3131654ff28cb7070e996f668ed6d0e7d9a445b8d37694bc
-SIZE (pptp-1.7.2.tar.gz) = 81113
+SHA256 (pptp-1.8.0.tar.gz) = e39c42d933242a8a6dd8600a0fa7f0a5ec8f066d10c4149d8e81a5c68fe4bbda
+SIZE (pptp-1.8.0.tar.gz) = 86778
diff --git a/net/pptpclient/files/patch-aa b/net/pptpclient/files/patch-aa
deleted file mode 100644
index a467e34fe3e9..000000000000
--- a/net/pptpclient/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.orig 2008-05-14 11:33:55.000000000 +0500
-+++ Makefile 2013-08-29 11:28:02.675336240 +0400
-@@ -4,7 +4,7 @@ RELEASE=
-
- #################################################################
- # CHANGE THIS LINE to point to the location of your pppd binary.
--PPPD = /usr/sbin/pppd
-+PPPD = /usr/sbin/ppp
- #################################################################
-
- BINDIR=$(DESTDIR)/usr/sbin
-@@ -16,7 +16,7 @@ RM = rm -f
- OPTIMIZE= -O0
- DEBUG = -g
- INCLUDE =
--CFLAGS = -Wall $(OPTIMIZE) $(DEBUG) $(INCLUDE)
-+CFLAGS += -Wall $(DEBUG) $(INCLUDE) -DUSER_PPP
- LIBS = -lutil
- # Solaris 10
- # LIBS = -lnsl -lsocket -lresolv
diff --git a/net/pptpclient/files/patch-ac b/net/pptpclient/files/patch-ac
deleted file mode 100644
index 50a2f85ae0a9..000000000000
--- a/net/pptpclient/files/patch-ac
+++ /dev/null
@@ -1,14 +0,0 @@
-RCS file: /home/jdp/f5/pptp/cvs/pptp/pptp_callmgr.h,v
-retrieving revision 1.1.1.1
-retrieving revision 1.2
-diff -u -r1.1.1.1 -r1.2
---- pptp_callmgr.h 1999/04/28 19:36:57 1.1.1.1
-+++ pptp_callmgr.h 1999/04/28 19:43:06 1.2
-@@ -6,4 +6,7 @@
- */
-
- #define PPTP_SOCKET_PREFIX "/var/run/pptp/"
-+
-+#ifndef PPTP_CALLMGR_BINARY
- #define PPTP_CALLMGR_BINARY "./pptp_callmgr"
-+#endif
diff --git a/net/pptpclient/files/patch-pptp_compat.c b/net/pptpclient/files/patch-pptp_compat.c
deleted file mode 100644
index b1789e25d92a..000000000000
--- a/net/pptpclient/files/patch-pptp_compat.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- pptp_compat.c.orig 2008-05-19 03:44:02.000000000 +0800
-+++ pptp_compat.c 2008-05-19 03:44:45.000000000 +0800
-@@ -7,7 +7,7 @@
- #include <fcntl.h>
- #include <sys/types.h>
- #include <unistd.h>
--#include <stropts.h>
-+#include <sys/un.h>
- #include <stdlib.h>
- #include <strings.h>
- #include "pptp_compat.h"
diff --git a/net/pptpclient/pkg-plist b/net/pptpclient/pkg-plist
deleted file mode 100644
index a1d7a93067f7..000000000000
--- a/net/pptpclient/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-sbin/pptp
-%%EXAMPLESDIR%%/README
-%%EXAMPLESDIR%%/ppp.conf
-@dirrm %%EXAMPLESDIR%%