aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-02-28 14:59:13 +0800
committerjgh <jgh@FreeBSD.org>2013-02-28 14:59:13 +0800
commit88bfc45ac7e3242567e7c8c8e3ed6f71768f422f (patch)
tree962f66d67db5c0b2600bde6ceff77f0d578e995d /net
parent98dc17783e46085de101dec374d5621e3825674b (diff)
downloadfreebsd-ports-gnome-88bfc45ac7e3242567e7c8c8e3ed6f71768f422f.tar.gz
freebsd-ports-gnome-88bfc45ac7e3242567e7c8c8e3ed6f71768f422f.tar.zst
freebsd-ports-gnome-88bfc45ac7e3242567e7c8c8e3ed6f71768f422f.zip
- add new port: net/svnup
A lightweight, dependency-free program to pull source using the svn protocol. WWW: http://jcm.dsl.visi.com/freebsd/svnup/ PR: 176381 Submitted by: jcm@visi.com
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/svnup/Makefile27
-rw-r--r--net/svnup/distinfo2
-rw-r--r--net/svnup/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index aa79e75e66a7..ab6eb0bacb2b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1123,6 +1123,7 @@
SUBDIR += subnetcalc
SUBDIR += suckblow
SUBDIR += sup
+ SUBDIR += svnup
SUBDIR += tableutil
SUBDIR += tac_plus-libradius
SUBDIR += tac_plus4
diff --git a/net/svnup/Makefile b/net/svnup/Makefile
new file mode 100644
index 000000000000..9d982040ec19
--- /dev/null
+++ b/net/svnup/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= svnup
+PORTVERSION= 0.55
+CATEGORIES= net
+MASTER_SITES= http://jcm.dsl.visi.com/freebsd/svnup/
+
+MAINTAINER= jcm@visi.com
+COMMENT= Lightweight program to pull source using the svn protocol
+
+LICENSE= BSD
+
+LDFLAGS+= -lmd
+USE_XZ= yes
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME}
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} -o ${PORTNAME} ${CFLAGS} ${PORTNAME}.c ${LDFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/net/svnup/distinfo b/net/svnup/distinfo
new file mode 100644
index 000000000000..a4a21b928a4f
--- /dev/null
+++ b/net/svnup/distinfo
@@ -0,0 +1,2 @@
+SHA256 (svnup-0.55.tar.xz) = b2471d33d19cf0b6cb1516c0ca56c7e4a0eed578db0a04d0c3eb5309f211202d
+SIZE (svnup-0.55.tar.xz) = 9160
diff --git a/net/svnup/pkg-descr b/net/svnup/pkg-descr
new file mode 100644
index 000000000000..5c63687b5a6d
--- /dev/null
+++ b/net/svnup/pkg-descr
@@ -0,0 +1,3 @@
+A lightweight, dependency-free program to pull source using the svn protocol.
+
+WWW: http://jcm.dsl.visi.com/freebsd/svnup/