aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-05 19:09:23 +0800
committeraz <az@FreeBSD.org>2013-09-05 19:09:23 +0800
commitd2098cbfa91712f1b21a5f09361643baf852d19f (patch)
tree7050f184ad070ef903d6ac4ab7b35140e7381404 /net
parent61ac1231dcd32de44f84ea46c3fc1d7e4355c792 (diff)
downloadfreebsd-ports-gnome-d2098cbfa91712f1b21a5f09361643baf852d19f.tar.gz
freebsd-ports-gnome-d2098cbfa91712f1b21a5f09361643baf852d19f.tar.zst
freebsd-ports-gnome-d2098cbfa91712f1b21a5f09361643baf852d19f.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'net')
-rw-r--r--net/dhcpdump/Makefile3
-rw-r--r--net/p5-BBS-UserInfo-SOB/Makefile3
-rw-r--r--net/p5-Cisco-IPPhone/Makefile3
-rw-r--r--net/p5-Daemon-Generic/Makefile3
-rw-r--r--net/p5-Data-IPV4-Range-Parse/Makefile3
-rw-r--r--net/p5-IO-Socket-INET6/Makefile3
-rw-r--r--net/p5-Net-CIDR-MobileJP/Makefile3
-rw-r--r--net/p5-Net-Flow/Makefile3
-rw-r--r--net/p5-Net-LDAP-LDAPhash/Makefile3
-rw-r--r--net/p5-Net-RawIP/Makefile3
-rw-r--r--net/p5-Net-SFTP-Foreign/Makefile3
-rw-r--r--net/p5-Net-Telnet-Netscreen/Makefile3
-rw-r--r--net/p5-Net-Telnet/Makefile3
-rw-r--r--net/p5-Net-TiVo/Makefile3
-rw-r--r--net/p5-Net-Z3950-ZOOM/Makefile3
-rw-r--r--net/p5-OurNet-BBSAgent/Makefile3
-rw-r--r--net/p5-XML-RPC-Fast/Makefile3
-rw-r--r--net/shelldap/Makefile2
-rw-r--r--net/wping/Makefile2
19 files changed, 36 insertions, 19 deletions
diff --git a/net/dhcpdump/Makefile b/net/dhcpdump/Makefile
index fb1d31cec34b..b9f120c570ac 100644
--- a/net/dhcpdump/Makefile
+++ b/net/dhcpdump/Makefile
@@ -16,7 +16,8 @@ COMMENT= Decode and diagnose sniffed DHCP packets
MAN8= dhcpdump.8
PLIST_FILES= bin/dhcpdump
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dhcpdump ${PREFIX}/bin
diff --git a/net/p5-BBS-UserInfo-SOB/Makefile b/net/p5-BBS-UserInfo-SOB/Makefile
index 844464b77cb4..d5d10850e029 100644
--- a/net/p5-BBS-UserInfo-SOB/Makefile
+++ b/net/p5-BBS-UserInfo-SOB/Makefile
@@ -17,7 +17,8 @@ COMMENT= Get user information of SOB-style BBS
RUN_DEPENDS= p5-Expect>=0:${PORTSDIR}/lang/p5-Expect
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= BBS::UserInfo::SOB.3
diff --git a/net/p5-Cisco-IPPhone/Makefile b/net/p5-Cisco-IPPhone/Makefile
index 917d7ceb8392..6c9f6fd52416 100644
--- a/net/p5-Cisco-IPPhone/Makefile
+++ b/net/p5-Cisco-IPPhone/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= numisemis@yahoo.com
COMMENT= Package for creating Cisco IPPhone XML objects
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Cisco::IPPhone.3
diff --git a/net/p5-Daemon-Generic/Makefile b/net/p5-Daemon-Generic/Makefile
index 128523369a3b..96c2a9c2cb3e 100644
--- a/net/p5-Daemon-Generic/Makefile
+++ b/net/p5-Daemon-Generic/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-File-Flock>=0:${PORTSDIR}/devel/p5-File-Flock \
p5-Eval-LineNumbers>=0:${PORTSDIR}/devel/p5-Eval-LineNumbers
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Daemon::Generic.3 \
Daemon::Generic::Event.3 \
diff --git a/net/p5-Data-IPV4-Range-Parse/Makefile b/net/p5-Data-IPV4-Range-Parse/Makefile
index b24b60143899..4752b3ed3340 100644
--- a/net/p5-Data-IPV4-Range-Parse/Makefile
+++ b/net/p5-Data-IPV4-Range-Parse/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Perl extension parsing IPv4 ranges
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::IPV4::Range::Parse.3
diff --git a/net/p5-IO-Socket-INET6/Makefile b/net/p5-IO-Socket-INET6/Makefile
index fa49a06a7aae..30d95eeb882b 100644
--- a/net/p5-IO-Socket-INET6/Makefile
+++ b/net/p5-IO-Socket-INET6/Makefile
@@ -14,7 +14,8 @@ COMMENT= Perl module with object interface to AF_INET6 domain sockets
BUILD_DEPENDS= p5-Socket6>=0.12:${PORTSDIR}/net/p5-Socket6
RUN_DEPENDS= p5-Socket6>=0.12:${PORTSDIR}/net/p5-Socket6
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IO::Socket::INET6.3
diff --git a/net/p5-Net-CIDR-MobileJP/Makefile b/net/p5-Net-CIDR-MobileJP/Makefile
index 64c1d90b05f0..997abab23bdd 100644
--- a/net/p5-Net-CIDR-MobileJP/Makefile
+++ b/net/p5-Net-CIDR-MobileJP/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= \
p5-YAML>0:${PORTSDIR}/textproc/p5-YAML
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::CIDR::MobileJP.3 \
Net::CIDR::net-cidr-mobilejp-scraper.3
diff --git a/net/p5-Net-Flow/Makefile b/net/p5-Net-Flow/Makefile
index 1530e366455c..f8aec61ce01f 100644
--- a/net/p5-Net-Flow/Makefile
+++ b/net/p5-Net-Flow/Makefile
@@ -13,7 +13,8 @@ COMMENT= Decode and encode NetFlow/IPFIX datagrams
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Flow.3
diff --git a/net/p5-Net-LDAP-LDAPhash/Makefile b/net/p5-Net-LDAP-LDAPhash/Makefile
index 660598f775d5..48e626b89943 100644
--- a/net/p5-Net-LDAP-LDAPhash/Makefile
+++ b/net/p5-Net-LDAP-LDAPhash/Makefile
@@ -18,7 +18,8 @@ COMMENT= Make a hash out of the return from a search using Net::LDAP::Search
BUILD_DEPENDS= p5-perl-ldap>=0.39:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS= p5-perl-ldap>=0.39:${PORTSDIR}/net/p5-perl-ldap
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::LDAP::LDAPhash.3
diff --git a/net/p5-Net-RawIP/Makefile b/net/p5-Net-RawIP/Makefile
index 849765f7a027..d4545244da30 100644
--- a/net/p5-Net-RawIP/Makefile
+++ b/net/p5-Net-RawIP/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= A perl module to manipulate raw IP packets
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::RawIP.3 Net::RawIP::libpcap.3
.include <bsd.port.mk>
diff --git a/net/p5-Net-SFTP-Foreign/Makefile b/net/p5-Net-SFTP-Foreign/Makefile
index 9e7d37af5e30..a86fae5f5935 100644
--- a/net/p5-Net-SFTP-Foreign/Makefile
+++ b/net/p5-Net-SFTP-Foreign/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::SFTP::Foreign.3 \
Net::SFTP::Foreign::Attributes.3 \
diff --git a/net/p5-Net-Telnet-Netscreen/Makefile b/net/p5-Net-Telnet-Netscreen/Makefile
index ccf2187dd4c6..d0b793a85f80 100644
--- a/net/p5-Net-Telnet-Netscreen/Makefile
+++ b/net/p5-Net-Telnet-Netscreen/Makefile
@@ -17,7 +17,8 @@ COMMENT= A Perl interface for interact with a Netscreen firewall
BUILD_DEPENDS= p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Telnet::Netscreen.3
diff --git a/net/p5-Net-Telnet/Makefile b/net/p5-Net-Telnet/Makefile
index 70259491a8d4..cd90ecb931c6 100644
--- a/net/p5-Net-Telnet/Makefile
+++ b/net/p5-Net-Telnet/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl5 module to access and use telnet protocol
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Telnet.3
diff --git a/net/p5-Net-TiVo/Makefile b/net/p5-Net-TiVo/Makefile
index 327912418b68..aec413c776dd 100644
--- a/net/p5-Net-TiVo/Makefile
+++ b/net/p5-Net-TiVo/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::TiVo.3 \
Net::TiVo::Show.3 \
diff --git a/net/p5-Net-Z3950-ZOOM/Makefile b/net/p5-Net-Z3950-ZOOM/Makefile
index fe5a822a4e42..b45affe28143 100644
--- a/net/p5-Net-Z3950-ZOOM/Makefile
+++ b/net/p5-Net-Z3950-ZOOM/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= yaz.4:${PORTSDIR}/net/yaz
BUILD_DEPENDS= p5-MARC-Record>=1.38:${PORTSDIR}/textproc/p5-MARC-Record
RUN_DEPENDS= p5-MARC-Record>=1.38:${PORTSDIR}/textproc/p5-MARC-Record
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Z3950::ZOOM.3 ZOOM.3
diff --git a/net/p5-OurNet-BBSAgent/Makefile b/net/p5-OurNet-BBSAgent/Makefile
index ad084f6082af..2d17e7976832 100644
--- a/net/p5-OurNet-BBSAgent/Makefile
+++ b/net/p5-OurNet-BBSAgent/Makefile
@@ -17,7 +17,8 @@ COMMENT= Scriptable telnet-based virtual users
BUILD_DEPENDS= p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= OurNet::BBSAgent.3
diff --git a/net/p5-XML-RPC-Fast/Makefile b/net/p5-XML-RPC-Fast/Makefile
index b6b8abe5101c..5cc2faacab18 100644
--- a/net/p5-XML-RPC-Fast/Makefile
+++ b/net/p5-XML-RPC-Fast/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::RPC::Enc.3 \
XML::RPC::Enc::LibXML.3 \
diff --git a/net/shelldap/Makefile b/net/shelldap/Makefile
index 135c68a6fd6e..6abd0e0b59d2 100644
--- a/net/shelldap/Makefile
+++ b/net/shelldap/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= p5-Algorithm-Diff>=0:${PORTSDIR}/devel/p5-Algorithm-Diff \
p5-ReadLine-Gnu>=0:${PORTSDIR}/devel/p5-ReadLine-Gnu \
p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
-USE_PERL5= yes
+USES= perl5
MAN1= shelldap.1
diff --git a/net/wping/Makefile b/net/wping/Makefile
index fb9244652197..6f320901cfa2 100644
--- a/net/wping/Makefile
+++ b/net/wping/Makefile
@@ -17,7 +17,7 @@ COMMENT= A Web-based graphical ping log
RUN_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
-USE_PERL5= yes
+USES= perl5
USE_BZIP2= yes
NO_BUILD= yes