aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-03-04 05:01:37 +0800
committerhrs <hrs@FreeBSD.org>2013-03-04 05:01:37 +0800
commitd72b5e98744b510a3db7c1cc56dd1b61d72bfb6a (patch)
tree293c74ee74afa3474907b33ed32a63e0cff838ac /net
parent8986ee2e733d78344b96d93e641db716c2c0e6de (diff)
downloadfreebsd-ports-gnome-d72b5e98744b510a3db7c1cc56dd1b61d72bfb6a.tar.gz
freebsd-ports-gnome-d72b5e98744b510a3db7c1cc56dd1b61d72bfb6a.tar.zst
freebsd-ports-gnome-d72b5e98744b510a3db7c1cc56dd1b61d72bfb6a.zip
- Add https support.
- Take maintainership.
Diffstat (limited to 'net')
-rw-r--r--net/http_ping/Makefile12
-rw-r--r--net/http_ping/files/patch-Makefile33
2 files changed, 38 insertions, 7 deletions
diff --git a/net/http_ping/Makefile b/net/http_ping/Makefile
index 96c1caebf4c1..c48d29201c32 100644
--- a/net/http_ping/Makefile
+++ b/net/http_ping/Makefile
@@ -1,19 +1,17 @@
-# New ports collection makefile for: http_ping
-# Date created: 11 August 2001
-# Whom: dd
-#
+# Created by: Dima Dorfman <dd@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= http_ping
PORTVERSION= 20050629
+PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= http://www.acme.com/software/${PORTNAME}/
DISTNAME= ${PORTNAME}_29jun2005
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Sends HTTP requests every few seconds and times how long they take
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Measure HTTP Latency
+USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN1= http_ping.1
MANCOMPRESSED= no
diff --git a/net/http_ping/files/patch-Makefile b/net/http_ping/files/patch-Makefile
new file mode 100644
index 000000000000..73bc1d8f8d4e
--- /dev/null
+++ b/net/http_ping/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig 2013-03-03 07:36:07.000000000 +0900
++++ Makefile 2013-03-03 07:44:01.000000000 +0900
+@@ -14,13 +14,15 @@
+ #SSL_INC = -I$(SSL_TREE)/include
+ #SSL_LIBS = -L$(SSL_TREE)/lib -lssl -lcrypto
+
+-
+-BINDIR = /usr/local/bin
+-MANDIR = /usr/local/man/man1
+-CC = gcc -Wall
+-CFLAGS = -O $(SRANDOM_DEFS) $(SSL_DEFS) $(SSL_INC)
++SSL_DEFS= -DUSE_SSL ${OPENSSL_CFLAGS}
++SSL_INC= -I${OPENSSLINC}
++SSL_LIBS= -L${OPENSSLLIB} -lssl -lcrypto
++bINDIR = ${PREFIX}/bin
++MANDIR = ${MANPREFIX}/man/man1
++CC?= gcc -Wall
++CFLAGS+= -g $(SRANDOM_DEFS) $(SSL_DEFS) $(SSL_INC)
+ #CFLAGS = -g $(SRANDOM_DEFS) $(SSL_DEFS) $(SSL_INC)
+-LDFLAGS = -s $(SSL_LIBS) $(SYSV_LIBS)
++LDFLAGS+= -s -lssl -lcrypto
+ #LDFLAGS = -g $(SSL_LIBS) $(SYSV_LIBS)
+
+ all: http_ping
+@@ -32,7 +34,7 @@
+ $(CC) $(CFLAGS) -c http_ping.c
+
+
+-install: all
++install:
+ rm -f $(BINDIR)/http_ping
+ cp http_ping $(BINDIR)
+ rm -f $(MANDIR)/http_ping.1