aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-01-16 11:06:59 +0800
committermarcus <marcus@FreeBSD.org>2003-01-16 11:06:59 +0800
commit03ba383eabfc4e0cf9fdb7ee49b2d690a8925c62 (patch)
treea18eb8dc581b38d7d9529a930e94d8b4898e3620 /net
parenta1eed9bba919334d317b709fb68a130d8c581fb7 (diff)
downloadfreebsd-ports-gnome-03ba383eabfc4e0cf9fdb7ee49b2d690a8925c62.tar.gz
freebsd-ports-gnome-03ba383eabfc4e0cf9fdb7ee49b2d690a8925c62.tar.zst
freebsd-ports-gnome-03ba383eabfc4e0cf9fdb7ee49b2d690a8925c62.zip
Add standard termination strings and correct the message conversion between
official yahoo messenger and gaim. PR: 47125 Submitted by: leeym Noticed by: Dustin Liu <dustinl@yahoo-inc.com> Obtained from: Palatis <tblanku@yahoo.com.tw>
Diffstat (limited to 'net')
-rw-r--r--net/gaim-snapshot/Makefile1
-rw-r--r--net/gaim-snapshot/files/patch-src_protocols_yahoo_yahoo.c12
-rw-r--r--net/gaim/Makefile1
-rw-r--r--net/gaim/files/patch-src_protocols_yahoo_yahoo.c12
4 files changed, 26 insertions, 0 deletions
diff --git a/net/gaim-snapshot/Makefile b/net/gaim-snapshot/Makefile
index a146954ba164..96f688e1d348 100644
--- a/net/gaim-snapshot/Makefile
+++ b/net/gaim-snapshot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gaim
PORTVERSION= 0.59.8
+PORTREVISION= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim-snapshot/files/patch-src_protocols_yahoo_yahoo.c b/net/gaim-snapshot/files/patch-src_protocols_yahoo_yahoo.c
new file mode 100644
index 000000000000..371395839df0
--- /dev/null
+++ b/net/gaim-snapshot/files/patch-src_protocols_yahoo_yahoo.c
@@ -0,0 +1,12 @@
+--- src/protocols/yahoo/yahoo.c.orig Wed Jan 15 21:19:22 2003
++++ src/protocols/yahoo/yahoo.c Wed Jan 15 21:19:46 2003
+@@ -1196,6 +1196,9 @@
+ yahoo_packet_hash(pkt, 1, gc->displayname);
+ yahoo_packet_hash(pkt, 5, who);
+ yahoo_packet_hash(pkt, 14, utf8);
++ yahoo_packet_hash(pkt, 63, ";0");
++ yahoo_packet_hash(pkt, 64, "0");
++ yahoo_packet_hash(pkt, 97, "1");
+
+ g_free (utf8);
+
diff --git a/net/gaim/Makefile b/net/gaim/Makefile
index a146954ba164..96f688e1d348 100644
--- a/net/gaim/Makefile
+++ b/net/gaim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gaim
PORTVERSION= 0.59.8
+PORTREVISION= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim/files/patch-src_protocols_yahoo_yahoo.c b/net/gaim/files/patch-src_protocols_yahoo_yahoo.c
new file mode 100644
index 000000000000..371395839df0
--- /dev/null
+++ b/net/gaim/files/patch-src_protocols_yahoo_yahoo.c
@@ -0,0 +1,12 @@
+--- src/protocols/yahoo/yahoo.c.orig Wed Jan 15 21:19:22 2003
++++ src/protocols/yahoo/yahoo.c Wed Jan 15 21:19:46 2003
+@@ -1196,6 +1196,9 @@
+ yahoo_packet_hash(pkt, 1, gc->displayname);
+ yahoo_packet_hash(pkt, 5, who);
+ yahoo_packet_hash(pkt, 14, utf8);
++ yahoo_packet_hash(pkt, 63, ";0");
++ yahoo_packet_hash(pkt, 64, "0");
++ yahoo_packet_hash(pkt, 97, "1");
+
+ g_free (utf8);
+