aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
committermat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
commit0691688a506fc2dffc574eeeb80dc0d876378fed (patch)
tree204c01c7973e83331fc29d8b09e59b3e9f219bd6 /net
parent33639ffbb666f12097ddeff5ef7da2226febf15b (diff)
downloadfreebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.gz
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.zst
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.zip
Remove OSVERSION checks that do not make sense any more.
For example (${OSVERSION} >= 900000 && ${OSVERSION} < 900021) is always true, as is (${OSVERSION} > 900002 || ${OSVERSION} < 900000 && ${OSVERSION} > 800107). Regarding patches, when an EXTRA_PATCHES is no longer needed, I remove it, when it is always needed, I renamed it, in one case, I merged two patches. Differential Revision: https://reviews.freebsd.org/D2209
Diffstat (limited to 'net')
-rw-r--r--net/freeradius3/Makefile4
-rw-r--r--net/iet/Makefile8
-rw-r--r--net/libpcap/Makefile2
-rw-r--r--net/ndisc6/Makefile4
-rw-r--r--net/ndisc6/files/patch-rdnssd__rdnssd.h (renamed from net/ndisc6/files/extra-patch-rdnssd__rdnssd.h)0
-rw-r--r--net/netatalk3/Makefile6
-rw-r--r--net/netatalk3/pkg-plist2
-rw-r--r--net/rtg/Makefile6
-rw-r--r--net/samba36/Makefile5
-rw-r--r--net/samba4/Makefile2
-rw-r--r--net/samba41/Makefile2
-rw-r--r--net/ssmping/Makefile8
-rw-r--r--net/tcpdump398/Makefile13
-rw-r--r--net/wmwlmon/Makefile12
-rw-r--r--net/wmwlmon/files/patch-wl.c (renamed from net/wmwlmon/files/extra-patch-wl.c)0
-rw-r--r--net/wmwlmon/files/patch-wmwlmon.1 (renamed from net/wmwlmon/files/extra-patch-wmwlmon.1)0
16 files changed, 7 insertions, 67 deletions
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index c2fc03eb5ba1..6aecbbc62e48 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -296,10 +296,6 @@ WITH_OPENSSL_PORT=yes
# if we're installing, place sample configs into ${EXAMPLESDIR}
MAKE_ARGS+= raddbdir="${EXAMPLESDIR}/raddb" R=${STAGEDIR}
-.if ${ARCH} == "sparc64" && ${OSVERSION} < 700000
-BROKEN= Does not build on sparc64-6
-.endif
-
FREERADIUS_LIBDIR= lib/freeradius-${PORTVERSION}
PLIST_SUB+= LIBDIR="${FREERADIUS_LIBDIR}"
USE_LDCONFIG= ${PREFIX}/${FREERADIUS_LIBDIR}
diff --git a/net/iet/Makefile b/net/iet/Makefile
index 436d4760854b..c285cb7364b8 100644
--- a/net/iet/Makefile
+++ b/net/iet/Makefile
@@ -31,17 +31,11 @@ MAKE_ENV+= KMODDIR=${KMODDIR} DATADIR=${DATADIR} SYSDIR="${SRC_BASE}/sys"
IET_CONF_FILES= ietd.conf initiators.allow initiators.deny targets.allow
-.include <bsd.port.pre.mk>
-
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel sources to build
.endif
-.if ${OSVERSION} < 800107
-BROKEN= requires 8.0-RELEASE or higher
-.endif
-
pre-install:
${MKDIR} ${STAGEDIR}${DATADIR} ${STAGEDIR}${KMODDIR} ${STAGEDIR}${ETCDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
index c314c1763eb3..c50fd56e5dec 100644
--- a/net/libpcap/Makefile
+++ b/net/libpcap/Makefile
@@ -130,9 +130,7 @@ post-install:
# package will be run on a system that does not have cloning (7.x).
# Always use bpf device, but specify CFLAGS if we have cloning.
CONFIGURE_ARGS+= --with-pcap=bpf
-.if ${OSVERSION} > 800043
CFLAGS+= -DHAVE_DEVICE_CLONING=1
-.endif
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
CFLAGS+= -fPIC
diff --git a/net/ndisc6/Makefile b/net/ndisc6/Makefile
index f59ec5a8576e..32e78ba93a02 100644
--- a/net/ndisc6/Makefile
+++ b/net/ndisc6/Makefile
@@ -27,10 +27,6 @@ OPTIONS_DEFINE= DOCS NLS
.include <bsd.port.options.mk>
-.if ${OSVERSION} >= 803000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-rdnssd__rdnssd.h
-.endif
-
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
LDFLAGS+= -lintl
diff --git a/net/ndisc6/files/extra-patch-rdnssd__rdnssd.h b/net/ndisc6/files/patch-rdnssd__rdnssd.h
index 1aa03c3104b9..1aa03c3104b9 100644
--- a/net/ndisc6/files/extra-patch-rdnssd__rdnssd.h
+++ b/net/ndisc6/files/patch-rdnssd__rdnssd.h
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index bfc886a27f2f..651aaef59a5b 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -139,12 +139,6 @@ CONFIGURE_ARGS+=--enable-tcp-wrappers
CONFIGURE_ARGS+=--disable-tcp-wrappers
.endif
-.if ${OSVERSION} < 800031
-PLIST_SUB+= ATFUNCS="@comment "
-.else
-PLIST_SUB+= ATFUNCS=""
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
diff --git a/net/netatalk3/pkg-plist b/net/netatalk3/pkg-plist
index eb900d779e5f..79c64827cf44 100644
--- a/net/netatalk3/pkg-plist
+++ b/net/netatalk3/pkg-plist
@@ -1,4 +1,4 @@
-%%ATFUNCS%%bin/ad
+bin/ad
bin/afpldaptest
bin/afppasswd
%%DBUS%%bin/afpstats
diff --git a/net/rtg/Makefile b/net/rtg/Makefile
index 65c314ae75bb..c99a9e3ab911 100644
--- a/net/rtg/Makefile
+++ b/net/rtg/Makefile
@@ -43,15 +43,11 @@ WANT_PHP_WEB= yes
USE_PHP= mysqli spl
.endif
-.include <bsd.port.pre.mk>
-
-.if ( ${OSVERSION} >= 800040 )
CFLAGS+= -fstack-protector
LDFLAGS+= -fstack-protector
-.endif
post-patch:
@${MV} ${WRKSRC}/etc/rtg.conf ${WRKSRC}/etc/rtg.conf.sample
@${MV} ${WRKSRC}/etc/routers ${WRKSRC}/etc/routers.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/samba36/Makefile b/net/samba36/Makefile
index bef80df98900..09b88eb3c71a 100644
--- a/net/samba36/Makefile
+++ b/net/samba36/Makefile
@@ -260,18 +260,13 @@ CONFIGURE_ARGS+= --disable-fam
.if ${PORT_OPTIONS:MACL_SUPPORT}
CONFIGURE_ARGS+= --with-acl-support
-. if ${OSVERSION} > 800000
WANT_EXP_MODULES+= vfs_zfsacl
LIB_DEPENDS+= libsunacl.so:${PORTSDIR}/sysutils/libsunacl
-. endif
.else
CONFIGURE_ARGS+= --without-acl-support
.endif
.if ${PORT_OPTIONS:MAIO_SUPPORT}
-.if ${OSVERSION} < 700055
-IGNORE= an AIO support requires 7.0-RELEASE or later. Disable AIO support
-.endif
CONFIGURE_ARGS+= --with-aio-support
.else
CONFIGURE_ARGS+= --without-aio-support
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index 11277457e24b..942d7316dd6d 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -219,11 +219,9 @@ WANT_EXP_MODULES= idmap_ad vfs_cacheprime gpext_scripts gpext_security gpext_reg
.endif
.if ${PORT_OPTIONS:MACL_SUPPORT}
-. if ${OSVERSION} > 800000
LIB_DEPENDS+= libsunacl.so:${PORTSDIR}/sysutils/libsunacl
WANT_EXP_MODULES+= vfs_zfsacl
SAMBA4_MODULES+= vfs_zfsacl
-. endif
CONFIGURE_ARGS+= --with-acl-support
.else
CONFIGURE_ARGS+= --without-acl-support
diff --git a/net/samba41/Makefile b/net/samba41/Makefile
index 91e145c58e3e..86c335aed84e 100644
--- a/net/samba41/Makefile
+++ b/net/samba41/Makefile
@@ -226,11 +226,9 @@ WANT_EXP_MODULES= idmap_ad vfs_cacheprime gpext_scripts gpext_security gpext_reg
.endif
.if ${PORT_OPTIONS:MACL_SUPPORT}
-. if ${OSVERSION} > 800000
LIB_DEPENDS+= libsunacl.so:${PORTSDIR}/sysutils/libsunacl
WANT_EXP_MODULES+= vfs_zfsacl
SAMBA4_MODULES+= vfs_zfsacl
-. endif
CONFIGURE_ARGS+= --with-acl-support
.else
CONFIGURE_ARGS+= --without-acl-support
diff --git a/net/ssmping/Makefile b/net/ssmping/Makefile
index dfdb1c9a15e6..e4a64632840d 100644
--- a/net/ssmping/Makefile
+++ b/net/ssmping/Makefile
@@ -14,12 +14,6 @@ PLIST_FILES= bin/ssmping bin/asmping bin/mcfirst sbin/ssmpingd \
man/man1/asmping.1.gz man/man1/mcfirst.1.gz \
man/man1/ssmping.1.gz
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} <= 800000
-IGNORE= does not work with FreeBSD 7.x
-.endif
-
do-install:
.for f in ssmping asmping mcfirst
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
@@ -27,4 +21,4 @@ do-install:
.endfor
${INSTALL_PROGRAM} ${WRKSRC}/ssmpingd ${STAGEDIR}${PREFIX}/sbin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/tcpdump398/Makefile b/net/tcpdump398/Makefile
index 89bc1f02a06b..0b5cb34bd315 100644
--- a/net/tcpdump398/Makefile
+++ b/net/tcpdump398/Makefile
@@ -13,17 +13,8 @@ PLIST_FILES= bin/tcpdump398 man/man1/tcpdump398.1.gz
USES= tar:bzip2
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800000
-IGNORE= comes with the base OS, only applicable for 8.0 and higher
-.endif
-
-post-build:
- ${GUNZIP_CMD} ${WRKSRC}/tcpdump.1.gz
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcpdump ${STAGEDIR}${PREFIX}/bin/tcpdump398
- ${INSTALL_MAN} ${WRKSRC}/tcpdump.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/tcpdump398.1
+ ${INSTALL_MAN} ${WRKSRC}/tcpdump.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1/tcpdump398.1.gz
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/wmwlmon/Makefile b/net/wmwlmon/Makefile
index 042726c08fa7..fbb365ba05a3 100644
--- a/net/wmwlmon/Makefile
+++ b/net/wmwlmon/Makefile
@@ -14,16 +14,6 @@ USE_XORG= x11 xpm
PLIST_FILES= bin/wmwlmon man/man1/wmwlmon.1.gz
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700052
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-wl.c ${PATCHDIR}/extra-patch-wmwlmon.1
-pre-everything::
- @${ECHO_CMD} "==========================================================="
- @${ECHO_CMD} "On FreeBSD > 700052 there is no wi(4) support in ${PORTNAME}"
- @${ECHO_CMD} "==========================================================="
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's#/usr/X11R6#${LOCALBASE}#g' \
-e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/Makefile
@@ -32,4 +22,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmwlmon ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/wmwlmon.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/wmwlmon/files/extra-patch-wl.c b/net/wmwlmon/files/patch-wl.c
index 01a400729411..01a400729411 100644
--- a/net/wmwlmon/files/extra-patch-wl.c
+++ b/net/wmwlmon/files/patch-wl.c
diff --git a/net/wmwlmon/files/extra-patch-wmwlmon.1 b/net/wmwlmon/files/patch-wmwlmon.1
index b41194fab860..b41194fab860 100644
--- a/net/wmwlmon/files/extra-patch-wmwlmon.1
+++ b/net/wmwlmon/files/patch-wmwlmon.1