aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrezny <rezny@FreeBSD.org>2017-02-23 03:51:08 +0800
committerrezny <rezny@FreeBSD.org>2017-02-23 03:51:08 +0800
commit0916e2e9a7ba4e44d1c8a2a9f54b67cf8ce4e8a4 (patch)
treed9976fc873327bcb7933618385c7274451df0c82 /net
parent806a8a8d9f591e514bb34ebeb15a14232d7c63ac (diff)
downloadfreebsd-ports-gnome-0916e2e9a7ba4e44d1c8a2a9f54b67cf8ce4e8a4.tar.gz
freebsd-ports-gnome-0916e2e9a7ba4e44d1c8a2a9f54b67cf8ce4e8a4.tar.zst
freebsd-ports-gnome-0916e2e9a7ba4e44d1c8a2a9f54b67cf8ce4e8a4.zip
Replace USE_OPENSSL with USES=ssl and bump portrevision for SSL changes.
This should have been part of the prior commit, oops. PR: 216781 Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D9727
Diffstat (limited to 'net')
-rw-r--r--net/qt4-network/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index aad22f0c4f2b..9271b01ef690 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -3,7 +3,7 @@
PORTNAME= network
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
PKGNAMEPREFIX= qt4-
@@ -15,11 +15,11 @@ LICENSE_COMB= dual
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+USES= ssl
USE_QT4= qmake_build moc_build rcc_build corelib
QT_DIST= yes
HAS_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
-USE_OPENSSL= yes
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
@@ -55,7 +55,8 @@ post-configure:
-E -e 's|(.*location=).*uic|\1${PREFIX}/${QT_BINDIR_REL}/${UIC:T}|g' \
${WRKSRC}/lib/pkgconfig/QtNetwork.pc
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
- ${WRKSRC}/src/network/ssl/qsslsocket_openssl.cpp \
+ ${WRKSRC}/src/network/ssl/qsslsocket_openssl.cpp
+ ${REINPLACE_CMD} -e 's|%%OPENSSLLIB%%|${OPENSSLLIB}|g' \
${WRKSRC}/src/network/ssl/qsslsocket_openssl_symbols.cpp
.include <bsd.port.mk>