aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2006-04-13 19:16:32 +0800
committeranray <anray@FreeBSD.org>2006-04-13 19:16:32 +0800
commit0f36293a2b7033b617ac7f594c0f17a3b1f5b346 (patch)
tree37ceb347bb14b820ec51162284abe5f862a50701 /net
parentab014ed50d7a5a710c8db2d66512e1926a1bbb71 (diff)
downloadfreebsd-ports-gnome-0f36293a2b7033b617ac7f594c0f17a3b1f5b346.tar.gz
freebsd-ports-gnome-0f36293a2b7033b617ac7f594c0f17a3b1f5b346.tar.zst
freebsd-ports-gnome-0f36293a2b7033b617ac7f594c0f17a3b1f5b346.zip
- This patch will fix net/lambamoo to build on 6.x. The problem exists when the
configure script sets YACC in the Makefile. It sets it to "YACC= bison -y" on 6.x systems. For one reason or another this does not work. Where as on 4.x systems, it sets "YACC= byacc" which works fine. I set YACC=${YACC} in CONFIGURE_ENV to fix this problem. I also added the dependency for bison (USE_BISON) as well as adding MASTER_SITE_SOURCEFORGE into the MASTER_SITES. [1] - Respect CFLAGS. - Pass maintainership to submitter. [1] PR: ports/93984 [1] Submitted by: Frank Laszlo <laszlof@vonostingroup.com> [1]
Diffstat (limited to 'net')
-rw-r--r--net/lambdamoo/Makefile7
-rw-r--r--net/lambdamoo/files/patch-Makefile.in11
2 files changed, 16 insertions, 2 deletions
diff --git a/net/lambdamoo/Makefile b/net/lambdamoo/Makefile
index dd8de7c8c40a..87d62efda524 100644
--- a/net/lambdamoo/Makefile
+++ b/net/lambdamoo/Makefile
@@ -8,15 +8,18 @@
PORTNAME= lambdamoo
PORTVERSION= 1.8.1
CATEGORIES= net
-MASTER_SITES= http://download.sourceforge.net/lambdamoo/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= LambdaMOO-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.ORG
+MAINTAINER= laszlof@vonostingroup.com
COMMENT= The most commonly used program to run MOOs
WRKSRC= ${WRKDIR}/MOO-${PORTVERSION}
GNU_CONFIGURE= yes
ALL_TARGET=
+CONFIGURE_ENV= YACC=${YACC}
+USE_BISON= yes
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/moo ${PREFIX}/sbin
diff --git a/net/lambdamoo/files/patch-Makefile.in b/net/lambdamoo/files/patch-Makefile.in
new file mode 100644
index 000000000000..648516093750
--- /dev/null
+++ b/net/lambdamoo/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Apr 13 13:54:19 2006
++++ Makefile.in Thu Apr 13 13:54:25 2006
+@@ -17,7 +17,7 @@
+ LIBRARIES = @LIBS@
+ YACC = @YACC@
+
+-CFLAGS = -O
++CFLAGS?= -O
+ # If you're using GCC, you may prefer:
+ # CFLAGS = -O2 -finline-functions
+ #