aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2006-04-16 21:05:13 +0800
committerdelphij <delphij@FreeBSD.org>2006-04-16 21:05:13 +0800
commit16fc1bee540fa9b44273ad55a9608ee6fac7af3b (patch)
tree242895940f186dadb567d79c63bb9cb1141bd7d0 /net
parent93c0b2d89106cc9598b26d0fa062b48e864e047b (diff)
downloadfreebsd-ports-gnome-16fc1bee540fa9b44273ad55a9608ee6fac7af3b.tar.gz
freebsd-ports-gnome-16fc1bee540fa9b44273ad55a9608ee6fac7af3b.tar.zst
freebsd-ports-gnome-16fc1bee540fa9b44273ad55a9608ee6fac7af3b.zip
Correct a bug that makes inversed logic for SHELL backend.
PR: ports/95689 Submitted by: Dmitriy Kirhlarov <dkirhlarov oilspace com>
Diffstat (limited to 'net')
-rw-r--r--net/openldap23-server/Makefile6
-rw-r--r--net/openldap24-server/Makefile6
2 files changed, 6 insertions, 6 deletions
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 28fb3b78f9eb..605963c853c9 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -39,7 +39,7 @@ BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 0
+PORTREVISION_SERVER= 1
.if !defined(CLIENT_ONLY)
OPTIONS= SASL "With (Cyrus) SASL2 support" on \
@@ -269,10 +269,10 @@ CONFIGURE_SED+= -e 's,ol_DB_LIB=$$,&-l${BDBLIB:R},' \
.endif
.if defined(WITHOUT_SHELL)
+PLIST_SUB+= BACK_SHELL="@comment "
+.else
CONFIGURE_ARGS+= --enable-shell=${BACKEND_ENABLE}
PLIST_SUB+= BACK_SHELL=${BACKEND_PLIST}
-.else
-PLIST_SUB+= BACK_SHELL="@comment "
.endif
.if defined(WITH_PERL)
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 28fb3b78f9eb..605963c853c9 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -39,7 +39,7 @@ BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 0
+PORTREVISION_SERVER= 1
.if !defined(CLIENT_ONLY)
OPTIONS= SASL "With (Cyrus) SASL2 support" on \
@@ -269,10 +269,10 @@ CONFIGURE_SED+= -e 's,ol_DB_LIB=$$,&-l${BDBLIB:R},' \
.endif
.if defined(WITHOUT_SHELL)
+PLIST_SUB+= BACK_SHELL="@comment "
+.else
CONFIGURE_ARGS+= --enable-shell=${BACKEND_ENABLE}
PLIST_SUB+= BACK_SHELL=${BACKEND_PLIST}
-.else
-PLIST_SUB+= BACK_SHELL="@comment "
.endif
.if defined(WITH_PERL)