aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2002-06-05 17:51:38 +0800
committerdougb <dougb@FreeBSD.org>2002-06-05 17:51:38 +0800
commit17acb0e134eaedd730ff5b855f1103825cc53833 (patch)
tree8bec4cf1291187f4daa0a6bcaebabd392b7bee46 /net
parent56252351960c1dfec8d69319643affed2ac8afab (diff)
downloadfreebsd-ports-gnome-17acb0e134eaedd730ff5b855f1103825cc53833.tar.gz
freebsd-ports-gnome-17acb0e134eaedd730ff5b855f1103825cc53833.tar.zst
freebsd-ports-gnome-17acb0e134eaedd730ff5b855f1103825cc53833.zip
Update to the latest, 0.21. This version contains many changes,
please see the Changes file for details. Some of the new features include TSIG support (experimental), a name server module, fixes for bind() problems in 5.005.03, and more. The good news is that our friends in perldom have now seen the light and fixed the later versions of this module so that it does not (any longer) require perl 5.6.0 or higher. I've tested quite a lot of the functions on both a RELENG_4 with stock perl 5.005.03, and a 5-Current system with stock 5.6.1, and didn't have any problems. I also added a few files to the PORTDOCS option.
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net-DNS/Makefile13
-rw-r--r--net/p5-Net-DNS/distinfo2
-rw-r--r--net/p5-Net-DNS/pkg-plist9
3 files changed, 22 insertions, 2 deletions
diff --git a/net/p5-Net-DNS/Makefile b/net/p5-Net-DNS/Makefile
index fbd8ad07a015..a9a51c20d5fa 100644
--- a/net/p5-Net-DNS/Makefile
+++ b/net/p5-Net-DNS/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-DNS
-PORTVERSION= 0.14
+PORTVERSION= 0.21
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
@@ -14,6 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= DougB@FreeBSD.org
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -31,4 +34,12 @@ MAN3= Net::DNS.3 Net::DNS::Header.3 Net::DNS::Packet.3 \
Net::DNS::RR::NIMLOC.3 Net::DNS::RR::NSAP.3 \
Net::DNS::RR::NULL.3 Net::DNS::RR::PX.3 Net::DNS::Update.3
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/p5-Net-DNS
+.for file in Changes README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/p5-Net-DNS
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/net/p5-Net-DNS/distinfo b/net/p5-Net-DNS/distinfo
index 2d767496a812..aad41a944ec6 100644
--- a/net/p5-Net-DNS/distinfo
+++ b/net/p5-Net-DNS/distinfo
@@ -1 +1 @@
-MD5 (Net-DNS-0.14.tar.gz) = 23ff3111fe23b525422768dd0580c50d
+MD5 (Net-DNS-0.21.tar.gz) = ba1ff7001262b4aa6482de8e2694bb18
diff --git a/net/p5-Net-DNS/pkg-plist b/net/p5-Net-DNS/pkg-plist
index 11b69ea6fa5b..cb803f853ec0 100644
--- a/net/p5-Net-DNS/pkg-plist
+++ b/net/p5-Net-DNS/pkg-plist
@@ -1,11 +1,13 @@
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Header.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Nameserver.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Packet.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Question.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/A.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/AAAA.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/AFSDB.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/CERT.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/CNAME.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/EID.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/HINFO.pm
@@ -21,19 +23,26 @@ lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/NIMLOC.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/NS.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/NSAP.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/NULL.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/OPT.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/PTR.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/PX.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/RP.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/RT.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/SOA.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/SRV.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/TSIG.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/TXT.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/X25.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Resolver.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Select.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Update.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/DNS/.packlist
+%%PORTDOCS%%share/doc/p5-Net-DNS/Changes
+%%PORTDOCS%%share/doc/p5-Net-DNS/README
+%%PORTDOCS%%share/doc/p5-Net-DNS/TODO
@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR
@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/DNS
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/DNS
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true
+%%PORTDOCS%%@dirrm share/doc/p5-Net-DNS/