aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2017-03-23 20:54:46 +0800
committerrobak <robak@FreeBSD.org>2017-03-23 20:54:46 +0800
commit2716ac8fea6558d774220380548b1c2163f54a4b (patch)
treebfc721f545f7b5a026cf6676f3ac7a866cc59d61 /net
parent9b229e7ef9c4ad18b61f8d1fbeb50d8433ea2666 (diff)
downloadfreebsd-ports-gnome-2716ac8fea6558d774220380548b1c2163f54a4b.tar.gz
freebsd-ports-gnome-2716ac8fea6558d774220380548b1c2163f54a4b.tar.zst
freebsd-ports-gnome-2716ac8fea6558d774220380548b1c2163f54a4b.zip
net/gogoc: new patch with various improvements
- When shutdown, the correct behavior is to send SIGHUP. - New patch patch-icmp_echo_engine.c: When PID of the gogoc process greater than 65536, it can not perform timeout ping check correctly, due to echo_id in icmp_hdr is declared as uint16_t. - New patch patch-freebsd.sh: To mute dmesg noise "nd6_dad_timer: cancel DAD on tun0 because of ND6_IFF_IFDISABLED." - Don't overwrite gogoc.conf on install. PR: 211426 Submitted by: Clive Lin <clive@tongi.org> Approved by: maintainer timeout (8 months)
Diffstat (limited to 'net')
-rw-r--r--net/gogoc/Makefile2
-rw-r--r--net/gogoc/files/gogoc.in1
-rw-r--r--net/gogoc/files/patch-freebsd.sh10
-rw-r--r--net/gogoc/files/patch-icmp_echo_engine.c11
-rw-r--r--net/gogoc/pkg-plist3
5 files changed, 24 insertions, 3 deletions
diff --git a/net/gogoc/Makefile b/net/gogoc/Makefile
index 9128052d873d..d09ada31978c 100644
--- a/net/gogoc/Makefile
+++ b/net/gogoc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gogoc
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://gogo6.com/downloads/
DISTNAME= gogoc-1_2-RELEASE
diff --git a/net/gogoc/files/gogoc.in b/net/gogoc/files/gogoc.in
index 35c2d107e398..c78bb5fe283b 100644
--- a/net/gogoc/files/gogoc.in
+++ b/net/gogoc/files/gogoc.in
@@ -17,6 +17,7 @@
name="gogoc"
rcvar=gogoc_enable
+sig_stop="HUP"
command=%%LOCALBASE%%/bin/${name}
diff --git a/net/gogoc/files/patch-freebsd.sh b/net/gogoc/files/patch-freebsd.sh
new file mode 100644
index 000000000000..e8b5b987af34
--- /dev/null
+++ b/net/gogoc/files/patch-freebsd.sh
@@ -0,0 +1,10 @@
+--- gogoc-tsp/template/freebsd.sh~ 2016-07-28 01:31:15.964503000 +0800
++++ gogoc-tsp/template/freebsd.sh 2016-07-28 01:33:41.691541000 +0800
+@@ -212,6 +212,7 @@
+ #
+ # Configured tunnel config (IPv6)
+
++ Exec $ifconfig $TSP_TUNNEL_INTERFACE inet6 -ifdisabled
+ Exec $ifconfig $TSP_TUNNEL_INTERFACE inet6 $TSP_CLIENT_ADDRESS_IPV6 $TSP_SERVER_ADDRESS_IPV6 prefixlen $TSP_TUNNEL_PREFIXLEN alias
+ Exec $ifconfig $TSP_TUNNEL_INTERFACE mtu 1280
+ #
diff --git a/net/gogoc/files/patch-icmp_echo_engine.c b/net/gogoc/files/patch-icmp_echo_engine.c
new file mode 100644
index 000000000000..c43043f317bd
--- /dev/null
+++ b/net/gogoc/files/patch-icmp_echo_engine.c
@@ -0,0 +1,11 @@
+--- gogoc-tsp/src/net/icmp_echo_engine.c~ 2016-07-22 15:16:32.382995000 +0800
++++ gogoc-tsp/src/net/icmp_echo_engine.c 2016-07-22 15:16:44.244691000 +0800
+@@ -238,7 +238,7 @@
+ p_engine->clbk_recv = recv_clbk;
+
+ // Initialize engine socket variables.
+- p_engine->icmp_echo_id = pal_getpid();
++ p_engine->icmp_echo_id = pal_getpid() % 65536;
+ p_engine->icmp_saf = af;
+ switch( p_engine->icmp_saf )
+ {
diff --git a/net/gogoc/pkg-plist b/net/gogoc/pkg-plist
index c4e33190a1d5..cb33744c5cf5 100644
--- a/net/gogoc/pkg-plist
+++ b/net/gogoc/pkg-plist
@@ -1,6 +1,5 @@
bin/gogoc
-etc/gogoc.conf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gogoc.conf.sample
+@sample %%PORTEXAMPLES%%%%EXAMPLESDIR%%/gogoc.conf.sample etc/gogoc.conf
man/man5/gogoc.conf.5.gz
man/man8/gogoc.8.gz
template/README