aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-05-23 01:03:11 +0800
committerroam <roam@FreeBSD.org>2001-05-23 01:03:11 +0800
commit28517e50351ce37c27f78827baeaed8683f190e0 (patch)
tree66bf28faca09b1a3f53d8120cc8d2f72de0dcc1d /net
parente2513fc93a7bae80e4587ae192097caf3f09daee (diff)
downloadfreebsd-ports-gnome-28517e50351ce37c27f78827baeaed8683f190e0.tar.gz
freebsd-ports-gnome-28517e50351ce37c27f78827baeaed8683f190e0.tar.zst
freebsd-ports-gnome-28517e50351ce37c27f78827baeaed8683f190e0.zip
Add a new patch (which seems to avoid a null pointer dereference).
Bump PORTREVISION accordingly. Change the port maintainer. PR: 27536 Submitted by: both former and new maintainers :)
Diffstat (limited to 'net')
-rw-r--r--net/gtk+licq/Makefile4
-rw-r--r--net/gtk+licq/files/patch-src::functions.cpp15
2 files changed, 17 insertions, 2 deletions
diff --git a/net/gtk+licq/Makefile b/net/gtk+licq/Makefile
index 84ba3de7a125..b7a5f518aaec 100644
--- a/net/gtk+licq/Makefile
+++ b/net/gtk+licq/Makefile
@@ -7,11 +7,11 @@
PORTNAME= gtk+licq
PORTVERSION= 0.50.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://gtk.licq.org/download/
-MAINTAINER= ishmael27@home.com
+MAINTAINER= roman@xpert.com
BUILD_DEPENDS= ${LOCALBASE}/include/licq/licq_icqd.h:${PORTSDIR}/net/licq
LIB_DEPENDS= pspell.4:${PORTSDIR}/textproc/pspell
diff --git a/net/gtk+licq/files/patch-src::functions.cpp b/net/gtk+licq/files/patch-src::functions.cpp
new file mode 100644
index 000000000000..c8ee50072d05
--- /dev/null
+++ b/net/gtk+licq/files/patch-src::functions.cpp
@@ -0,0 +1,15 @@
+--- src/functions.cpp 2001/04/23 21:07:27 1.97
++++ src/functions.cpp 2001/05/17 08:34:51 1.98
+@@ -989,7 +989,11 @@
+ {
+ unsigned long *uinptr;
+ GtkWidget *parent=NULL;
+-
++
++ if (widget == NULL) {
++ return(0);
++ }
++
+ for (;;)
+ {
+ if (GTK_IS_MENU (widget)) {