aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorasmodai <asmodai@FreeBSD.org>2001-04-03 04:06:19 +0800
committerasmodai <asmodai@FreeBSD.org>2001-04-03 04:06:19 +0800
commit286acc4f087d4f734e53105ca1a597ad090c613b (patch)
tree0dcb5f8fba06c17db7211241b663ca11f968522f /net
parent27c3259963fdb2c45d532c7f2a817f9169d8c507 (diff)
downloadfreebsd-ports-gnome-286acc4f087d4f734e53105ca1a597ad090c613b.tar.gz
freebsd-ports-gnome-286acc4f087d4f734e53105ca1a597ad090c613b.tar.zst
freebsd-ports-gnome-286acc4f087d4f734e53105ca1a597ad090c613b.zip
Add p5-NetAddr-IP-Count:
This module implements a symplistic way to match individual IP Addresses to subnets. It can be used to, among other things, help analyze HTTPD logs. Submitted by: Anton Berezin <tobez@tobez.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-NetAddr-IP-Count/Makefile25
-rw-r--r--net/p5-NetAddr-IP-Count/distinfo1
-rw-r--r--net/p5-NetAddr-IP-Count/pkg-comment1
-rw-r--r--net/p5-NetAddr-IP-Count/pkg-descr6
-rw-r--r--net/p5-NetAddr-IP-Count/pkg-plist5
6 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1a8f85bae002..2fd97c5f6e01 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -231,6 +231,7 @@
SUBDIR += p5-Net-Whois
SUBDIR += p5-Net-ext
SUBDIR += p5-NetAddr-IP
+ SUBDIR += p5-NetAddr-IP-Count
SUBDIR += p5-PlRPC
SUBDIR += p5-SNMP
SUBDIR += p5-SNMP-Util
diff --git a/net/p5-NetAddr-IP-Count/Makefile b/net/p5-NetAddr-IP-Count/Makefile
new file mode 100644
index 000000000000..0e38f9404759
--- /dev/null
+++ b/net/p5-NetAddr-IP-Count/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: net/p5-NetAddr-IP-Count
+# Date created: 29 March 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= NetAddr-IP-Count
+PORTVERSION= 2.00
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= NetAddr
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/NetAddr/IP.pm:${PORTSDIR}/net/p5-NetAddr-IP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= NetAddr::IP::Count.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/net/p5-NetAddr-IP-Count/distinfo b/net/p5-NetAddr-IP-Count/distinfo
new file mode 100644
index 000000000000..9c30766347c6
--- /dev/null
+++ b/net/p5-NetAddr-IP-Count/distinfo
@@ -0,0 +1 @@
+MD5 (NetAddr-IP-Count-2.00.tar.gz) = c832ba5975a93f870b2dd9d65e0179ba
diff --git a/net/p5-NetAddr-IP-Count/pkg-comment b/net/p5-NetAddr-IP-Count/pkg-comment
new file mode 100644
index 000000000000..220a9d580018
--- /dev/null
+++ b/net/p5-NetAddr-IP-Count/pkg-comment
@@ -0,0 +1 @@
+NetAddr::IP::Count - Count hosts in named subnets
diff --git a/net/p5-NetAddr-IP-Count/pkg-descr b/net/p5-NetAddr-IP-Count/pkg-descr
new file mode 100644
index 000000000000..ca45e0e189a4
--- /dev/null
+++ b/net/p5-NetAddr-IP-Count/pkg-descr
@@ -0,0 +1,6 @@
+This module implements a symplistic way to match individual IP Addresses
+to subnets. It can be used to, among other things, help analyze HTTPD
+logs.
+
+-Anton
+<tobez@tobez.org>
diff --git a/net/p5-NetAddr-IP-Count/pkg-plist b/net/p5-NetAddr-IP-Count/pkg-plist
new file mode 100644
index 000000000000..2fad3dc4890f
--- /dev/null
+++ b/net/p5-NetAddr-IP-Count/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/NetAddr/IP/Count/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/NetAddr/IP/sample.pl
+lib/perl5/site_perl/%%PERL_VER%%/NetAddr/IP/Count.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/NetAddr/IP/Count
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/NetAddr/IP 2>/dev/null || true