aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-09-05 03:39:09 +0800
committermiwi <miwi@FreeBSD.org>2009-09-05 03:39:09 +0800
commit30990f33bef685aa5b172672013b6842b67ac999 (patch)
treef6d9456370eba3a1e644f6bcaf6bf717f01ba3a5 /net
parent5371771695a4a092ee3444154c984c0d4b0afbab (diff)
downloadfreebsd-ports-gnome-30990f33bef685aa5b172672013b6842b67ac999.tar.gz
freebsd-ports-gnome-30990f33bef685aa5b172672013b6842b67ac999.tar.zst
freebsd-ports-gnome-30990f33bef685aa5b172672013b6842b67ac999.zip
- Update to 1.0.4.3
PR: 138412 Submitted by: Richard <r.neese@gmail.com> (mainainer)
Diffstat (limited to 'net')
-rw-r--r--net/freeswitch/Makefile46
-rw-r--r--net/freeswitch/distinfo6
-rw-r--r--net/freeswitch/pkg-message11
-rw-r--r--net/freeswitch/pkg-plist4
4 files changed, 53 insertions, 14 deletions
diff --git a/net/freeswitch/Makefile b/net/freeswitch/Makefile
index 492f2edc6aa1..7db05c079310 100644
--- a/net/freeswitch/Makefile
+++ b/net/freeswitch/Makefile
@@ -6,24 +6,24 @@
#
PORTNAME= freeswitch
-PORTVERSION= 1.0.4.2
+PORTVERSION= 1.0.4.3
CATEGORIES= net
MASTER_SITES= http://files.freeswitch.org/:source1 \
http://dl.getdropbox.com/u/152504/:source2 \
http://www.freeswitch.org/eg/:source3
DISTNAME= ${PORTNAME}-${PORTVERSION}
DISTFILES= pizza_gram.tar.gz:source1 \
- freeswitch-1.0.4.2.tar.gz:source2 \
+ ${PORTNAME}-${PORTVERSION}.tar.gz:source2 \
pizza_sounds.tar.gz:source3 \
- freeswitch-sounds-en-us-callie-8000-1.0.11.tar.gz:source1 \
- freeswitch-sounds-en-us-callie-16000-1.0.11.tar.gz:source1 \
- freeswitch-sounds-en-us-callie-32000-1.0.11.tar.gz:source1 \
- freeswitch-sounds-en-us-callie-48000-1.0.11.tar.gz:source1 \
- freeswitch-sounds-music-8000-1.0.8.tar.gz:source1 \
- freeswitch-sounds-music-16000-1.0.8.tar.gz:source1 \
- freeswitch-sounds-music-32000-1.0.8.tar.gz:source1 \
- freeswitch-sounds-music-48000-1.0.8.tar.gz:source1
-EXTRACT_ONLY= freeswitch-1.0.4.2.tar.gz
+ ${PORTNAME}-sounds-en-us-callie-8000-1.0.11.tar.gz:source1 \
+ ${PORTNAME}-sounds-en-us-callie-16000-1.0.11.tar.gz:source1 \
+ ${PORTNAME}-sounds-en-us-callie-32000-1.0.11.tar.gz:source1 \
+ ${PORTNAME}-sounds-en-us-callie-48000-1.0.11.tar.gz:source1 \
+ ${PORTNAME}-sounds-music-8000-1.0.8.tar.gz:source1 \
+ ${PORTNAME}-sounds-music-16000-1.0.8.tar.gz:source1 \
+ ${PORTNAME}-sounds-music-32000-1.0.8.tar.gz:source1 \
+ ${PORTNAME}-sounds-music-48000-1.0.8.tar.gz:source1
+EXTRACT_ONLY= ${DISTNAME}.tar.gz
MAINTAINER= r.neese@gmail.com
COMMENT= FreeSwitch SoftSwitch Port
@@ -59,7 +59,9 @@ OPTIONS= MODSHOUT "Enable mod_shout (streaming audio/mp3)" on \
MODPOCKETSPHINX "Enable mod_pockectsphinx (voice control)" on \
MODCIDLOOKUP "Enable mod_cidlookup" on \
MODDPDIRECTORY "Enable mod_dialplan_directory" on \
+ MODDINGALING "Enable mod_dingaling(google talk)" on \
MODEASYROUTE "Enable mod_easyroute(routeing tool)" on \
+ MODERLANGEVENT "Enable mod_erlang_event (Call Center Dist)" off \
MODFAX "Enable mod_fax" on \
MODLCR "Enable mod_lcr (least cost routing)" on \
MODSOUNDTOUCH "Enable mod_soundtouch" on \
@@ -326,6 +328,18 @@ PLIST_SUB+= WITH_MODNIBBLEBILL="@comment "
PLIST_SUB+= WITH_MODNIBBLEBILL=""
.endif
+.if !defined(WITH_MODDINGALING)
+ PLIST_SUB+= WITH_MODDINGALING="@comment "
+.else
+PLIST_SUB+= WITH_MODDINGALING=""
+.endif
+
+.if !defined(WITH_MODERLANGEVENT)
+PLIST_SUB+= WITH_MODERLANGEVENT="@comment "
+.else
+PLIST_SUB+= WITH_MODERLANGEVENT=""
+.endif
+
pre-configure:
@cd ${WRKSRC} && ./bootstrap.sh
@${CP} ${WRKSRC}/build/modules.conf.in ${WRKSRC}/modules.conf
@@ -453,6 +467,14 @@ post-configure:
@${REINPLACE_CMD} -e 's|#applications/mod_nibblebill|applications/mod_nibblebill|g' ${WRKSRC}/modules.conf
.endif
+.if defined(WITH_MODDINGALING)
+ ${REINPLACE_CMD} -e 's|#endpoints/mod_dingaling|endpoints/mod_dingaling|g' ${WRKSRC}/modules.conf
+.endif
+
+.if defined(WITH_MODERLANGEVENT)
+ @${REINPLACE_CMD} -e 's|#event_handlers/mod_erlang_event|event_handlers/mod_erlang_event|g' ${WRKSRC}/modules.conf
+.endif
+
post-patch:
@${GREP} -Rl '/bin/bash' ${WRKSRC} | \
${XARGS} ${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|g'
@@ -493,6 +515,8 @@ post-install:
@${TAR} -xzvf ${DISTDIR}/pizza_sounds.tar.gz -C ${LOCALBASE}/${PORTNAME}/sounds/en/us
.endif
+ @${CAT} ${PKGMESSAGE}
+
.if ${OSVERSION} < 700000
IGNORE= it's to unsupported before FreeBSD 7.X
.endif
diff --git a/net/freeswitch/distinfo b/net/freeswitch/distinfo
index c44dcdd818f1..d3dfb3b5745e 100644
--- a/net/freeswitch/distinfo
+++ b/net/freeswitch/distinfo
@@ -1,9 +1,9 @@
MD5 (pizza_gram.tar.gz) = dc10f21c8d6bd708b7deae9f18a82b92
SHA256 (pizza_gram.tar.gz) = e713406834ba40fe07c69b84f042fcb27493c15bc6b51133418527bc7a818027
SIZE (pizza_gram.tar.gz) = 1053
-MD5 (freeswitch-1.0.4.2.tar.gz) = ce3d8e75856cb1304afba50e489f1651
-SHA256 (freeswitch-1.0.4.2.tar.gz) = f9417e557c7111a6a3f3d9c33270a34c504d8f6bb948f414b4d4274a1d73b5aa
-SIZE (freeswitch-1.0.4.2.tar.gz) = 57086208
+MD5 (freeswitch-1.0.4.3.tar.gz) = 05572d867c25b23b4dcdaae096e71cbd
+SHA256 (freeswitch-1.0.4.3.tar.gz) = 6e3adaf153d63eea7ad127978886cecc9b09d0f952675f2dccc2c12e38a2b8d2
+SIZE (freeswitch-1.0.4.3.tar.gz) = 57172620
MD5 (pizza_sounds.tar.gz) = dacfde8879da8dd0e0542069e5cba6a2
SHA256 (pizza_sounds.tar.gz) = 606f736625b7f331e219e10460029c8e0b0e58136feeddde976a0dcc68a97bef
SIZE (pizza_sounds.tar.gz) = 1498679
diff --git a/net/freeswitch/pkg-message b/net/freeswitch/pkg-message
new file mode 100644
index 000000000000..d13ca17b7876
--- /dev/null
+++ b/net/freeswitch/pkg-message
@@ -0,0 +1,11 @@
+IF you need mod_erlang_event. For right now you have to
+
+manualy install erlang-lite in /usr/ports/lang/erlang-lite.
+
+then come back to freeswitch and make the port and choose
+
+mod_erlang_event in the menu options.
+
+Once the erlang port is fixed to build with other ports this
+
+will be done automaticly.
diff --git a/net/freeswitch/pkg-plist b/net/freeswitch/pkg-plist
index c463ccd124b2..941df73f8418 100644
--- a/net/freeswitch/pkg-plist
+++ b/net/freeswitch/pkg-plist
@@ -301,12 +301,16 @@ freeswitch/mod/mod_dialplan_asterisk.so
%%WITH_MODDPDIRECTORY%%freeswitch/mod/mod_dialplan_directory.so
freeswitch/mod/mod_dialplan_xml.la
freeswitch/mod/mod_dialplan_xml.so
+%%WITH_MODDINGALING%%freeswitch/mod/mod_dingaling.la
+%%WITH_MODDINGALING%%freeswitch/mod/mod_dingaling.so
freeswitch/mod/mod_dptools.la
freeswitch/mod/mod_dptools.so
%%WITH_MODEASYROUTE%%freeswitch/mod/mod_easyroute.la
%%WITH_MODEASYROUTE%%freeswitch/mod/mod_easyroute.so
freeswitch/mod/mod_enum.la
freeswitch/mod/mod_enum.so
+%%WITH_MODERLANGEVENT%%freeswitch/mod/mod_erlang_event.la
+%%WITH_MODERLANGEVENT%%freeswitch/mod/mod_erlang_event.so
freeswitch/mod/mod_esf.la
freeswitch/mod/mod_esf.so
%%WITH_MODMULTICAST%%freeswitch/mod/mod_event_multicast.la