aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2017-08-19 18:43:06 +0800
committerkoobs <koobs@FreeBSD.org>2017-08-19 18:43:06 +0800
commit3345d2be3db70c8968a7ad92fe64c0b65b3748bd (patch)
treec1d14eacc88201d7625ee9affb4549f7bb43498a /net
parent41ddc02a6ad6508d71aca4576772fe1f38345723 (diff)
downloadfreebsd-ports-gnome-3345d2be3db70c8968a7ad92fe64c0b65b3748bd.tar.gz
freebsd-ports-gnome-3345d2be3db70c8968a7ad92fe64c0b65b3748bd.tar.zst
freebsd-ports-gnome-3345d2be3db70c8968a7ad92fe64c0b65b3748bd.zip
net/py-ldaptor: Limit to 2.7 (Does not support Python 3.x)
This port depends on Twisted, which supports Python 3.x as of a number of versions ago for some growing number of its components. On initial view, ldaptor appears inconsistent (at least not explicit) in its state of Python 3.x support for its latest version (16.0.0, not this ports version, 0.0.43) - A Python 3 compatible wheel is available on PyPI - Python 3.3-3.5 are included in tox.ini for testing However: - Travis CI configuration only tests with 2.7 - Open "Python3 support #55" upstream issue [1] Additionally, Twisted/Python3 support aside, test builds (without USES=twisted declared), results in a build error at configure time: SyntaxError: invalid syntax This change limits build support to Python 2.7 accordingly. While I'm here: - Pet portlint: LICENSE [2], PLIST_FILES, makepatch. [1] https://github.com/twisted/ldaptor/issues/55 [2] https://github.com/twisted/ldaptor/commit/7e249b1586789a5c588f662ce74ee9f4338666e0 PR: 219323 Reported by: Johannes Jost Meixner Approved by: portmgr (blanket) MFH: 2017Q3
Diffstat (limited to 'net')
-rw-r--r--net/py-ldaptor/Makefile9
-rw-r--r--net/py-ldaptor/files/patch-setup.py6
-rw-r--r--net/py-ldaptor/pkg-plist2
3 files changed, 11 insertions, 6 deletions
diff --git a/net/py-ldaptor/Makefile b/net/py-ldaptor/Makefile
index c399b16eb89a..aa4657c93a1f 100644
--- a/net/py-ldaptor/Makefile
+++ b/net/py-ldaptor/Makefile
@@ -12,15 +12,22 @@ DISTNAME= ldaptor-${PORTVERSION}-${GITVERSION}
MAINTAINER= bra@fsn.hu
COMMENT= Pure-python LDAP module for Twisted
+LICENSE= MIT LGPL21+
+LICENSE_COMB= multi
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>=0:devel/py-pyparsing \
${PYTHON_PKGNAMEPREFIX}openssl>=0:security/py-openssl
GITVERSION= aad8ded658b36337a08aeb7402b6b67eb8771bea
NO_ARCH= yes
-USES= gettext python twisted
+USES= gettext python:2.7 twisted
USE_PYTHON= distutils autoplist
+
PYDISTUTILS_INSTALL_TARGET= install_locale install
PYDISTUTILS_BUILD_TARGET= build_locale build
+PLIST_FILES= share/locale/fi/LC_MESSAGES/ldaptor-webui.mo \
+ share/locale/fr/LC_MESSAGES/ldaptor-webui.mo
+
.include <bsd.port.mk>
diff --git a/net/py-ldaptor/files/patch-setup.py b/net/py-ldaptor/files/patch-setup.py
index 758ad1db1e06..527e1b8cd536 100644
--- a/net/py-ldaptor/files/patch-setup.py
+++ b/net/py-ldaptor/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2013-12-13 13:49:46.929425897 -0200
-+++ setup.py 2013-12-13 13:49:58.999423613 -0200
-@@ -154,7 +154,6 @@
+--- setup.py.orig 2011-06-10 07:02:47 UTC
++++ setup.py
+@@ -154,7 +154,6 @@ from the command line.
'build_locale': build_locale,
'clean': clean,
'clean_locale': clean_locale,
diff --git a/net/py-ldaptor/pkg-plist b/net/py-ldaptor/pkg-plist
deleted file mode 100644
index e1c04709e421..000000000000
--- a/net/py-ldaptor/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-share/locale/fi/LC_MESSAGES/ldaptor-webui.mo
-share/locale/fr/LC_MESSAGES/ldaptor-webui.mo